zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > (X)HTML
Seite neu laden Komischer Rahmen bei einem Bild

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 19.06.2021, 09:35
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 18.06.2021
Beiträge: 3
Web-Schneiderin befindet sich auf einem aufstrebenden Ast
Standard Komischer Rahmen bei einem Bild

Guten Tag

Ich bin ganz neu hier und auch neu in Sachen HTML / CSS. Ich arbeite mit WordPress und dem Pagebuilder Beaver Builder. Nun habe ich einen Kundenauftrag, bei welchem ich für die Umsetzung HTML / CSS brauche.

Ich habe ein Bild, welches bei Hover eine blaue Farbe annehmen soll und beim Klicken dann zu einer Marke weiter unten springt. Das funktioniert alles. Nur hat es da einen seltsamen hellgrauen Rahmen um das Bild, den ich nicht wegbekomme.

Ich habe alles in einen HTML-Code gepackt, weil ich das im Internet so gefunden und wie gesagt selber noch keine Ahnung habe. Vermutlich müsste da noch einiges optimiert werden. Für mich war die Freude schon gross, dass es überhaupt funktioniert... Gerne lasse ich mich belehren, was ich anders machen soll.

Hier der HTML-Code:
HTML-Code:
<!DOCTYPE html>
<html >
<head>
  <style type="text/css">
    .imgBox
    {
      width: 84px;
      height: 60px;
      background: url(https://orbit1.web-testumgebung.ch/wp-content/uploads/2021/05/freiheit-schwarz.svg) no-repeat;
    }
    .imgBox:hover {
      width: 84px;
      height: 60px;
      background: url(https://orbit1.web-testumgebung.ch/wp-content/uploads/2021/06/Symbol-Freiheit-overroll.png) no-repeat;
    }
  </style>
</head>
<body>
<center>
  <div class="imgBox">
      <a href="#dominique"><img class="imgBox"></a>
  </div>
</center>
</body>
</html>
Und hier der Link zur Testseite: Das Problem ist inzwischen gelöst, daher habe ich den Link entfernt.

Ich bedanke mich schon jetzt für eure Hilfe!
LG
tanja

Geändert von Web-Schneiderin (19.06.2021 um 15:25 Uhr)
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 19.06.2021, 10:14
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 23.01.2018
Beiträge: 170
basti1012 befindet sich auf einem aufstrebenden Ast
Standard

Das Passwort geht nicht.
Ist das alles an Code, was du da gepostet hast?
Da kann ich nix hellgraues sehen und die Funktion die beim klick aufs Bild kommen soll sehe ich in den Code auch nicht, da fehlt doch was?

Gebe uns mal das richtige Passwort dann kann man das mal in Live sehen was du meinst

Geändert von basti1012 (19.06.2021 um 10:22 Uhr)
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 19.06.2021, 10:25
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 18.06.2021
Beiträge: 3
Web-Schneiderin befindet sich auf einem aufstrebenden Ast
Standard

sorry, da war noch ein Generalpasswort drin. Jetzt sollte es gehen.
Ja das ist alles an Code, ich habe sonst nirgends was eingestellt (wüsste auch gar nicht wo ).

Danke!
Mit Zitat antworten
  #4 (permalink)  
Alt 19.06.2021, 10:35
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 23.01.2018
Beiträge: 170
basti1012 befindet sich auf einem aufstrebenden Ast
Standard

Ich würde das
HTML-Code:
<img class="imgBox">
erstmal so ändern,( dann sollte das Problem auch weg sein )
HTML-Code:
<div class="imgBox"></div>
Ein Img ein Background Bild zugeben finde ich falsch.Ob das erlaubt ist weiß ich auch nicht.

Dein <center> ist auch veraltet und wird so auch nicht mehr verwendet

Geändert von basti1012 (19.06.2021 um 10:43 Uhr)
Mit Zitat antworten
  #5 (permalink)  
Alt 19.06.2021, 10:46
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 18.06.2021
Beiträge: 3
Web-Schneiderin befindet sich auf einem aufstrebenden Ast
Standard

Wow, vielen Dank, das hat funktioniert!

Wie finde ich denn heraus, was «erlaubt» ist? Ich war immer der Meinung, wenn es funktioniert ist gut...

Könnte das der Grund sein, weshalb das Bild (schwarz) etwas ausgefranst wirkt, obwohl es eine svg-Grafik ist?
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Komischer blauer Rahmen um mein Bild ohne Link vipro CSS 3 01.05.2009 18:15
Bild mit Rahmen aus Bild Holger (HMR) CSS 3 21.05.2008 12:55
Verflixter Rahmen um ein Bild Webelix CSS 6 22.07.2007 12:32
Rahmen mit Abstand um ein Bild butterhead CSS 11 07.12.2005 17:48
Rahmen um ein Bild (jpg, png, gif) ziehen Don Stefano CSS 8 30.07.2005 21:42


Alle Zeitangaben in WEZ +2. Es ist jetzt 02:49 Uhr.