zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Safari spielt mp4 Video nicht

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 20.08.2018, 16:10
wtj wtj ist offline
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.08.2018
Beiträge: 6
wtj befindet sich auf einem aufstrebenden Ast
Standard Safari spielt mp4 Video nicht

Hallo liebe Forums-Mitglieder,
leider habe ich im Forum keine ähnliche Fragestellung gefunden, ich würde mich über einen Lösungsansatz für folgende Problematik freuen:
Ich habe eine Webseite programmiert in der ein Video eingebettet ist, welches automatisch beim Öffnen der entsprechenden Seite startet.
Das Video liegt als mp4-Datei vor und ist per <video> direkt als Datei eingebunden (also nicht über einen player) und startet automatisch als videoloop.
Die Seite habe ich zunächst auf einem Test-Space online gestellt, da lief alles wunderbar.
Auf der eigentlichen Webseite startet es nun plötzlich in (auf?) Safari nicht mehr, auf Firefox und Chrome läuft es.
Ich habe alternativ auch noch eine m4v-Datei hinterlegt, das bringt allerdings auch kein Ergebnis.
Ich hoffe es weiß jemand Rat?

PS: lokal läuft auf Safari alles wunderbar, daher weiß ich mir gerade keinen Rat wie ich das auch online zum laufen bringen kann.
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 20.08.2018, 16:14
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.887
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Zuerst mal, wieso kommst du auf die Idee, dass es was mit CSS zu tun hat?

So wie du es beschreibst ist es wohl eher ein Problem in der Serverkonfiguration. Hast du dir mal den Header der mp4 Datei in den Developer Tools deines Browser angeschaut?
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 20.08.2018, 16:24
wtj wtj ist offline
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.08.2018
Beiträge: 6
wtj befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von protonenbeschleuniger Beitrag anzeigen
Zuerst mal, wieso kommst du auf die Idee, dass es was mit CSS zu tun hat?
...wenn man nicht weiß wo das Problem liegt kann man natürlich nur raten mit was es zu tun hat...

Zitat:
Zitat von protonenbeschleuniger Beitrag anzeigen
So wie du es beschreibst ist es wohl eher ein Problem in der Serverkonfiguration. Hast du dir mal den Header der mp4 Datei in den Developer Tools deines Browser angeschaut?
Das klingt nach einem schlauen Ansatz, habe ich bisher nicht. Wie mache ich das?
Mit Zitat antworten
  #4 (permalink)  
Alt 20.08.2018, 16:49
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.887
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Zitat:
Zitat von wtj Beitrag anzeigen
Das klingt nach einem schlauen Ansatz, habe ich bisher nicht. Wie mache ich das?
Naja, du musst erstmal Wissen welchen Browser du verwendest und wo du die Developer Tools dort findest. Dann startest du es und aktivierst die Netzwerktools, dann öffnest du die Seite und siehst in der Liste der anzeigten Dateien das video, dort gibt es den Reiter Kopfzeile/Header und dort kannst du sehen welche Attribute vom Server gesendet wurden. diese sind relevant dafür ob und wie eine Datei angezeigt wird.
Mit Zitat antworten
  #5 (permalink)  
Alt 20.08.2018, 17:59
wtj wtj ist offline
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.08.2018
Beiträge: 6
wtj befindet sich auf einem aufstrebenden Ast
Standard

Dann sehe ich folgendes:

Übersicht
URL: (Seitenname/ Dateiname, lasse ich mal weg)
Status: 206 Partial Content
Quelle: Netzwerk

Anfrage
Range: bytes=47714471-134810494
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1 Safari/605.1.15
Accept: */*
Connection: Keep-Alive
Accept-Encoding: identity
Referer: (Seitenname, lasse ich mal weg)
X-Playback-Session-Id: 21922C67-27F2-4001-B7EE-EDDE7323BB4C

Antwort
ETag: "8090b7f-573dcc4893837"
Content-Type: video/mp4
Date: Mon, 20 Aug 2018 14:55:53 GMT
Last-Modified: Mon, 20 Aug 2018 12:08:30 GMT
Server: Apache
Content-Length: 87096024
Connection: keep-alive
Content-Range: bytes 47714471-134810494/134810495
Accept-Ranges: bytes
Keep-Alive: timeout=15
Mit Zitat antworten
  #6 (permalink)  
Alt 20.08.2018, 18:08
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.887
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

in der version wo das video angezeigt wird oder da wo es nicht angezeigt wird?
Im Grunde ist die Frage, gibt es da einen Unterschied?
Mit Zitat antworten
  #7 (permalink)  
Alt 20.08.2018, 18:14
wtj wtj ist offline
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.08.2018
Beiträge: 6
wtj befindet sich auf einem aufstrebenden Ast
Standard

Die Daten sind aus den Safari Tools, wo es nicht angezeigt wird.
Mit Zitat antworten
  #8 (permalink)  
Alt 20.08.2018, 18:25
wtj wtj ist offline
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.08.2018
Beiträge: 6
wtj befindet sich auf einem aufstrebenden Ast
Standard

Firefox (wo es läuft) zeigt in den meisten Punkten das gleiche, Abweichungen gibt es wenn ich das richtig überblicke hier:

Content-Length: 119636103 // 87096024
Content-Range: bytes 15174392-134810494/134810495 // bytes 47714471-134810494/134810495
Range: bytes=15174392- // bytes=47714471-134810494

(Angaben von Safari Invers)
Leider sagt mir das alles nichts...
Mit Zitat antworten
  #9 (permalink)  
Alt 20.08.2018, 19:31
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.887
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Relevant wäre hier der Content-Type

wenn es da keinen Unterschied gibt, dann gibt es so erstmal keine Erklärung für das unterschiedliche Verhalten.

Wobei ich gerade sehe, dir geht es nur um das automatische starten?
Das ist zwar auch kein CSS Problem, aber es könnte am HTML Code liegen. wie bindest du das video denn ein?
Mit Zitat antworten
Sponsored Links
  #10 (permalink)  
Alt 20.08.2018, 19:39
wtj wtj ist offline
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.08.2018
Beiträge: 6
wtj befindet sich auf einem aufstrebenden Ast
Standard

Update: ich glaube ich habe das Problem gefunden, es liegt vermutlich weder an der Videodatei noch an meinen Programmierkünsten, sondern offenbar daran, dass Safari standartmäßig die automatische Wiedergabe blockt: https://support.apple.com/de-de/guid...rw29c6ecf8/mac

Jedenfalls läuft das Video wenn ich Safari entsprechend einstelle.
Mit Zitat antworten
Sponsored Links
Antwort

Stichwörter
mp4, safari

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Video soll nur abspielen, wenn DIV eingeblendet ist Fanello Javascript & Ajax 2 05.06.2018 10:43
Width - mp4 video crop / video breiter als screen groesse jandes CSS 10 01.02.2017 16:39
MP4 im Internet Explorer 11 abspielen Handle3000 (X)HTML 1 16.02.2016 11:29
Safari 5 (PC) & Video-Element 1chris (X)HTML 0 10.09.2010 12:51
3 Column Float IE,FF,Opera hui, Safari, Konq. Pfui.... dablake CSS 5 29.05.2005 19:43


Alle Zeitangaben in WEZ +2. Es ist jetzt 10:09 Uhr.