zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > (X)HTML
Seite neu laden Problem mit jQuery und DIV

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 24.04.2015, 16:41
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 13.03.2015
Beiträge: 9
BR1977 befindet sich auf einem aufstrebenden Ast
Standard Problem mit jQuery und DIV

Der Div bleibt sichtbar trotz jQuery code.
Ich sehe die Lösung nicht...

<!DOCTYPE html>
<html dir="ltr" lang="de"><head>
<meta charset="utf-8">
<title></title>
<meta name="viewport" content="initial-scale = 1.0, maximum-scale = 1.0, user-scalable = no, width = device-width">

<!--[if lt IE 9]><script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<link rel="stylesheet" href="style.css" media="screen">
<!--[if lte IE 7]><link rel="stylesheet" href="style.ie7.css" media="screen" /><![endif]-->
<link rel="stylesheet" href="style.responsive.css" media="all">

<link rel="shortcut icon" href="favicon.ico" type="image/x-icon">
<script src="jquery.js"></script>
<script src="script.js"></script>
<script src="script.responsive.js"></script>
<script>
$("#hiddendiv1").hide();
$("a").on("click", function(e){
e.preventDefault();
$("#hiddendiv1").toggle();
});
</script>

</head>
<body>

<div id="art-main">


<div id="inhalte_uebersicht">

<table border=0 cellpadding="10">
<td colspan="2" valign="top">
<img src="images/service.jpg"></img>
</td>
<td valign="top">
<span style="font-weight: bold;">zertifiziert in:</span>
<br><br>
<a href="#"><img src="images/zert1_kl.jpg"></img></a>
<div id="hiddendiv1"></div>

</td>
</table>
...
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 25.04.2015, 14:16
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 13.03.2015
Beiträge: 9
BR1977 befindet sich auf einem aufstrebenden Ast
Standard

Ach, vermutlich muss das </a> closing tag hinter das </div>. Ich denke das müsste die Lösung sein, probiere es später mal aus.
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 26.04.2015, 19:40
Benutzerbild von Thielo
Web Ninja
XHTMLforum-Kenner
 
Registriert seit: 17.09.2009
Ort: Stuttgart oder so
Beiträge: 3.373
Thielo ist ein LichtblickThielo ist ein LichtblickThielo ist ein LichtblickThielo ist ein LichtblickThielo ist ein LichtblickThielo ist ein Lichtblick
Standard

Bei mir funktioniert es. Aber das Image-Tag ist selbstschießend
__________________
Hier ein immer gültiges Statement: Überarbeite deine Code, lerne die Grundlagen, widersprich mir nicht, wehre dich nicht, ich habe Recht, wir sind Lolgion, wir sind viele.. potato...
All meine Angaben sind ohne Gewähr, es könnte also trotz meiner Unfehlbarkeit dazu kommen dass ich falsch liege

www.richard-thiel.de | Müssen Websiten überall gleich ausschauen?
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Fragen zu CSS und Joomla DOKTOR CSS 2 23.05.2011 20:29
DIV Problem darnia CSS 1 01.04.2011 12:54
Jquery Load Div Problem / Css Style wird nicht erkannt mastaa Javascript & Ajax 5 16.03.2011 18:50
Problem mit Backround in einem aufgespannten DIV marius-schneider CSS 0 27.03.2009 12:50
Problem mit CSS-Layout: Div "springt" im IE Andrzew CSS 2 15.03.2006 17:18


Alle Zeitangaben in WEZ +2. Es ist jetzt 03:13 Uhr.