zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Problem mit men

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 20.03.2014, 18:52
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.03.2014
Beiträge: 13
Spike1977 befindet sich auf einem aufstrebenden Ast
Standard Problem mit men

Ich will das am ende des Menüs ganz unten das Bild mit dem Rand des Menüs abschließt
und kein platz darunter mehr ist.

Code:
Menü code:

  ...
  ...
 <li class='last'><a href='#' target='_self'>
  <span>
     <img src="fussbild.jpg" border="0" width="xxx" height="xxx">
  </span></a></li>
Was muss ich in der styles.css noch dazu schreiben damit es so aussieht wie oben beschrieben?

Bild:
__________________
Hauptsache die Haare liegen!
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 20.03.2014, 19:23
Neuer Benutzer
neuer user
 
Registriert seit: 17.02.2013
Ort: Heidelberg
Beiträge: 19
SansArt befindet sich auf einem aufstrebenden Ast
Standard

Sorry aber aus dem Code-Schnipsel, dem Bild und deiner Beschreibung wird glaube ich niemand schlau genug um ne hilfreiche antowrt zu geben. Schick und doch mal nen Link zur Seite und beschreib nochmal genau was du willst
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 20.03.2014, 19:56
Benutzerbild von etux
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 17.09.2007
Ort: Berlin
Beiträge: 643
etux wird schon bald berühmt werden
Standard

Zitat:
Zitat von SansArt Beitrag anzeigen
Schick und doch mal nen Link zur Seite und beschreib nochmal genau was du willst
Volle Zustimmung - so sollte am besten eine Frage gestellt werden.

Kristallkugel sagt:
.last img { vertical-align: bottom; }

oder, wenn es die restliche CSS-Formatierung zulässt:
.last img { display: block; }
oder
.last img { float: left; }
da Float den betroffenen Elementen (hier dem Bild) Block-Eigenschaften verleiht.

DOCTYPE-Switch: Unerklärliche Lücken zwischen Elementen
__________________
Grüße: Emil
--------------------------------------
https://emil-webdesign.net/

Geändert von etux (20.03.2014 um 20:02 Uhr) Grund: Link zum Lesestoff zugefügt
Mit Zitat antworten
  #4 (permalink)  
Alt 20.03.2014, 21:03
?!?
XHTMLforum-Kenner
 
Registriert seit: 20.03.2013
Beiträge: 1.638
explanator sorgt für eine eindrucksvolle Atmosphäreexplanator sorgt für eine eindrucksvolle Atmosphäre
Standard

HTML-Code:
<span>
     <img src="fussbild.jpg" border="0" width="xxx" height="xxx">
  </span>
Das span um das Element Img ist unnötig, das kanst du problemlos weglassen.
Das Attribut border beim Img ist veraltet, verwende CSS stattdessen.
Im Img-Element fehlt das Attribut Alt.

So wenig hast du uns gezeigt und so viele Fehler, den Rest wollen wir wohl erst sehen, wenn deine Seite den W3C Validator-Test mit bravur bestanden hat.
__________________
"Wieso ist der Code schrott, ich dachte hier seien Profis..."
Aus einem Forum.
Mit Zitat antworten
  #5 (permalink)  
Alt 20.03.2014, 22:23
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.03.2014
Beiträge: 13
Spike1977 befindet sich auf einem aufstrebenden Ast
Standard

Also der html code:
<li class='last'><a href='#' target='_self'><span><img src="hp-pics/menu-fuss.jpg" border="0" width="246" height="97"></span></a></li>

der css code:
#cssmenu ul ul li.last a {
display: bottom;
}


der blöde rand da unten soll weg
__________________
Hauptsache die Haare liegen!

Geändert von Spike1977 (20.03.2014 um 22:33 Uhr)
Mit Zitat antworten
  #6 (permalink)  
Alt 20.03.2014, 22:40
Neuer Benutzer
neuer user
 
Registriert seit: 17.02.2013
Ort: Heidelberg
Beiträge: 19
SansArt befindet sich auf einem aufstrebenden Ast
Standard

(Bitte Code Tags benutzen)

Also erstmal den span und das target=_self weg, ersteres ist einfach überflüssig, letzteres die default einstellung von target.

HTML-Code:
<li class='last'>
<a href='#'><img src="hp-pics/menu-fuss.jpg" border="0" width="246" height="97"></a>
</li>
So. Jetzt guck ich mir dein Bild an, bei dem ich nur mutmaßen kann was da was ist. Laut deinem HTML müsste da ein Bild sein das bedeutend breiter als hoch ist, auf deinem BIld ist das Bild aber höher als breit, mindestens jedoch quadratisch.

Code:
#cssmenu ul ul li.last a {
display: bottom;
}
Daaaaas ist jetzt mehr als nichtssagend. display definiert wie ein Element angezeigt wird. Es hat kein Attribut "bottom". dein gezeigter code hat einfluss auf die klasse "a" die von (!!!!!) 5 Überklassen/ids erbt. dein Fehler kann aus all diesen resultieren.

Wir wollen dir wirklich helfen, aber mit sowenig Informationen ist uns das einfach nicht möglich. Was spricht denn dagegen einfach mal deine HP hier zu verlinken damit wir sie inspizieren können. Ich mache das auch wenn ich Probleme habe, und lösche anschließend den Link einfach wieder, sobald mein Problem gelöst ist

Gruß
Sans
Mit Zitat antworten
  #7 (permalink)  
Alt 26.03.2014, 12:46
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 20.03.2014
Beiträge: 13
Spike1977 befindet sich auf einem aufstrebenden Ast
Böse

Ich versuche es mal so.
Auf der site MyVideo sieht es so aus wie ich es haben will.

Bild:



Mein code:
PHP-Code:
// H T M L    D a t e i
  
...
  <
li class='last'><a href='#' target='_self'><img width="146" height="97" alt="" src="hp-pics/menu-fuss.jpg"></img></a></li>
 </
ul>
</
li>

// C S S     D a t e i
#cssmenu ul ul li.last img {
        
vertical-alignbottom;

Und es geht nicht...
__________________
Hauptsache die Haare liegen!
Mit Zitat antworten
  #8 (permalink)  
Alt 26.03.2014, 12:58
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 30.01.2014
Beiträge: 2.207
cloned ist ein wunderbarer Anblickcloned ist ein wunderbarer Anblickcloned ist ein wunderbarer Anblickcloned ist ein wunderbarer Anblickcloned ist ein wunderbarer Anblickcloned ist ein wunderbarer Anblickcloned ist ein wunderbarer Anblick
Standard

Liest man sich die Definition von vertical-align durch wird einem auch sofort klar, warum es nicht klappt:
die vertikale Ausrichtung von Text in einer Zeile, bezogen auf das Elternelement, das ein Inline-Element sein muß [...] - nicht aber die vertikale Positionierung in einem Blockelement
Dein Elternelement ist das a und an dem orientiert sich dein Bild, deine Liste hat hier keinen Einfluss. Du wirst deinem Link wohl als Blockelement definieren müssen und zusätzlich margin/padding Eigenschaften entfernen um dein Ziel zu erreichen.
Mit Zitat antworten
  #9 (permalink)  
Alt 26.03.2014, 13:10
Benutzerbild von Thielo
Web Ninja
XHTMLforum-Kenner
 
Registriert seit: 17.09.2009
Ort: Stuttgart oder so
Beiträge: 3.373
Thielo ist ein LichtblickThielo ist ein LichtblickThielo ist ein LichtblickThielo ist ein LichtblickThielo ist ein LichtblickThielo ist ein Lichtblick
Standard

Zitat:
Zitat von Spike1977 Beitrag anzeigen
Ich versuche es mal so.
Auf der site MyVideo sieht es so aus wie ich es haben will.
Gut und keiner weiß wie das, was du da hast aussieht. Hast du dir mal das gesamte CSS von MyVideo angesehen? So Stichwort, Zeilenhöhe, Display etc.?

Aber nein, es ist wohl immernoch einfacher keinen Link zu zeigen, warum auch immer (es gibt keinen Grund das zu rechtfertigen)
__________________
Hier ein immer gültiges Statement: Überarbeite deine Code, lerne die Grundlagen, widersprich mir nicht, wehre dich nicht, ich habe Recht, wir sind Lolgion, wir sind viele.. potato...
All meine Angaben sind ohne Gewähr, es könnte also trotz meiner Unfehlbarkeit dazu kommen dass ich falsch liege

www.richard-thiel.de | Müssen Websiten überall gleich ausschauen?
Mit Zitat antworten
Sponsored Links
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Font der Überschrift ändern (Problem) artist CSS 2 07.12.2007 10:01
Design zu CSS/HTML verarbeiten - Problem häufen sich. Grafikamateur CSS 2 06.08.2007 09:57
Problem mit WordPress und dem Bilder Upload Maxefix Serveradministration und serverseitige Scripte 0 19.12.2006 14:58
Problem bei Div's - zwei mal das gleiche und doch nicht ... Niriel CSS 10 09.06.2005 17:39
Problem mit einem CSS Layout nARC CSS 20 21.05.2005 06:28


Alle Zeitangaben in WEZ +2. Es ist jetzt 06:54 Uhr.