zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Bilder werden von IE7 lokal nicht geladen

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 17.12.2012, 10:46
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 01.09.2009
Beiträge: 16
DasGrussel befindet sich auf einem aufstrebenden Ast
Standard Bilder werden von IE7 lokal nicht geladen

Hallo, liebe Forengemeinde,

ich habe ein seltenes Problem, was ich zwar ein paar Mal im Internet gefunden habe, aber nie mit Lösung...

Grobe Beschreibung
Wir machen für einen Kunden eine Art Mini-Intranet, welches lokal von einer Netzwerkfestplatte dort läuft, quasi nur eine lokale Website. In der gesamten Firma laufen die Rechner mit Windows XP und Internet Explorer 7. An diesen Fakten kann ich nichts ändern, der Kunde lässt sich auf nichts anderes ein.
Und jetzt das Problem: Beim Laden der Seiten werden nicht alle Grafiken angezeigt, der IE sagt uenendlich lange, die Grafiken würden noch geladen, aber es passiert nichts. Das passiert nur, solange die Seite inkl. Bilder nur lokal bei mir liegt. Sobald ich das Ganze auf einen Server ins Internet hochlade, funktioniert alles. Aber das geht hier ja nicht.

Websites, die sich mit diesem Problem beschäftigen
Microsoft - leider hat dieser Lösungsvorschlag nichts gebracht
PC Tipp - auch hier wird auf den Cache eingegangen - das löst es bei mir nicht
SelfHTML-Board: Das sieht auch nach meinem Problem aus
Bezieht sich zwar auf irgendeinen Webeditor, Problem scheint aber dasselbe zu sein
Hier klingt es so, als hätte es was mit den PNGs zutun...
Selbes Problem, wieder keine Lösung



Fragen an euch
  • Da es ja anscheinend irgendetwas damit zutun hat, dass die Daten lokal geladen werden und nicht von einem Server: Kann man das irgendwie simulieren, dass der IE denkt, es käme von einem Server und es entsprechend behandelt?
  • Kennt jemand das Problem bzw. vielleicht sogar eine Lösung?
  • Irgendwelche Ansätze? Ich probiere jetzt gerade damit rum, die PNGs zu ersetzen, was aufgrund von Transparenzen teilweise problematisch ist...

Danke im Voraus und wenn es noch irgendwelche Fragen gibt: Immer raus damit! Ich beschäftigte mich jetzt mal mit den PNGs...

Geändert von DasGrussel (17.12.2012 um 12:29 Uhr)
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 17.12.2012, 11:43
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.913
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Was heißt denn lokal? Per http oder file?
Stimmen die Verzeichnisse?
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 17.12.2012, 11:51
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 01.09.2009
Beiträge: 16
DasGrussel befindet sich auf einem aufstrebenden Ast
Standard

Per File, ich öffne die Datei einfach über den Dateidialog im Internet Explorer.

Ich bin inzwischen auch schon ein bisschen weiter, ich habe das Gefühl, es liegt an der Datei "kasten_weiss_hintergrund_oben.png". Ich werde sie jetzt einfach mal neu abspeichern, vielleicht gab es da ja ein Problem.

Die Verzeichnisse sind alle korrekt, Firefox, Chrome und der IE ab Version 9 haben keinerlei Probleme.
Mit Zitat antworten
  #4 (permalink)  
Alt 17.12.2012, 12:23
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.913
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Zitat:
Zitat von DasGrussel Beitrag anzeigen
Ich bin inzwischen auch schon ein bisschen weiter, ich habe das Gefühl, es liegt an der Datei "kasten_weiss_hintergrund_oben.png". Ich werde sie jetzt einfach mal neu abspeichern, vielleicht gab es da ja ein Problem.
das heißt, wenn du die Datei alleine anzeigen läßt, wird sie auch nicht dargestellt?
Mit Zitat antworten
  #5 (permalink)  
Alt 17.12.2012, 12:28
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 01.09.2009
Beiträge: 16
DasGrussel befindet sich auf einem aufstrebenden Ast
Standard

Ich fasse es nicht, wirklich.

Ich arbeite an diesem Problem jetzt seit Freitag Morgen und habe so viele Beiträge im Internet gelesen, so viele Sachen ausprobiert.

Und jetzt liegt das alles daran, dass diese eine PNG defekt ist. Ich weiß nicht, wieso, aber sie lässt sich auch in Photoshop nicht mehr öffnen. Evtl. ist irgendwas beim Abspeichern oder Kopieren schiefgegangen - sie ist aber nach wie vor so intakt, dass alle anderen Browser mit ihr umgehen können.

Aber das Problem ist gelöst - es lag tatsächlich an der Datei. Was ich überhaupt nicht verstehe ist, dass der Internet Explorer aber damit klarkommt, wenn die Datei hochgeladen wird.. außer das FTP-Programm repariert irgendwie die Datei, schreibt einen vollständigen Header oder sowas...

Dann können wir diesen Thread hier schließen und wenn irgendjemand irgendwann auch wieder das Problem hat, dann findet er so vielleicht schneller die Ursache bzw. die Lösung

ich bin begeistert!

Und natürlich danke an dich, protonenbeschleuniger, dass du dich meinem Problem angenommen hast!

Geändert von DasGrussel (17.12.2012 um 12:30 Uhr)
Mit Zitat antworten
  #6 (permalink)  
Alt 17.12.2012, 13:48
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.913
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Zitat:
Zitat von DasGrussel Beitrag anzeigen
Und jetzt liegt das alles daran, dass diese eine PNG defekt ist. Ich weiß nicht, wieso, aber sie lässt sich auch in Photoshop nicht mehr öffnen. Evtl. ist irgendwas beim Abspeichern oder Kopieren schiefgegangen - sie ist aber nach wie vor so intakt, dass alle anderen Browser mit ihr umgehen können.
Also ob Photoshop das "Topprogramm" zum bearbeiten von png Bildern ist, weiß ich nicht (Bei Bildproblemen bevorzuge ich Programme, die auf das anzeigen von vielen Formaten spezialisiert sind. unter Windows z.b. Irfanview) . Mich hätte halt erstmal interessiert, wie die Antwort auf meine Frage lautet. also ob der IE das Bild an sich anzeigt.
Der nächste Schritt wäre gewesen sich die Bildinformation z.b. im Firefox anzeigen zu lassen. Und dann eben sich mal den HTTP Header, vom Server wo es funktioniert, ausgeben zu lassen.

Zitat:
Zitat von DasGrussel Beitrag anzeigen
Was ich überhaupt nicht verstehe ist, dass der Internet Explorer aber damit klarkommt, wenn die Datei hochgeladen wird.. außer das FTP-Programm repariert irgendwie die Datei, schreibt einen vollständigen Header oder sowas...
Nein, ein Server sendet einen Header. U.u. lag es daran.
Mit Zitat antworten
  #7 (permalink)  
Alt 17.12.2012, 13:53
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 01.09.2009
Beiträge: 16
DasGrussel befindet sich auf einem aufstrebenden Ast
Standard

Naja, die Grafik ist ja in Photoshop entstanden, daher war das meine erste Wahl, es auch wieder darin öffnen zu wollen.

Habe es getestet, die Datei lässt sich auch nicht vom IE direkt öffnen.

Als ich den Thread eröffnete, hatte ich ja schon lauter Sachen getestet, war aber noch nicht so weit, diese PNG dafür verantwortlich zu machen.

Das mit dem Server ist ja interessant, das erklärt einiges.
Mit Zitat antworten
  #8 (permalink)  
Alt 17.12.2012, 14:05
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.913
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Zitat:
Zitat von DasGrussel Beitrag anzeigen
Habe es getestet, die Datei lässt sich auch nicht vom IE direkt öffnen.

[....]

Das mit dem Server ist ja interessant, das erklärt einiges.
Nicht unbedingt.

Ein bisschen ratlos hinterläßt du mich schon. Dass eine Bilddatei ohne HTTP-Header nicht angezeigt wird, aber mit schon, ist zumindest seltsam. Aber da der IE an sich Probleme mit png Dateien hat, liegt es wohl daran.
Mit Zitat antworten
  #9 (permalink)  
Alt 17.12.2012, 14:14
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 01.09.2009
Beiträge: 16
DasGrussel befindet sich auf einem aufstrebenden Ast
Standard

Ich habe mich in Bezug auf den IE schon daran gewöhnt, dass da grundsätzlich alles passieren kann und man nicht immer weiß, warum.

Der Fehler liegt diesmal ja eigentlich nicht im IE, aber die Frage ist trotzdem, warum die Windows- und Macbildvorschau, sowie sämtliche Browser mit der Datei umgehen können, nur eben nicht der IE7 und Photoshop

Habe jetzt noch eine Theorie:
Die Datei war zwar als PNG abgespeichert, war aber eigentlich ne JPG - das ist mir mit dem "Für Web speichern"-Dialog schon ein paar Mal passiert... da reagiert der Photoshop auch immer allergisch drauf, wenn man das dann wieder öffnen will.
Mit Zitat antworten
Sponsored Links
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Hintergrund wird nicht angezeigt maxx CSS 6 14.10.2012 18:27
Hilfe!!! mein Homepagelayout funktioniert nicht! maxx CSS 5 14.10.2012 07:21
Schriftart wird in IE7 nicht geladen Eppi CSS 4 07.07.2011 09:59
Wann in CSS verlinkte Bilder wirklich geladen werden Pablo CSS 1 07.12.2007 20:27


Alle Zeitangaben in WEZ +2. Es ist jetzt 15:36 Uhr.