zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Server (online) vs. Editor (offline) Darstellung

Antwort
 
LinkBack Themen-Optionen Ansicht
  #21 (permalink)  
Alt 25.11.2012, 22:12
Benutzerbild von fox
fox fox ist offline
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 11.09.2006
Beiträge: 1.011
fox sorgt für eine eindrucksvolle Atmosphärefox sorgt für eine eindrucksvolle Atmosphäre
Standard

Da hast du wieder diese Proxy-Adresse drin, außerdem ist der ganze Whitespace entfernt.

Du gehst per T-Mobile online?

Speedmanager - Smartphone/Laptop | Telekom
Wie genau du das deaktivieren kannst, kann ich da jetzt nicht rauslesen. Das müsstest du selbst suchen.

Natürlich darf das trotzdem nicht sein, dass das Layout dadurch zerlegt wird.
__________________
:)
Mit Zitat antworten
Sponsored Links
  #22 (permalink)  
Alt 25.11.2012, 22:18
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.779
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Danke. Das ist hart.
Für etliche Layoutmethoden, für die der Whitespace eine Rolle spielt ist das tödlich. Wahrscheinlich erzählt man dir aber, dass die Komprimierung die Darstellung von Webseiten nicht beeinflusst ...
Wobei ich mir gerne mal erklären lassen würde, inwiefern das Einbinden von externen Stylesheets (und vermutlich auch Scripten) ins Html einen Gewinn für den mobilen Surfer darstellt. Damit wird das Caching kaputtgemacht.

[Irgendwie seh ich da immer noch (oder schon wieder?) diese Validator-Bildchen ...]

edit: fox, ich hatte ja um genau diesen Code gebeten.
edit2:
Zitat:
Zitat von Speedmanager
die optische Darstellung wird nicht verändert.
*g*

Geändert von fricca (25.11.2012 um 22:23 Uhr)
Mit Zitat antworten
Sponsored Links
  #23 (permalink)  
Alt 25.11.2012, 22:24
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.09.2012
Beiträge: 50
<--steph--> befindet sich auf einem aufstrebenden Ast
Standard

@ fox

Das mit den proxy adressen kommt automatisch sobald die html datei am server liegt, erstellt lautet der code so

HTML-Code:
<img src="spanien3.1.jpg" alt="image"/>
Was du mit dem whitespace meinst verstehe ich nicht und ja ich bin mit den web n walk router III online.

@fricca

ja, werde mir das morgen mit der Komprimierung erklären lassen. Habe heute schon gesucht, die Seite von Fox ist in Ö nicht zielführend. Leider gehts das ganze aber über den technischen Support 0,88 € / Minute. Und in der Router Einstellung habe ich auch nicht so einen Menüpunkt "Speedmanager" gefunden.

Etwas könnte mir noch helfen: Wie soll die Frage an den technik - support eurer Meinung nach lauten?
Mit Zitat antworten
  #24 (permalink)  
Alt 25.11.2012, 22:32
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.779
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Zitat:
Was du mit dem whitespace meinst verstehe ich nicht
Leerzeichen. Die sind weg, deshalb funktioniert der "Blocksatz" nicht mehr.

Zitat:
Und in der Router Einstellung habe ich auch nicht so einen Menüpunkt "Speedmanager" gefunden.
Das ist in dem Fall einfach eine Website, die du aufrufen musst.
Speedmanager - per Handy | Telekom
Da steht die Adresse. Schau dich mal bei deinem Anbieter um.

Ansonsten frag den Support, wie du die Komprimierung abschalten kannst.
Dass die Darstellung verändert wird kannst du Ihnen ja an deiner Seite zeigen, wenn sie es nicht glauben wollen.

edit: Weil das noch nach einem Missverständnis klingt:
Zitat:
Das mit den proxy adressen kommt automatisch sobald die html datei am server liegt
Das passiert, wenn die Daten zu dir ausgeliefert werden. Mit dem Server, auf dem die Daten liegen, hat das nichts zu tun. Deshalb merkst das auch nur du. Mit anderen Worten: Dein Anbieter manipuliert den Quelltext.
Schau dir doch mal Quelltexte anderer Seiten an. Die werden genauso aussehen wie deine.

Geändert von fricca (25.11.2012 um 22:39 Uhr)
Mit Zitat antworten
  #25 (permalink)  
Alt 26.11.2012, 13:52
Benutzerbild von fox
fox fox ist offline
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 11.09.2006
Beiträge: 1.011
fox sorgt für eine eindrucksvolle Atmosphärefox sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von fricca Beitrag anzeigen
edit: fox, ich hatte ja um genau diesen Code gebeten.
Mir war schon klar, dass er den Code genau so eingefügt hat, wie er ihn bekommt.
@steph: Vielleicht hab ich mich etwas missverständlich ausgedrückt - das war kein Vorwurf an dich, viel mehr an deinen Netzbetreiber.

Schönes Thema "Netzneutralität".

Für dich relevant: Der Speedmanager ist eine Webseite. Hier: http://speedmanager.t-mobile.de/
Noch mehr zum Thema: UMTS via T-Mobile/Vodafone: doppelte Übertragungsmenge als mit DSL/Modem | HagensTechiBlog
__________________
:)
Mit Zitat antworten
  #26 (permalink)  
Alt 26.11.2012, 18:26
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.09.2012
Beiträge: 50
<--steph--> befindet sich auf einem aufstrebenden Ast
Standard

Hallo fox,
Hallo fricca,

der Artiekl von fox war super. Hier wird genau die Problematik beschrieben die ich habe.

Fakt: der speedmanager-Link funktioniert nicht. Ich wunder mich, da ich ja t-moblie Kunde bin. Entweder nur für DE vorgesehen oder man muss noch vorab was in seinem Konto aktivieren - kann ich nicht sagen. Technik-MA bis jetzt noch nicht erreicht (9 Min. Wartezeit tu ich mir [noch nicht an])

Fakt2: selbst wenn ich das im Laufe der Woche für mich ändere, so bleibt meine Seite für alle anderen wlan nutzer eines Telefonanbieters und Handys! ebenso fehlerhaft. Nicht falsch verstehen - ich biete jetzt natürlich nicht den superwichtigen Inhalt, soll nur ein Fotoblog werden - trotzdem möchte ich, dass meine Seite korrekt dargestellt wird, wenn ich (und ihr) so viel Zeit investiert.

Überlegung: gibt es eine andere Technik wie man diesen Fehler seitens des Netzanbieters umgehen kann?

Überlegung2: wenn mir alles zu blöd wird (wenig Kundennähe, Technik=Mehrwerddinest, etc) gestalte ich meine Seite einfach um.

Danke, Stephan
Mit Zitat antworten
  #27 (permalink)  
Alt 26.11.2012, 20:01
Benutzerbild von fox
fox fox ist offline
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 11.09.2006
Beiträge: 1.011
fox sorgt für eine eindrucksvolle Atmosphärefox sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von <--steph--> Beitrag anzeigen
Überlegung: gibt es eine andere Technik wie man diesen Fehler seitens des Netzanbieters umgehen kann?

Überlegung2: wenn mir alles zu blöd wird (wenig Kundennähe, Technik=Mehrwerddinest, etc) gestalte ich meine Seite einfach um.
Von deiner Seite aus wohl nicht, eher von Seiten des Kunden. Möglicherweise werden TLS-Verbindungen (HTTPS) nicht gefiltert, aber diese Variante ist nicht günstig und schon gar nicht mit wenig Aufwand zu bewerkstelligen.

Du musst die Seite nicht gleich umgestalten, aber einige Bastelarbeit wird da schon auf dich zukommen. Das Problem ist, dass du wenig Unterstützung bekommen kannst. Aber: Selbst ist der Mann! Schaue dir einfach noch mal die Unterschiede zwischen der lokalen und der dir ausgelieferten Version an, und verändere nach und nach einige Parameter, bis es besser wird. Validieren ist zwar grundsätzlich immer eine gute Idee, aber noch lange keine Garantie dafür, dass alles auch korrekt dargestellt wird. Tipp: Probiere erst mit Firefox, Chrome, Opera oder anderen Browsern, da der IE grundsätzlich fehleranfälliger ist.

Und vielleicht hast du ja Glück und es meldet sich tatsächlich jemand, der die Lösung auf dem Silbertablett präsentieren kann.
__________________
:)
Mit Zitat antworten
  #28 (permalink)  
Alt 26.11.2012, 21:12
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.779
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Ich habe schon des öfteren diverse "whitespaceabhängige" Layoutmethoden verwendet und konnte bei meinen mobilen Tests keine solchen Darstellungsprobleme beobachten.
Heute habe ich eine Blick in den Code werfen können (ist ein anderer Mobilfunkanbieter, der aber die gleiche Komprimierungstechnik einsetzt) und tatsächlich war es so, dass der Whitespace aus "meinem" Inhaltsbereich nicht wegkomprimiert wurde. Bei deiner Testseite aber schon.
Nach einigem Hin- und Herprobieren habe ich möglicherweise(!) den Unterschied gefunden, weshalb meine Projekte nicht kaputtimiert werden.
Tausch bitte mal die ersten Zeilen deines Dokuments gegen folgendes aus:
Zitat:
<!DOCTYPE html>
<html lang="de">
<head>
<meta charset="utf-8" />
Und schau dann mal, was bei dir im Browser ankommt.

edit:
Und noch eine Bitte: Ruf doch mal bitte die folgenden 3 Links auf. Es sind jeweils drei hübsche, gelbe Listen, die eigentlich jeweils eine Blocksatz-Zeile bilden sollen:
http://test.fwpf-webdesign.de/whitespace/01.html
http://test.fwpf-webdesign.de/whitespace/02.html
http://test.fwpf-webdesign.de/whitespace/03.html
Bei welcher der drei Testfälle siehst du alle drei Listen im Blocksatz, bei welchen ist eine (oder mehrere davon) zusammengerückt?
(Im Anhang die Darstellung, wie sie eigentlich sein soll)
Angehängte Grafiken
Dateityp: jpg soll.jpg (29,1 KB, 7x aufgerufen)

Geändert von fricca (26.11.2012 um 21:39 Uhr)
Mit Zitat antworten
  #29 (permalink)  
Alt 26.11.2012, 21:49
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.09.2012
Beiträge: 50
<--steph--> befindet sich auf einem aufstrebenden Ast
Standard

Hallo corina,

um auf deine Frage zu antworten: 1 ist zusammendgestaucht, 2+3 sind als Blocksatz dargestellt.

meine ersten Zeilen Code schauen (bis body) nun wie folgt aus:

HTML-Code:
<!DOCTYPE html>
<html lang="de">
<head>
<meta charset="utf-8" />

<title>Steven's page</title>
<link rel="stylesheet" type="text/css" href="mystyles.css" media="screen"></link>
<link rel="icon" href="mein_favicon.ico" type="image"></link>
<base href="http://www.stev.bplaced.net"></base>
</head>
Ergebnis: Im Browser FF leider noch immer gestaucht, im Editor wie gehabt wie gewollt. Beabsichtigt?
Mit Zitat antworten
Sponsored Links
  #30 (permalink)  
Alt 26.11.2012, 21:50
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.09.2012
Beiträge: 50
<--steph--> befindet sich auf einem aufstrebenden Ast
Standard

edit: bei Link 1 ist das dritte Beispiel gestaucht um korrekt zu sein
Mit Zitat antworten
Sponsored Links
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Karrierestart-IT - die online Jobmesse für IT-Studenten ictjob.de Offtopic 0 20.09.2012 10:46
Biete Half live 2 cs:s Server auf übernahme an netshuttle Offtopic 4 20.12.2009 22:51
SMTP Server einrichten [Mercury, Win03 Server] ct2oo4 Serveradministration und serverseitige Scripte 5 22.08.2009 13:51
footer stick alt tut nicht wirklich, was es soll E|H (X)HTML 16 01.01.2006 19:15
Beim Seitenaufruf schon connect zu anderem Server herstellen Olel (X)HTML 8 01.02.2005 00:14


Alle Zeitangaben in WEZ +2. Es ist jetzt 19:24 Uhr.