zurück zur Startseite
  


Zurück XHTMLforum > Webentwicklung (außer XHTML und CSS) > Serveradministration und serverseitige Scripte
Seite neu laden Fehler in der HTACCESS

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 18.09.2012, 15:20
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 02.01.2007
Beiträge: 241
web334 befindet sich auf einem aufstrebenden Ast
Standard Fehler in der HTACCESS

Ich habe mir die folgende HTACCESS zusammengestellt

Code:
AddDefaultCharset utf-8
AddCharset utf-8 .php .html .css

<IfModule mod_expires.c>
 ExpiresActive On
 ExpiresByType text/html "access plus 2 days"
 ExpiresByType text/css "access plus 2 days"
 ExpiresByType text/xml "access plus 1 month"
 ExpiresByType text/javascript “access plus 1 month”
 ExpiresByType application/javascript "access plus 1 month"
 ExpiresByType application/x-javascript "access plus 1 month"
 ExpiresByType application/xml "access plus 1 month"
 ExpiresByType image/gif "access plus 1 month"
 ExpiresByType image/jpg "access plus 1 month"
 ExpiresByType image/jpeg "access plus 1 month"
 ExpiresByType image/png "access plus 1 month"
 ExpiresByType image/x-icon "access plus 1 year"
 ExpiresByType application/x-shockwave-flash "access plus 1 year"
</IfModule>

<IfModule mod_deflate.c>
<FilesMatch "\\.(html|css|js|xml|php|txt)$">
 SetOutputFilter DEFLATE
</FilesMatch>
</IfModule>

aber wenn ich diese auf meinen Server hochlade erscheint folgende Fehlermeldung:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.


Was ist denn daran falsch?
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 18.09.2012, 16:55
Benutzerbild von mantiz
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 25.02.2007
Beiträge: 2.845
mantiz kann auf vieles stolz seinmantiz kann auf vieles stolz seinmantiz kann auf vieles stolz seinmantiz kann auf vieles stolz seinmantiz kann auf vieles stolz seinmantiz kann auf vieles stolz seinmantiz kann auf vieles stolz seinmantiz kann auf vieles stolz sein
Standard

Bei solchen Fehlern gehe ich meistens so vor, dass ich entweder zunächst alles deaktiviere (auskommentiere) und dann Zeile für Zeile aktiviere (einkommentiere), bis ich einen Fehler erhalte. Das ganze geht natürlich auch andersherum (zeilenweise auskommentieren bis es läuft).

Dann hat man das Problem zumindest schonmal eingegrenzt.
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 18.09.2012, 19:24
Benutzerbild von David
auch, ja!
XHTMLforum-Kenner
 
Registriert seit: 08.11.2007
Beiträge: 2.630
David ist ein wunderbarer AnblickDavid ist ein wunderbarer AnblickDavid ist ein wunderbarer AnblickDavid ist ein wunderbarer AnblickDavid ist ein wunderbarer AnblickDavid ist ein wunderbarer AnblickDavid ist ein wunderbarer Anblick
Standard

Was sagt denn das Error Log?
__________________
github | http://dnaber.de
Mit Zitat antworten
  #4 (permalink)  
Alt 19.09.2012, 11:33
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 02.01.2007
Beiträge: 241
web334 befindet sich auf einem aufstrebenden Ast
Standard

Wenn ich die Zeile
Code:
 ExpiresByType text/javascript “access plus 1 month”
entferne, dann funktioniert es.
Aber was soll daran falsch sein?
Diese Angabe benötige ich doch auch, wenn ich für die Skripte etwas festlegen möchte
Mit Zitat antworten
  #5 (permalink)  
Alt 19.09.2012, 11:46
Benutzerbild von Praktikant
Semantikbremse.
XHTMLforum-Kenner
 
Registriert seit: 22.04.2008
Beiträge: 4.997
Praktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz sein
Standard

Wahrscheinlich die Anführungszeichen
__________________
Rettet die Erde.... sie ist der einzige Planet mit Schokolade!
Mit Zitat antworten
  #6 (permalink)  
Alt 19.09.2012, 11:52
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 02.01.2007
Beiträge: 241
web334 befindet sich auf einem aufstrebenden Ast
Standard

welche Anführungszeichen meinst du?
Diese sind auch bei den anderen an der gleichen Stelle vorhanden und da passt es auch
Mit Zitat antworten
  #7 (permalink)  
Alt 19.09.2012, 11:58
Benutzerbild von Manfred62
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2009
Ort: Ludwigsburg
Beiträge: 2.138
Manfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nett
Standard

schau mal in den Code deines ersten Post --> dort fällt das sofort auf.
Das sind andere Zeichen wie die restlichen 'normalen' Anführungszeichen.
Mit Zitat antworten
  #8 (permalink)  
Alt 19.09.2012, 12:19
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 02.01.2007
Beiträge: 241
web334 befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von Manfred62 Beitrag anzeigen
schau mal in den Code deines ersten Post --> dort fällt das sofort auf.
Das sind andere Zeichen wie die restlichen 'normalen' Anführungszeichen.
vollkommen korrekt! Das ist mir überhaupt nicht aufgefallen.
Recht herzlichen Dank euch beiden!
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Website funktioniert bei anderem Hoster nicht. htaccess Fehler? Cobretty Serveradministration und serverseitige Scripte 20 27.03.2012 12:36
Redesign für Steiner Cycling Team pkipper Site- und Layoutcheck 11 09.02.2011 12:25
Fehler: $(blabla...) is null... Was bedeutet das und wie kann ich es beheben? pkipper Javascript & Ajax 2 04.05.2010 09:16
Fehler im Code koshiro (X)HTML 23 07.12.2009 13:39
htaccess - unterschiedliche Behandlung der Fehler, wieso? andir Serveradministration und serverseitige Scripte 13 13.03.2009 18:47


Alle Zeitangaben in WEZ +2. Es ist jetzt 01:45 Uhr.