zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > (X)HTML
Seite neu laden Adobe Browser Labs: Fehlerhafte Umlaute in Safari 5.1

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 10.08.2012, 10:20
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 06.12.2011
Beiträge: 11
zoomify befindet sich auf einem aufstrebenden Ast
Standard Adobe Browser Labs: Fehlerhafte Umlaute in Safari 5.1

Hallo an alle,

da ich selbst kein Mac habe, bin ich leider etwas aufgeschmissen.
Adobe Browser Labs zeigt mir beim testen von Safari 5.1 - OS X fehlerhafte Umlaute an.

Könnt Ihr euch das erklären bzw. liebe Mac-User: ist die Anzeige tatsächlich falsch oder ist das ein Fehler von Adobe?


Hier ist mein Testcase:
TEST

und im Anhang ein Screenshot.


LIEBEN DANK!
Angehängte Grafiken
Dateityp: jpg abl.JPG (22,0 KB, 3x aufgerufen)

Geändert von zoomify (10.08.2012 um 10:40 Uhr)
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 10.08.2012, 12:17
Benutzerbild von heiko_rs
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2005
Ort: Berlin
Beiträge: 9.854
heiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblick
Standard

Der Server sendet keine Zeichenkodierung, aber das ist auch nicht nötig, wenn man in XHTML dessen Standardkodierung UTF-8 verwendet - von daher liegt der Fehler nicht bei Dir.

Dennoch, für alle Fälle: Wenn Du es optimal machen möchtest, machst Du das meta-Element mit der Zeichenkodierung zum ersten Kind von head (das sollte es eh immer sein) und sendest außerdem die Kodierung per HTTP-Header, und wenn Browser Labs dann immer noch Fehler zeigt, spinnt es anscheinend
__________________
Wer keinen Link auf seine problembehaftete Seite posten kann, weil diese noch nicht online ist: Testcase bauen, online stellen, Link posten.
Internet-Grundregel: Unbekannte Begriffe googeln! (Erspart 99% aller Nachfragen.)
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 10.08.2012, 13:25
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 06.12.2011
Beiträge: 11
zoomify befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von heiko_rs Beitrag anzeigen
Der Server sendet keine Zeichenkodierung, aber das ist auch nicht nötig, wenn man in XHTML dessen Standardkodierung UTF-8 verwendet - von daher liegt der Fehler nicht bei Dir.

Dennoch, für alle Fälle: Wenn Du es optimal machen möchtest, machst Du das meta-Element mit der Zeichenkodierung zum ersten Kind von head (das sollte es eh immer sein) und sendest außerdem die Kodierung per HTTP-Header, und wenn Browser Labs dann immer noch Fehler zeigt, spinnt es anscheinend
Hallo Heiko,
dank dir für deine Antwort.

Ich bin mir etwas unsicher, ob ich dich richtig verstanden habe:
Was meinst du "als erstes Kind von Head"? Dass es als erstes genannt werden soll? Das habe ich nun getan und den title nach unten gestellt:

HTML-Code:
<head>
<meta http-equiv="Content-type" content="text/html; charset=UTF-8" />
<title>TEST</title>
<meta name="robots" content="index,follow" />
<meta name="description" content="TEST" />
</head>
Und wie sendet man die "Kodierung per HTTP-Header"? Habe ich das nicht schon getan?

Da Browser Labs andere Seiten korrekt anzeigt, gehe ich eher von einem Fehler meiner Seite aus als von Adobe...

DANKE FÜR DEINE HILFE
Mit Zitat antworten
  #4 (permalink)  
Alt 10.08.2012, 13:32
Benutzerbild von heiko_rs
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2005
Ort: Berlin
Beiträge: 9.854
heiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblick
Standard

Zitat:
Zitat von zoomify Beitrag anzeigen
Was meinst du "als erstes Kind von Head"? Dass es als erstes genannt werden soll? Das habe ich nun getan und den title nach unten gestellt
Genau.

Und head-Element != HTTP-Header - google htaccess utf-8
(PHP kann ebenfalls HTTP-Header senden)
__________________
Wer keinen Link auf seine problembehaftete Seite posten kann, weil diese noch nicht online ist: Testcase bauen, online stellen, Link posten.
Internet-Grundregel: Unbekannte Begriffe googeln! (Erspart 99% aller Nachfragen.)
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Ich dachte, UTF-8 garantiert Umlaute??? obo (X)HTML 8 06.08.2012 18:06
HTML5 Multicolumn fehlerhafte Darstellung in Safari und Chrome Dethix (X)HTML 6 30.06.2010 17:59
Safari 3.1 Windows mit Develop Menu laborix Offtopic 3 31.05.2008 20:46
CSS Einteiger am verzweifeln / Navi / Safari mac/ fehlerhafte Darstellung Pazifika CSS 5 10.08.2007 15:45
3 Column Float IE,FF,Opera hui, Safari, Konq. Pfui.... dablake CSS 5 29.05.2005 19:43


Alle Zeitangaben in WEZ +2. Es ist jetzt 02:26 Uhr.