XHTMLforum

XHTMLforum (http://xhtmlforum.de/index.php)
-   Barrierefreiheit (http://xhtmlforum.de/forumdisplay.php?f=78)
-   -   PHP Problem (http://xhtmlforum.de/showthread.php?t=67925)

triMaik 08.08.2012 03:59

PHP Problem
 
Hey Leute. Bin hier voll am verzweifeln. Und zwar bastle ich momentan an meiner vereinshomepage. Nun gibt es bei mir folgendes problem .
PHP Code wird im html code nicht erkannt. die datei hat auch eine php endung:<?php
if(!isset($_SESSION["check"]))
{
session_set_cookie_params(1800);
session_start();
}
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="de" xml:lang="de">

<head>
<title>[var.title]</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<meta name="Description" content="[var.metadescription]" />
<link rel="Stylesheet" type="text/css" href="[var.domain]/style.css" media="screen" />
</head>

<body>
<div class="root">
<a id="top" name="top"></a>
<div id="header">
<a style="background-image:url([var.designdomain]/banner_left.png);" href="[var.domain]">TriTeam Selm</a>
</div>
<div id="navi">
<ul>
<li>
<a class="navilink" href="[var.domain]/index.php"><span>1</span> Neuigkeiten</a>
</li>
<li>
<a class="navilink" href=""><span>2</span> Team</a>
</li>
<li>
<a class="navilink" href=""><span>3</span> Training</a>
</li>
<li>
<a class="navilink" href=""><span>4</span> Termine</a>
</li>
<li>
<a class="navilink" href=""><span>5</span> Bilder</a>
</li>
<li>
<a class="navilink" href=""><span>6</span> Ergebnisse</a>
</li>
<li>
<a class="navilink" href=""><span>7</span> Presse</a>
</li>
<?php
if (isset($_SESSION["log"]))
{
echo "
<li>
<a class="navilink" href=""><span>8</span> Chat</a>
</li>
<li>
<a class="navilink" href=""><span>9</span> Beitrag</a>
</li>
";
}
?>
</ul>
</div>
<div id="content">
<div class="options">
<ul>
<li class="feedback"><a href="">Feedback</a></li>
<li class="fehler_melden"><a href="">Fehler melden</a></li>
<li class="empfehlen"><a href="">Weiterempfehlen</a></li>
</ul>
</div>
<div class="chapter">

fox 08.08.2012 09:15

Bitte code-Tags für deine Quelltextangaben verwenden.

Ist PHP auf dem Server überhaupt aktiv? Welches Paket bei welchem Anbieter hast du?

Probier mal folgendes:

phpinfo.php
PHP-Code:

<?php phpinfo();


triMaik 08.08.2012 14:12

also ich habe auch andere php codes schon auf der seite, wie zum beispiel einen login . der funktioniert auch einwandfrei. daran kann es auch nicht liegen .

triMaik 08.08.2012 15:08

problem ist gelöst. es lag daran , dass die datei, die diesen code included nicht eine php datei war :oops:

trotzdem danke


Alle Zeitangaben in WEZ +2. Es ist jetzt 23:22 Uhr.

Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

© Dirk H. 2003 - 2019