XHTMLforum

XHTMLforum (http://xhtmlforum.de/index.php)
-   Ressourcen (http://xhtmlforum.de/forumdisplay.php?f=74)
-   -   Fehler im W3C CSS-Validator? (http://xhtmlforum.de/showthread.php?t=66769)

Webcoder 31.01.2012 06:00

Fehler im W3C CSS-Validator?
 
Hi Community

kann es sein, dass es im W3C CSS-Validator einen Fehler gibt?

Und zwar bei der CSS 3 Validierung von box-shadow. Sobald man dort mehr als 1 Schatten angibt (Beispiel: box-shadow:-3px 10px 13px rgba(64, 64, 64, 0.25), 3px 10px 13px rgba(64, 64, 64, 0.25); ), was nach W3C Vorgaben zulässig ist, meldet der Validator den Fehler "Empty String".

Hat jemand da nähere Infos zu?


Edit: Das Problem scheint nur im Zusammenhang mit dem rgba-Farbraum aufzutreten.


Danke und Gruß
Webcoder

inta 31.01.2012 08:32

Dazu konkret habe ich keine Informationen, aber da CSS 3 noch nicht fertig ist, wird es sich mit der Implementierung des Validators (zumindest für CSS 3) genauso verhalten. Er kann ja auch z.B. Vendorprefixe nicht erkennen, obwohl sie jn der Spezifikation definiert sind (und nicht mal neu sind).

IChao 31.01.2012 11:35

nähere Infos findest du selber im Bugtracker des W3C Validators. In diesem Fall hier: https://www.w3.org/Bugs/Public/show_bug.cgi?id=11880

Webcoder 31.01.2012 18:15

@IChao
Danke für den Link! ;)

Praktikant 31.01.2012 18:54

In diesem Thema wird der Fehler im Validator übrigens auch beschrieben, ohne RGBa Farbraum: http://xhtmlforum.de/66752-css-2-1-n...tml#post510481


Alle Zeitangaben in WEZ +2. Es ist jetzt 21:11 Uhr.

Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

© Dirk H. 2003 - 2019