zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Bekomme im Validator Check 5 Error Meldungen und weiß nicht wie ich das beheben kann

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 09.12.2011, 16:19
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 03.04.2011
Beiträge: 10
BraucheHilfe befindet sich auf einem aufstrebenden Ast
Standard Bekomme im Validator Check 5 Error Meldungen und weiß nicht wie ich das beheben kann

Hallo ich habe heute mein Projekt auf ein neues Design / css abgeändert.

Wenn ich die Seite auf validator.w3.org checken lasse, erhalte ich immer die gleichen 5 Error Meldungen.

Meine Seite lautet spalierobst[dot]com.

Ich habe das Design genommen, da ich unbedingt ein Dropdown Menü haben wollte, was auf css basiert. Ich gebe zu, ich habe es ziemlich lange zusammen gefrickelt, damit ich das Ergbniss hatte was ich jetzt habe.

Ich bin mit .css nicht so vertraut und kann die Error Meldungen nicht ohne weiteres entfernt bekommen ohne dabei das Dropdown Menü zu zerschießen oder das Design zu ruinieren.

Welche Abnschitt muss ich abändern, damit der Validator keine Fehlermeldungen mehr anzeigt und mein Design das gleiche bleibt.

Über eine Hilfestellung Eurerseits wäre ich sehr dankbar!

Gruß
BraucheHilfe
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 09.12.2011, 16:26
Neuer Benutzer
neuer user
 
Registriert seit: 27.10.2011
Beiträge: 7
dfm666 befindet sich auf einem aufstrebenden Ast
Standard

hallo!

HTML-Code:
<li><a class="active" href="http://www.spalierobst.com/">Startseite</a>
					<li><a>Säulenobst Sorten</a>
hast vergessen das li zu schließen.
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 09.12.2011, 16:49
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 03.04.2011
Beiträge: 10
BraucheHilfe befindet sich auf einem aufstrebenden Ast
Standard

Danke für deine Antwort.

Ich hatte soeben alle geschlossen nur dann wurden kein Dropdown menü mehr angezeigt sonders alles nebeneinander.
Mit Zitat antworten
  #4 (permalink)  
Alt 09.12.2011, 17:38
Benutzerbild von Manfred62
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2009
Ort: Ludwigsburg
Beiträge: 2.136
Manfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nett
Standard

Nicht alle, nur den einen:
Zitat:
<li><a class="active" href="http://www.spalierobst.com/">Startseite</a></li>
Mit Zitat antworten
  #5 (permalink)  
Alt 10.12.2011, 10:24
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 22.03.2006
Beiträge: 387
gaby sorgt für eine eindrucksvolle Atmosphäre
Standard

Hallo,

Auf deiner Seite Spalierobst günstig kaufen | Hilfreiche Pflegetipps und Zubehör für das Säulenobst komme ich bei deinem zweiten Link nicht mehr auf die Sub-Links.

Bei (m)einer Schriftgröße von 16px rutschen die rechten Links des Hauptmenüs in die zweite Zeile. Wenn ich jetzt auf den Link "Säulenobst Sorten" gehe, klappen die Untermenüs zwar auf, aber um sie zu erreichen, muß ich mit der Maus erstmal über den heruntergerutschten Link "Saatkalender/Schnittzeiten von einem Säulenobst". In dem Moment hat der erste Link nicht mehr den Focus, und das Untermenü klappt wieder zu.

Lösung:
Am einfachsten wäre es, die Linktexte des Hauptmenüs zu verkürzen, sodaß sie bei einer Schriftgröße von 16px, - was btw die Defaultschriftgröße der Browser ist - noch alle in eine Zeile passen.


Grüße
gaby
Angehängte Grafiken
Dateityp: png BraucheHilfe-xhtml.png (179,0 KB, 9x aufgerufen)
Mit Zitat antworten
  #6 (permalink)  
Alt 10.12.2011, 11:18
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 03.04.2011
Beiträge: 10
BraucheHilfe befindet sich auf einem aufstrebenden Ast
Standard

@ dfm666 und Manfred62 erstmal vielen Dank für eure Hilfe, habe mich heute Morgen hingesetzt und jede einzelne .html Seite gechekt. Nun passt alles und Google kann die Seite sauber lesen

@ Gaby DANKE für deinen Hinweis.
Ich habe einen 24 Zoll Monitor und habe ein recht hohe Auflösung sodass ich das Problem gar nicht gesehen habe. Nachdem ich die Strg+ Taste gedrückt habe war es mir klar. Ich habe in den Überschriften jeweils ein paar Wörter entfernt, sodass es jetzt immer passen sollte.

Aber was meinst Du mit folgender Aussage
Zitat: "komme ich bei deinem zweiten Link nicht mehr auf die Sub-Links."
Zitat Ende

Ich bin jetzt jeden einzelnen Link durchgegangen und konnte keine fehlerhaften Links feststellen. Das ganze wundert mich schon, da ich gesten bei der Sitemap Erstellung ebenfalls einen Hinweis erhalten habe, das auf meiner Seite 6 broken Links vorhanden sind. Kann diese aber nicht ausmachen.
Cache vom Browser etc. sind gelöscht.

Gruß
BraucheHilfe
Mit Zitat antworten
  #7 (permalink)  
Alt 10.12.2011, 15:02
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 22.03.2006
Beiträge: 387
gaby sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von BraucheHilfe Beitrag anzeigen
@ Gaby DANKE für deinen Hinweis.
Bitte sehr.


Zitat:
Ich habe in den Überschriften jeweils ein paar Wörter entfernt, sodass es jetzt immer passen sollte.
Nunja, immer wohl nicht, aber es ist schon besser.

Zitat:
Aber was meinst Du mit folgender Aussage
Zitat: "komme ich bei deinem zweiten Link nicht mehr auf die Sub-Links."
Hmm, das habe ich doch genau beschrieben und bebildert. Klick mal die angehängte Grafik an.

Der zweite Link deines Hauptmenüs ist "Säulenobst Sorten". Vergrößere die Schrift auf ca 16px, sodaß die Links in der Position stehen, wie auf meinem Screenshot im Vorposting.
(kein Seitenzoom, sondern nur Text vergrößern).

Und jetzt versuche, mit der Maus auf die Sublinks zu gehen. ...

Ein Problem besteht aber immer noch:
wenn ich deine Seite mit den jetzt verkürzten Links um 1 Stufe vergrößere (nur Text, kein Zoom), rutscht die Box mit dem Bild ganz nach rechts, und der Textteil mit dem Shop-Link verschwindet.
Wenn das bei deinem breiten Bildschirm nicht der Fall ist, dann verkleinere mal dein Browserfenster auf ca 1000px.

wer floatet, muß auch clearen.

Float-Tutorial v. Andreas Kalt:
Float

Grüße
gaby
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Quelltext nicht w3c valide: kann Fehler nicht beheben Mojo83 CSS 4 31.05.2008 13:32
Problem bei der Darstellung im IE6 und keinen Plan wie zu beheben... prosac257 CSS 6 04.08.2006 19:27


Alle Zeitangaben in WEZ +2. Es ist jetzt 21:36 Uhr.