zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Browserkompabilität selber checken und IEs Kompabilitätsmodus

Antwort
 
LinkBack Themen-Optionen Ansicht
  #11 (permalink)  
Alt 29.09.2011, 15:06
body.ie {display: grotte}
XHTMLforum-Mitglied
 
Registriert seit: 09.01.2011
Beiträge: 841
take_a_7 sorgt für eine eindrucksvolle Atmosphäretake_a_7 sorgt für eine eindrucksvolle Atmosphäre
Standard

Moin,

Zitat:
Zitat von japanworm Beitrag anzeigen
Leider habe ich auf meinen beiden Laptops jeweils nur den IE8 und im Kompabilitätsmodus ist mein Layout eine einzige Katastrophe.
Willkommen in der Welt der alten IEs Die können (hat man manchmal jedenfalls das Gefühl) gar nix...
Zitat:
Zitat von japanworm Beitrag anzeigen
Werde mal den IE9 herunterladen.
Wenn du Windows 7 hast, sonst ist bei IE8 Schluss.

gruß,
take
Mit Zitat antworten
Sponsored Links
  #12 (permalink)  
Alt 29.09.2011, 15:08
Benutzerbild von japanworm
Confuser
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 14.07.2011
Ort: Japan
Beiträge: 143
japanworm befindet sich auf einem aufstrebenden Ast
Standard

Da lässt sich dann auch nicht sonderlich viel machen (evtl. mit Hacks, aber da kenne ich mich zu wenig aus)?! :/

Yepp, Windows7
Mit Zitat antworten
Sponsored Links
  #13 (permalink)  
Alt 29.09.2011, 15:15
body.ie {display: grotte}
XHTMLforum-Mitglied
 
Registriert seit: 09.01.2011
Beiträge: 841
take_a_7 sorgt für eine eindrucksvolle Atmosphäretake_a_7 sorgt für eine eindrucksvolle Atmosphäre
Standard

Moin,

wieso? Bis auf die Navi kriegt der IE9 das im IE7 Modus das doch ganz gut hin Du weißt, dass die Kompatibilitätsansicht über den Button neben der Adressleiste noch was anderes ist, oder? Wie die Seite gerendert werden soll, kannst du in den Entwicklertools (F12) einstellen.

gruß,
take
Mit Zitat antworten
  #14 (permalink)  
Alt 29.09.2011, 15:34
Benutzerbild von japanworm
Confuser
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 14.07.2011
Ort: Japan
Beiträge: 143
japanworm befindet sich auf einem aufstrebenden Ast
Standard

Ist nicht nur die Navigation, aber das alleine finde ich schon ganz schrecklich, weil es schließlich was Essenzielles ist!!
Mit Zitat antworten
  #15 (permalink)  
Alt 01.10.2011, 16:58
Benutzerbild von japanworm
Confuser
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 14.07.2011
Ort: Japan
Beiträge: 143
japanworm befindet sich auf einem aufstrebenden Ast
Standard

Hallo!

Ich habe jetzt in sehr vielen Browsern getestet.
Die neuesten Versionen aller Browser: Internet Explorer 8, Opera 11, Safari 5 und Chrome 14 (selbst benutze ich Firefox 6)
Da gibt es eigentlich keine Probleme!

Zusätzlich getestet habe ich:
- Safari 3
- Internet Explorer 7 (allerdings nur über den Kompa-modus im IE8..)
- Firefox 3.6
- Chrome 4, 5 und 8

Im Chrome, selbst in der neuesten Version ist mir aufgefallen, dass die Schrift ganz anders dargestellt wird. Da bekommt man beim Lesen direkt Augenschmerzen. Irgendeine Idee wie man das ändern könnte?:

http://i55.tinypic.com/125qkgp.jpg

Irgendwas scheint an den Header-Elementen nicht zu stimmen, denn in älteren Browserversionen und sogar im neuen Opera gibt's Probleme:

Safari 3:



Internet Explorer 7:

http://i54.tinypic.com/217ou1.jpg

Opera 11:

Screenshot


Was mir auch noch aufgefallen ist: Ein paar Browser, z.B. Safar haben scheinbar ein automatisches Highlight für textareas in forms. Das sieht etwas hässlich aus und überschreibt das CSS "on focus". Kann man da irgendwas machen?


Ich möchte es jetzt auch nicht übertreiben und auf Teufel komm raus alles in jedem Browser perfekt haben, aber wenigstens die Navigation im Header möchte ich hinbekommen.

Geändert von japanworm (02.10.2011 um 03:57 Uhr)
Mit Zitat antworten
  #16 (permalink)  
Alt 12.10.2011, 15:59
Benutzerbild von japanworm
Confuser
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 14.07.2011
Ort: Japan
Beiträge: 143
japanworm befindet sich auf einem aufstrebenden Ast
Standard

Ich frage jetzt nach fast 2 Wochen nochmal ganz bescheiden nach, ob wirklich keiner helfen kann oder mir zumindest Tipps geben könnte, wie ich selber drauf kommen könnte?!

Ich habe selber schon etwas rumgespielt.

Folgendes habe ich verändert:
Code:
.jqueryslidemenu ul li{
position:relative;
display:inline;
float: left;}

.jqueryslidemenu ul{
list-style-type: none;
float:right;
z-index:2;}
verändert zu:


Code:
.jqueryslidemenu ul{
list-style-type: none;
z-index:2;}


.jqueryslidemenu ul li{
position:relative;
float: left;}
Wenn ich das float:left herausnehmen, dann sieht das Menü im Firefox genauso verratzt aus wie im IE, also nehme ich an, dass irgendwo dort das Problem liegt.
Mit meinen jetzigen Veränderungen zeigt sich das Menü im IE7 allerdings GAR NICHT mehr....

Es sieht so aus als könnte der IE7 aus irgendeinem Grund das "float:left" nicht umsetzen.

Geändert von japanworm (12.10.2011 um 16:20 Uhr)
Mit Zitat antworten
  #17 (permalink)  
Alt 12.10.2011, 19:16
Standardkatze
XHTMLforum-Kenner
 
Registriert seit: 06.02.2007
Beiträge: 1.821
gato ist einfach richtig nettgato ist einfach richtig nettgato ist einfach richtig nettgato ist einfach richtig nettgato ist einfach richtig nett
Standard

Zitat:
Zitat von japanworm Beitrag anzeigen
Im Chrome, selbst in der neuesten Version ist mir aufgefallen, dass die Schrift ganz anders dargestellt wird. Da bekommt man beim Lesen direkt Augenschmerzen. Irgendeine Idee wie man das ändern könnte?:
Auf JPEG (also verlustvollen Bildern ist es nicht gerade einfach, Details zu erkennen). Bei meinem Chrome scheint die schrift lediglich etwas weniger Kontrastreich. Ich sollte aber dazusagen, dass ich den Kontrast zwischen Schrift- und Hintergrundfarbe allgemein viel zu schwach empfinde.

Dein Problem mit den Menüpunkten scheint auch von der Schrift abhängig zu sein. Diese wird von jedem Browser und jedem OS nunmal etwas anders dargestellt, dagegen kannst du nichts machen. Du kannst aber etwas mehr Platz in der horizontalen schaffen, so dass die Listenpunkte immer Platz haben.

Momentan haben sie das einfach nicht immer.

Zitat:
Zitat von japanworm Beitrag anzeigen
Es sieht so aus als könnte der IE7 aus irgendeinem Grund das "float:left" nicht umsetzen.
Doch schon, irgendwie. Aber es ist halt der IE7.
Ein möglicher Ansatz könnte sein, dem Elternelement (ul) eine Breite zu geben. Dadurch werden die Punkte schon mal nebeneinander dargestellt.

Zitat:
Zitat von japanworm Beitrag anzeigen
Was mir auch noch aufgefallen ist: Ein paar Browser, z.B. Safar haben scheinbar ein automatisches Highlight für textareas in forms. Das sieht etwas hässlich aus und überschreibt das CSS "on focus". Kann man da irgendwas machen?
Kann ich nicht nachvollziehen, ist eventuell ein alter Safari-Bug.

Zitat:
Zitat von japanworm Beitrag anzeigen
Ich möchte es jetzt auch nicht übertreiben und auf Teufel komm raus alles in jedem Browser perfekt haben, aber wenigstens die Navigation im Header möchte ich hinbekommen.
Die Fehlersuche im IE7 geht ziemlich schwer, weil die Skripte das Programm sehr stark belasten und verlangsamen. Aber obiger Hinweis sollte ich vorerst weiterbringen.

Zudem ist der Quelltext sehr unübersichtlich. Ich denke 90% der Klassen und einen Großteil der div-Elemente könntest du problemlos löschen.
__________________
Über Internet Explorer 8:
Noch bis 8. April 2014 wird der Internet Explorer 6 mit Sicherheitsupdates versorgt.
Bereits jetzt kann dieser Browser aber vollständig durch den IE8 ersetzt werden. Ältere Betriebssysteme und Browserversionen werden von Microsoft nicht mehr unterstützt.
Auch Programme, die den IE7 benötigen, sind kein Argument gegen IE8, da dieser über entsprechende Kompatibilitätsschichten verfügt.
Ab sofort gilt daher der Internet Explorer 8 als vorausgesetzer Mindeststandard.
Mit Zitat antworten
  #18 (permalink)  
Alt 13.10.2011, 14:08
Benutzerbild von japanworm
Confuser
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 14.07.2011
Ort: Japan
Beiträge: 143
japanworm befindet sich auf einem aufstrebenden Ast
Standard

Ich habe dem ul-Element eine feste Breite gegeben. An sich klang das nach einer guten Idee, allerdings ist das Navigationsmenü im IE7 jetzt komplett verschwunden!!

Verändert hatte ich das hier:

Code:
ul.menu {
margin:10px 20px 0 0;
position:relative;
margin-right:390px;
width:500px;
}
Mit Zitat antworten
  #19 (permalink)  
Alt 13.10.2011, 14:13
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.964
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Zitat:
Zitat von japanworm Beitrag anzeigen
Ich frage jetzt nach fast 2 Wochen nochmal ganz bescheiden nach, ob wirklich keiner helfen kann oder mir zumindest Tipps geben könnte, wie ich selber drauf kommen könnte?!
Wenn wir die Seite sehen könnten schon, aber mit Screenshots kann man eigentlich gar nichts sagen.
Mit Zitat antworten
Sponsored Links
  #20 (permalink)  
Alt 13.10.2011, 14:19
Benutzerbild von japanworm
Confuser
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 14.07.2011
Ort: Japan
Beiträge: 143
japanworm befindet sich auf einem aufstrebenden Ast
Standard

Hm? Ich hatte doch einen Link zu meiner Webseite geopstet ....
Aber hier gerne nochmal: klick
Mit Zitat antworten
Sponsored Links
Antwort

Stichwörter
browser, kompabilität, kompatibilitätsmodus, layoutcheck

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus



Alle Zeitangaben in WEZ +2. Es ist jetzt 05:17 Uhr.