XHTMLforum

XHTMLforum (http://xhtmlforum.de/index.php)
-   CSS (http://xhtmlforum.de/forumdisplay.php?f=73)
-   -   Navigation zuckt/hüpft (http://xhtmlforum.de/showthread.php?t=65727)

ninaha73 13.09.2011 13:16

Navigation zuckt/hüpft
 
Hallo,

ich muss für eine bestehende Homepage ein paar Fehler ausbügeln,
das Problem besteht darin das ich die Homepage nicht selbst gemacht habe
und es so viele Dokumente gibt das ich so langsam den Überblick verliere.
Ich bin auch noch recht neu in dem Gebiet und es wäre toll wenn mir jemand
helfen könnte. Ich keine Ahnung nach was ich genau schauen soll.

Auf der Homepage ist links eine Navigationsleiste und wenn man ein
Menüpunkt anklickt wird dieser Fett gedruckt und ändert die Farbe, alles so
wie es sein soll aber dein verteilt sich das ganze Menü um ein paar mm nach
oben oder nach unten. Sieht so aus als würde es sich von selbst noch einmal
ausrichten. Versteht jemand was ich meine? Kommt das durch das Fett gedruckte?



LG Nina

Praktikant 13.09.2011 13:22

Zitat:

Zitat von ninaha73 (Beitrag 502262)
Versteht jemand was ich meine?

Ein wenig. Mit Link und Quellcode wäre es deutlich einfacher!
Zitat:

Zitat von ninaha73 (Beitrag 502262)
Kommt das durch das Fett gedruckte?

Wahrscheinlich. Fettschrift braucht eben mehr Platz als normal gedrucktes.
Du kannst ja mal probieren, indem du den Menüpunkten generell eine höhere Zeilenhöhe zuordnest. Sind deine Probleme dann verschwunden, lag es an der Fettschrift.

ninaha73 13.09.2011 13:34

Hab ich mir schon gedacht das die Sache schwierig ohne Codebeispiel wird,
wenn es privat wäre, wäre das kein Problem aber ist es leider nicht.

Ich habe das ganze auch ohne fett gedruckt gemacht, aber immer noch das selbe Problem :(

Hier mal ein kleiner Ausschnitt aus der CSS Datei oder kann da auch was an der HTML-Datei liegen?

___________________

#navi_main {
}
#navi_main ul li {
margin: 0 0 10px;
padding: 0;
/*font-weight: bold;*/
font-size: 1em;
background: none;
}

#navi_main ul li ul {
margin: 0 0 10px;
padding: 0;
}

#navi_main ul li ul li {
font-weight: normal;
margin: 8px 0 8px 10px;
line-height: 1em;
font-size: 0.9em;
}

#navi_main ul li ul li ul li {
margin: 8px 0 8px 10px;
font-size: 0.9em;
}

#navi_main ul li ul li ul li ul li{
margin: 8px 0 8px 10px;
font-size: 0.9em;
}


#navi_main ul li a {
display: block;
margin: 0;
padding: 0;
color: #5a5555;
text-decoration: none;
}

/* Hovered links, active Elements (non-clickable) and active parent elemets are blue*/
#navi_main ul li a:hover,
#navi_main ul li a.activeparent,
#navi_main ul li h3 {
font-weight: inherit;
font-size: inherit;
}

Praktikant 13.09.2011 13:42

Sorry, aber Wort "Link" war doch deutlich zu lesen, oder?

Bitte lies die Hinweise für Fragende und Antwortende. Wir haben auch keine Lust auf Bastelstunde.

Solltest du den Link absolut nicht posten können, dann baue uns ein Testcase, welches das Problem 100%ig nachstellt und poste den Link dazu.

Der CSS-Code der da steht passt übrigens nicht zu deiner Aussage über das Verhalten der Menüpunkte. Allerdings ist das aber auch nicht der komplette Code.
Desweiteren hat das Forum Code-Tags. Diese kannst du im Textfeld beim Eingeben oder Bearbeiten (erweiterte Ansicht) eines Beitrages anklicken. Bitte nutze Sie!

ninaha73 13.09.2011 13:52

Tut mir leid ich bin noch recht neu auf dem Gebiet und in diesem Forum und ich weiß nicht so recht wo ich noch suchen kann.
Wie gesagt ein Link kann ich in dem Fall nicht einstellen und das ganze hab ich schon mal versucht nachzubauen,
aber das Problem kann ich nicht simulieren sonst wüsste ich ja wie ich es lösen könnte.

Ich hab nur gedacht das vielleicht jemand das selbe Problem hatte
und seinen Lösungsansatz erklären könnte der mir vielleicht weiter hilft.

Aber trotzdem Danke für deine Aufmerksamkeit.
LG Nina

Praktikant 13.09.2011 14:02

Weißt du. Anhand deines Ausschnittes kann man nichts erkennen. Ich habe nicht einmal annähernd ein Bild im Kopf wie deine Seite aussieht. Die Navigation hat mindestens 4 Ebenen. Du hast nicht einmal den kompletten Quellcode von einer gepostet.

Wenn du Hilfe willst, dann musst du uns helfen. Wir machen das freiwillig und gerne, aber ohne irgendwelche Anhaltspunkte ist es für uns unmöglich irgendetwas zu machen. Wir haben leider keine funktionierenden Glaskugeln und können weder zaubern noch hellsehen.

Das Problem kann, da du ja schon sagtest du hast keine Ahnung von der Struktur der Seite, auch von einer ganz anderen Stelle kommen, die du nicht mit dem Fehler in Zusammenhang bringst.

Ich verstehe nicht, warum Leute es sich so schwer machen hier Informationen rauszurücken, allerdings einen super-duper Lösungsansatz bzw. die gesamte Lösung erwarten.

Wenn Menschen sich so quer Stellen, dann kann und will ich nicht helfen. Ich gebe dir noch zwei Tipps:

1. Testcase baut man indem man einfach den gesamten Quellcode kopiert und die Texte und Bilder austauscht.
2. Installier dir das Firefox-Plugin Firebug. Dann kannst du selber suchen :)


Alle Zeitangaben in WEZ +2. Es ist jetzt 10:14 Uhr.

Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

© Dirk H. 2003 - 2019