zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Ein Template - viele Fragen

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 15.06.2011, 16:16
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 15.06.2011
Beiträge: 3
nRabbit befindet sich auf einem aufstrebenden Ast
Standard Ein Template - viele Fragen

Hallo Leute,

Wie ihr seht, bin ich neu hier.
Ich habe mich nun getraut ein eigenes Template für Joomla zu basteln. Das Ganze läuft soweit auch ganz gut und es klappt auch mehr oder weniger alles, bis auf ein paar schönheitsfehler.
ich hoffe ihr könnt mir da ein wenig helfen. ich habe bereits nach diesen problemen gesucht, aber nichts gefunden, da ich wohl auch nicth genau weiß, wonach ich da suchen soll.

1. um das gesamte Template sind zwei divs gelegt die sich von der größe her dem Inhalt innerhalb dieser divs anpassen sollten. das hat bis vor kurzem auch funktioniert, doch dann passiert etwas unvorhergesehenes und die divs verschwanden einfach - ich kann sie mit firebug nicht orten, sie sollten ja eigentlich beim draufzeigen das ganze template bläulig einfärben, wie es bei firebug üblich ist, das passiert aber leider nicht, obwohl der recht richtig dargestellt wird. was könnte da das problem sein?

2. mein layout ist so aufgebaut, dass der contentbereich alle anderen positionen deckt. meine divs überlappen sich also. das sieht dann ungefähr so aus:



um diesen Effekt zu erreichen muss ich ja mit der Eitenschaft "top: -WERTpx;" arbeiten.
dadurch wird bei mir dann der inhalt der betroffenen divs um den WERT nach oben verschoben, wodurch aber unten wiederum ein Abstand zum nächsten div entsteht. Wie bekomme ich diesen Abstand weg?

Geändert von nRabbit (15.06.2011 um 18:02 Uhr)
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 15.06.2011, 17:50
Benutzerbild von Manfred62
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2009
Ort: Ludwigsburg
Beiträge: 2.134
Manfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nettManfred62 ist einfach richtig nett
Standard

Binde das Bild von/mit einem ImageHoster ein. Nicht von deiner Uni.
Sonst wird das wohl nicht geladen.

Noch besser, stell deine Testseite bei einem Freehoster online.
Dann kann man am schnellsten helfen.

Manfred
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 15.06.2011, 18:11
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 15.06.2011
Beiträge: 3
nRabbit befindet sich auf einem aufstrebenden Ast
Standard

das bild wird nun angezeigt. lag nicht an meiner uni. Das bild habe ich auf meinem webspace hochgeladen, nur war ich an meinem laptop über mein handy online, was den link wohl etwas manipuliert hat...

die seite findet ihr hier:

schlager.riders-media.de

ich habe sie mal veröffentlich, sobald meine probleme gelöst wurden, werde ich sie wieder offline stellen.

wenn euch ansonsten noch was auffällt, was man verbesser könnte, sagt bescheid. Ist wie gesagt mein erster versuch, also wird es da wohl ein paar fehler geben.

bin für jede Hilfe dankbar!
Mit Zitat antworten
  #4 (permalink)  
Alt 24.07.2011, 18:46
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 15.06.2011
Beiträge: 3
nRabbit befindet sich auf einem aufstrebenden Ast
Standard

Es hat sich hier leider niemand mehr gemeldet. Inzwischen habe ich aber die Ursachen und auch die Lösungen für meine Probleme gefunden. Also falls jemand noch diese Probleme haben sollte, hier ein paar Tipps:

1. Die zwei divs wurden nicht angezeigt: das lag daran, dass die divs innerhalb dieser beiden äußeren divs per float positioniert wurden. Nach diesen divs hat ein clear div gefehlt. nachdem ich diesen eingefügt habe, werden nun auch die beiden äußeren divs angezeigt.

2. durch die relative positionierung mit der eigenschaft "top: -20px;" wurden die divs ensprechend versetzt und so übereinander gelegt. leider blieb aber unterhalb dieser divs ein abstand von genau diesen 20px frei. Dies kann man umgehen in dem man statt der eigenschaft "top" die "margin" Eigenschaft nimmt und diese mit negativen Werten nutzt, zum Beispiel in unserem Beispiel "margin-top: -20px;" Das hat den gleichen Effekt ohne lästige Leerräume an unerwünschten Stellen.

Gruß!
nRabbit

Geändert von nRabbit (24.07.2011 um 18:49 Uhr)
Mit Zitat antworten
Antwort

Stichwörter
css, joomla, positionierung, template

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
FAQ -- Häufig gestellte Fragen und häufig gegebene Antworten mazzo CSS 10 05.04.2012 17:32
Fragen zu einem Template watchdogg CSS 0 07.12.2010 15:15
Fragen über Fragen jules CSS 5 09.10.2008 15:21
Joomla Template Problem tyrannski CSS 0 15.02.2007 15:06
utf8 Fragen und Probleme lewian (X)HTML 11 07.09.2005 01:47


Alle Zeitangaben in WEZ +2. Es ist jetzt 06:17 Uhr.