zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > Site- und Layoutcheck
Seite neu laden Problem mit Slider

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 06.06.2011, 12:09
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 06.06.2011
Beiträge: 4
Fabhino22Elz befindet sich auf einem aufstrebenden Ast
Standard Problem mit Slider

Hallo!

Ich hoffe ich bin hier im richtigen Forumbereich.

Ich habe einen kostenlosen Slider gefunden, welcher eine einfache HTML Datei war / ist, der hier eingesehen werden kann:

Land Of Coder - The Lof SiderNews Plugin

Dieser besteht aus einer HTML Datei, in welcher eben alle Daten stehen die der Slider ausgibt.

Ich habe aus diesem Slider eine PHP Version mit Datenbankanbindung gemacht. Dieser funktioniert auch absolut reibungslos, bis auf eine Sache.

Hier das Problem:

Man kann im HTML Format sehen das es dort Links gibt, die man eintragen kann, entweder mit einer Read More Beschriftung oder eben indem man unter die Überschrift einen Link setzt. Dies funktioniert auch einwandfrei.

Bei meiner PHP Lösung jedoch geht das ganze nicht. Jedoch nicht weil die Daten nicht übergeben werden (Wenn man mit Firebug den Quellcode untersucht sieht man das dort alle Links richtig ausgegeben werden), sondern weil er immer den Link des letzten Sliders über die anderen legt. Ich habe schon versucht das ganze anzupassen, bekomme das ganze jedoch nicht hin.

Deswegen ersuche ich nun hier Hilfe.

Nochmal die Kurzbeschreibung:
Der Slider bekommt im Admin CP alle Links richtig mit. Diese werden auch richtig ausgegeben, jedoch wird immer nur der letzte Link angezeigt.

Hoffe mir kann da jemand helfen?

Hier mal unsere Webseite wo ihr das nachsehen könnt:

http://www.desbl.de

Grüße Fabhino
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 06.06.2011, 13:24
Benutzerbild von Praktikant
Semantikbremse.
XHTMLforum-Kenner
 
Registriert seit: 22.04.2008
Beiträge: 4.997
Praktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz sein
Standard

Zitat:
Zitat von Fabhino22Elz Beitrag anzeigen
Ich hoffe ich bin hier im richtigen Forumbereich.
Nein. Dieses wäre richtig gewesen: Serveradministration und serverseitige Scripte - XHTMLforum
Unser Administrator wird das aber sicherlich bald verschieben.

Nun musst du nur noch deinen Quellcode der php-Datei posten. In dieser ist ja anscheinend der Fehler.
__________________
Rettet die Erde.... sie ist der einzige Planet mit Schokolade!
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 06.06.2011, 14:45
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 06.06.2011
Beiträge: 4
Fabhino22Elz befindet sich auf einem aufstrebenden Ast
Standard

Sorry dann dafür, das war keine Absicht!

Hier mal der Quellcode meiner Template Datei:

Code:
<link type="text/css" rel="stylesheet" href="{@RELATIVE_WCF_DIR}style/slider.css" />

<script type="text/javascript" src="{@RELATIVE_WCF_DIR}js/jquery.js"></script>

<script type="text/javascript" src="{@RELATIVE_WCF_DIR}js/jquery.easing.js"></script>

<script type="text/javascript" src="{@RELATIVE_WCF_DIR}js/script.js"></script>

<script type="text/javascript">

	jQuery(document).ready( function(){	

		jQuery("#lofslidecontent45").lofJSidernews( {

			interval:4000,

			direction:"opacity",

			duration:500,

			startItem:{@$sliderid},

			gameID:{@$gameid},

			easing:"easeInOutSine"

		} );

	});

</script>

<div id="container">

	<div id="lofslidecontent45" class="lof-slidecontent  lof-snleft">

		<div class="preload"><div>

	</div>

</div>

<div class="lof-main-outer">

	<ul class="lof-main-wapper">

		{foreach from=$sliderdata item=$value}

		<li>

			<img title="{@$value.link}" src="{@RELATIVE_WCF_DIR}images/slider/large/{@$value.mainimage}" height="240" width="900">

			<div class="lof-main-item-desc">

				<h3>

					<a target="_parent" title="{@$value.link}" href="index.php?page=Thread&threadID={@$value.link}">{@$value.mainheadline}</a>

				</h3>

				<p>{@$value.maintext}</p>

			</div>

		</li>

		{/foreach}

	</ul>

</div>

<div class="lof-navigator-outer">

	<ul class="lof-navigator">

		{foreach from=$sliderdata item=$value}

		<li>

			<div>

				<img src="{@RELATIVE_WCF_DIR}images/slider/thumbs/{@$value.logoleft}" />

				<h3>{@$value.headlineleft}</h3>

				<span>{@$value.textleft}</span>

			</div>

		</li>

		{/foreach}

	</ul>

</div>

</div>

</div>
Hoffe mir kann hier einer helfen!

Grüße
Mit Zitat antworten
  #4 (permalink)  
Alt 07.06.2011, 11:56
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 06.06.2011
Beiträge: 4
Fabhino22Elz befindet sich auf einem aufstrebenden Ast
Standard

Hat hier keiner eine Idee?

Grüße
Mit Zitat antworten
  #5 (permalink)  
Alt 07.06.2011, 12:35
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.784
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Wenn ich mir die zu deiner Seite passende Demo 5 anschaue kann ich die Überschriften-Links auch nur beim letzten Slide anklicken. Das dürfte daran liegen, dass die Elemente lediglich auf "durchsichtig" geschaltet werden.
Bei der von dir oben verlinkten Mootools-Variante besteht das Problem nicht -- da steht noch visibility dabei.
Wende dich am besten an den Anbieter des Sliders.

edit: Sehe gerade, dass es schon reicht, diesen vom Original mit-kopierten Fehler auszubessern:
Zitat:
Code:
.lof-main-item-desc {
    [...]
    z-index: 100px;
    [...]
}

Geändert von fricca (07.06.2011 um 12:55 Uhr)
Mit Zitat antworten
  #6 (permalink)  
Alt 08.06.2011, 15:35
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 06.06.2011
Beiträge: 4
Fabhino22Elz befindet sich auf einem aufstrebenden Ast
Standard

Vielen vielen Dank!

Damit hast du uns sehr weiter geholfen!!!
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit Text neben Navigationsleiste andi01 CSS 6 08.06.2011 16:54
Design zu CSS/HTML verarbeiten - Problem häufen sich. Grafikamateur CSS 2 06.08.2007 09:57
Scriptalous Slider problem mit ie6 EdgarM CSS 1 21.12.2006 10:36
Problem mit WordPress und dem Bilder Upload Maxefix Serveradministration und serverseitige Scripte 0 19.12.2006 14:58
Problem bei Div's - zwei mal das gleiche und doch nicht ... Niriel CSS 10 09.06.2005 17:39


Alle Zeitangaben in WEZ +2. Es ist jetzt 10:23 Uhr.