zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden CSS Problem mit html area und map im IE9

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 11.05.2011, 11:10
Benutzerbild von icebox
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.05.2011
Beiträge: 2
icebox befindet sich auf einem aufstrebenden Ast
Frage CSS Problem mit html area und map im IE9

Hallo liebe Leute,

da ich zu dem Problem hier noch nichts gefunden habe, mach ich mal den Thread auf. Mir stellt sich folgende Problematik, ich habe für meine Firma eine neue Seite aufgezogen, die als Weiterleitung an die Webseiten der betreffenden Länder in unseren Einsatzgebieten verweist (www.brz.eu).

Dazu habe ich wie gewohnt den Mapping-Tag von html verwendet (bietet sich ja geradezu an ).

Nun zu meinem Problem: Bei Klick auf ein Land macht mir der IE9 nen schwarzen Rand drumrum... - leider konnte ich durch googlen auch nichts weiter zu diesem Problem in Erfahrung bringen - Ihr seid nun meine große Hoffnung

Mein Mapping umfasst folgenden Code:
HTML-Code:
<img src=".../brz_eu/standorte_international_mit logos.jpg"usemap="#eumap" style="border: none;>
<map name="eumap">
		    <area shape="poly" coords="407,31,536,50,566,86,588,203,581,221,581,221,511,255,559,323,534,377,449,384,358,368,388,306,338,286,330,253,330,176"
			  href="http://www.brz.de" target="_blank" alt="Click here to switch to BRZ Deutschland GmbH" title="Click here to switch to BRZ Deutschland GmbH" onmousedown="ET_Event.link('www.brz.eu_link_de', '')" >
		<area shape="rect" coords="566,255,637,286"
			  href="http://www.brz.de" target="_blank" alt="Click here to switch to BRZ Deutschland GmbH" title="Click here to switch to BRZ Deutschland GmbH" onmousedown="ET_Event.link('www.brz.eu_link_de', '')" >

		<area shape="poly" coords="258,249,365,320,338,447,351,467,317,498,233,512,175,494,145,470,175,383,109,323,106,302"
			  href="http://www.brz-pharos.fr" target="_blank" alt="Click here to switch to BRZ Pharos" title="Click here to switch to BRZ Pharos" onmousedown="ET_Event.link('www.brz.eu_link_fr', '')">
               <area shape="poly" coords="379,510,390,510,396,520,391,546,372,544,373,519"
			  href="http://www.brz-pharos.fr" target="_blank" alt="Click here to switch to BRZ Pharos" title="Click here to switch to BRZ Pharos" onmousedown="ET_Event.link('www.brz.eu_link_fr', '')">
                <area shape="rect" coords="20,246,96,275"
			  href="http://www.brz-pharos.fr" target="_blank" alt="Click here to switch to BRZ Pharos" title="Click here to switch to BRZ Pharos" onmousedown="ET_Event.link('www.brz.eu_link_fr', '')">

               <area shape="poly" coords="418,387,442,397,473,427,472,444,461,456,429,469,346,446,354,428,381,396"
			  href="http://www.brz-wibeag.ch" target="_blank" alt="Click here to switch to BRZ WIBEAG" title="Click here to switch to BRZ WIBEAG" onmousedown="ET_Event.link('www.brz.eu_link_ch', '')">
                <area shape="rect" coords="551,387,632,409"
			  href="http://www.brz-wibeag.ch" target="_blank" alt="Click here to switch to BRZ WIBEAG" title="Click here to switch to BRZ WIBEAG" onmousedown="ET_Event.link('www.brz.eu_link_ch', '')">

</map>
Eine kleine Anmerkung noch: das ganze läuft über TYPO3 (wobei ich jetzt eher net glaube das es daran liegen kann)

Ich dank euch schonmal im Voraus für eure Hilfe
Angehängte Grafiken
Dateityp: jpg ie9-mappinprob.jpg (27,5 KB, 5x aufgerufen)
__________________
think positive
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 11.05.2011, 13:14
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 22.03.2006
Beiträge: 387
gaby sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von icebox Beitrag anzeigen
Nun zu meinem Problem: Bei Klick auf ein Land macht mir der IE9 nen schwarzen Rand drumrum
Hallo,

Immer noch, nachdem du die Syntaxfehler, insbesondere den hier:

Zitat:
Line 69, Column 336: there is no attribute "none"

…_international_mit logos.jpg" usemap="#eumap" style="border:" none="" alt="" />

korrigiert hast?

der Validator, dein Freund und Helfer. ...

The W3C Markup Validation Service
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 11.05.2011, 13:31
Benutzerbild von icebox
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.05.2011
Beiträge: 2
icebox befindet sich auf einem aufstrebenden Ast
Standard

Hi gaby

Dank dir für deine schnelle Antwort Ich hab das ganze jetzt mal durch den Validator gejagt und den dort angezeigten Fehler soweit behoben (peinlichpeinlich das ichs vorher net schon geprüft hab)

Leider ist mein ursprüngliches Problem immer noch vorhanden >.<°° - vielleicht bin ich auch zu doof und seh den Wald vor lauter Bäumen nicht

Liebe Grüße

icebox
__________________
think positive
Mit Zitat antworten
Antwort

Stichwörter
<area>, <map>, css, darstellungsproblem, ie9

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Einbindung von frei erhältlichen Scripten - CSS Problem DonL CSS 1 22.01.2011 17:09
Problem mit CSS in HTML einfügen Chizzo CSS 6 18.10.2010 21:07
Problem Browserweiche IE CSS 00001 CSS 5 24.09.2010 11:23
Problem mit CSS relative, absolute & float FrageHabe CSS 3 13.08.2010 15:40
habe eine problem mit html + css madlarkin CSS 6 12.01.2006 14:24


Alle Zeitangaben in WEZ +2. Es ist jetzt 14:34 Uhr.