zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden CSS-Referenz führt zu IE7-Interpretation im IE8

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 09.12.2010, 13:13
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 09.12.2010
Beiträge: 6
moon_dog befindet sich auf einem aufstrebenden Ast
Standard CSS-Referenz führt zu IE7-Interpretation im IE8

Hallo,

ich habe ein sehr seltsames Problem. Wenn ich in einer HTML-Datei eine CSS-Datei über
HTML-Code:
<link href="/sampleapp/css/jswat.css" rel="stylesheet" type="text/css" media="screen" />
referenziere, oder sogar via <style> ... </style> Styles definiere, dann interpretiert der IE8 die Seite als IE7. Das passiert alles im LAN.
Wenn ich z.B. Startseite - www.arbeitsagentur.de aufrufe, dann interpretiert der IE8 die Seite auch - wie er soll - als IE8. Wenn ich den Quellcode der Startseite kopiere und im LAN auf einen Server spiele, dann interpretiert er den gleichen Quellcode als IE7. Allerdings kann ich den IE über
HTML-Code:
<meta http-equiv="X-UA-Compatible" content="IE=8"/>
dazu bringen, doch als IE8 zu interpretieren.

Ich bin grad echt am Verzweifeln.

Doctypes habe ich schon ausprobiert:
  • XHTML Strict
  • XHTML Transitional
  • HTML 4 Loose

Wäre super, wenn jemand wenigstens einen Ansatz für mich hätte

VG.

Edit:

Hier nochmal mit Referenz: http://imgur.com/RHPeB.png
und ohne: http://imgur.com/dNWQH.png

Geändert von moon_dog (13.12.2010 um 17:14 Uhr)
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 09.12.2010, 15:00
{ display: random;}
XHTMLforum-Kenner
 
Registriert seit: 08.09.2004
Ort: Stuttgart
Beiträge: 5.042
andir ist ein wunderbarer Anblickandir ist ein wunderbarer Anblickandir ist ein wunderbarer Anblickandir ist ein wunderbarer Anblickandir ist ein wunderbarer Anblickandir ist ein wunderbarer Anblick
Standard

Nö mit der CSS-referenz hat das wohl nichts zu tun.

Wenn Du deine Seiten UTF-8 codiert abspeicherst, liegt es wohl eher an einem BOM (byte order mark) welches dein Editor am Anfang jeder utf-8 Datei reincodiert.

Schau mal in deinen Editor-Einstellungen nach, ob es eine Option gibt, das BOM NICHT zu generieren... und wende diese an. Deine Probleme sollten damit gelöst sein.

Edit: Entsprechende Dateien natürlich nochmal speichern
__________________
Grüsse Andreas- auch mal wieder da...

Design isn't about the tools, it's about creating the best experience for the user. A design should be based on usability, accesibility, aesthetics, but never on floats, lists or background images. ( by Cameron Adams)
Wiedergelesen: > hier und hier

[Foren-Links] Dein Post? Klar, DAS vorher gelesen? Hilft. ## User-Landkarte
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 09.12.2010, 16:46
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 09.12.2010
Beiträge: 6
moon_dog befindet sich auf einem aufstrebenden Ast
Standard

Hat leider nicht funktioniert. Hab eine HTML-Datei aus dem Eclipse-Workspace genommen und mit Notepad++ das Format auf UTF8-ohne-BOM geändert. Dann deployed und es war noch immer eine IE7-Interpretation.

Dann habe ich wieder

HTML-Code:
<meta http-equiv="X-UA-Compatible" content="IE=8"/>
eingefügt und es hat funktioniert. Nur bei meinen JSP-Dateien schlägt die Meta-Information nicht ordentlich an.
Mit Zitat antworten
  #4 (permalink)  
Alt 09.12.2010, 16:50
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.778
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Vermutlich steht in den Kompatibilitäts-Modus-Einstellungen des IE8 noch, dass "Intranetsites" im Komp.-Modus angezeigt werden sollen.
Mit Zitat antworten
  #5 (permalink)  
Alt 09.12.2010, 16:54
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 09.12.2010
Beiträge: 6
moon_dog befindet sich auf einem aufstrebenden Ast
Standard

Das wäre schlecht, kann aber gut sein, weil unser Intranet ziemlich bescheiden aussieht, wenn man es im IE8 interpretiert. Dann hätte ich wirklich ein Problem.
Mit Zitat antworten
  #6 (permalink)  
Alt 09.12.2010, 16:55
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.778
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Es ist eine Einstellung in deinem IE8.
Extras - Einstellungen der Komp.Ansicht - Intranetsites ...
Haken wegmachen.
Mit Zitat antworten
  #7 (permalink)  
Alt 10.12.2010, 08:35
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 09.12.2010
Beiträge: 6
moon_dog befindet sich auf einem aufstrebenden Ast
Standard

Hi, du hattest recht. Wenn ich den Haken entferne, dann geht alles. Allerdings ist der Haken von den Admins in jedem Browser in der Firma gesetzt.

Aber was ich mich frage ist, woran es liegen könnte, dass ich mit der Meta-Information auf manchen Seiten den IE8-Modus erzwingen kann und auf anderen nicht.
Mit Zitat antworten
  #8 (permalink)  
Alt 13.12.2010, 12:08
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 09.12.2010
Beiträge: 6
moon_dog befindet sich auf einem aufstrebenden Ast
Standard

Ok, das Problem hat sich scheinbar endlich gelöst.

Es ist tatsächlich so, dass über Extras > Einstellung der Kompatibilitätsansicht > Intranetsites in Kompatibilitätsansicht anzeigen eingestellt war, dass alle Seiten im IE7-Modus interpretiert werden.

Weiterhin kann man über das Meta-Tag
Code:
<meta http-equiv="X-UA-Compatible" content="IE=8"/>
angeben, dass doch im IE8-Modus interpretiert werden soll.

Bei einigen Seiten ging das, bei anderen wiederum nicht. Die Antwort über dieses abweichende Verhalten ist, dass bei denen, bei denen es nicht funktioniert hat, vor dem Meta-Tag schon CSS-Dateien geladen wurden. Der IE8 braucht beim Laden der CSS-Dateien allerdings schon eine Information wie er zu interpretieren hat. Da noch nichts angegeben wurde, gelten die Angaben unter Extras > Einstellung der Kompatibilitätsansicht > Intranetsites in Kompatibilitätsansicht anzeigen und das Meta-Tag nach den CSS-Imports wird ignoriert.

Lösung war also, dass man das Meta-Tag vor die CSS-Imports schreibt.

Ich hoffe das stand nicht auf der Microsoft-Seite, aber werde auch nicht nachschauen, sonst muss ich mich nur ärgern
Mit Zitat antworten
  #9 (permalink)  
Alt 13.12.2010, 12:39
Benutzerbild von heiko_rs
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2005
Ort: Berlin
Beiträge: 9.858
heiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblick
Standard

Zitat:
Zitat von Microsoft
er muss im Header der Webseite (im Abschnitt „HEAD“ ) vor allen anderen Elementen außer dem TITLE-Element und anderen META-Elementen stehen.
META-Tags und Sperren für zukünftige Kompatibilität
__________________
Wer keinen Link auf seine problembehaftete Seite posten kann, weil diese noch nicht online ist: Testcase bauen, online stellen, Link posten.
Internet-Grundregel: Unbekannte Begriffe googeln! (Erspart 99% aller Nachfragen.)
Mit Zitat antworten
Sponsored Links
  #10 (permalink)  
Alt 13.12.2010, 14:53
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 09.12.2010
Beiträge: 6
moon_dog befindet sich auf einem aufstrebenden Ast
Standard

-.- War mir klar.
Mit Zitat antworten
Sponsored Links
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
CSS Sprite wird vom IE8 komplett falsch angezeigt phpheld CSS 10 12.02.2011 23:03
CSS Tips & Tricks Webnauts Ressourcen 0 25.08.2006 23:04
CSS Interpretation Firefox und IE - Grundgerüsst verzerrt EvilGeorge CSS 2 26.10.2005 13:22
CSS Hacks werden zum Problem für IE7 Floele Offtopic 24 17.10.2005 11:31
problem mit css interpretation von IE - Opera - Mozilla captain CSS 2 03.03.2004 13:15


Alle Zeitangaben in WEZ +2. Es ist jetzt 02:15 Uhr.