zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden fieldset und der Internet Explorer

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 05.11.2010, 14:58
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 02.10.2010
Beiträge: 28
RFDarter befindet sich auf einem aufstrebenden Ast
Standard fieldset und der Internet Explorer

Hey

Ich habe ein Fieldset bei einer Registrierung:

HTML-Code:
<fieldset class="regi_fields">
   <legend class="regi_fields_legend">Username</legend>
   <table>
       <tbody class="regi_Username">
           <tr>
               <td>
                   Bitte geben Sie einen Benutzernamen an.
                   <br>
                   <span id="regi_error">
                   <?php
                   if( isset($data['error']['singup_Username']) && $data['error']['singup_Username'] !== '' ){
                       echo $data['error']['singup_Username'];
                   }else{
                       echo '&nbsp;';
                   }
                   ?>
                   </span>
               </td>
           </tr>
           <tr>
               <td>
                   <strong>Username:</strong>
               </td>
           </tr>
           <tr>
               <td>
                   <?php
                   if( isset($data['singup_data']['singup_Username']) && $data['singup_data']['singup_Username'] !== '' &&
                       !isset($data['error']['singup_Username'])){
                       echo '<input type="text" class="regi_field" name="singup_Username" value="'.$data['singup_data']['singup_Username'].'"/>';
                   }else{
                       echo '<input type="text" class="regi_field" name="singup_Username" />';
                   }
                   ?>

               </td>
           </tr>
       </tbody>
   </table>
</fieldset>
nun habe ich dem Fieldset in meiner css datei ein Hintergrund verpasst:

HTML-Code:
   fieldset.regi_fields {
         border:1px #000000 solid;
         padding:10px;
         background:#9a0101 url("../Images/Layout/regi_boxes.png") repeat-y ;
   }

   legend.regi_fields_legend {
         /*padding-left:5px;
         padding-right:5px;*/
         font-weight:bold;
         border:1px #000000 solid;
         padding:5px;
         background:#9a0101 url("../Images/Layout/regi_boxes.png") repeat-y ;
   }
Im FF, Opera, Safari und Seamonkey wird alles gut angezeigt, der hintergrund des Fieldsets passt aber im IE macht das ganze irgendwie zicken:



Ich weiß nicht ob man es erkennt kann aber der hintergrund wir auch über dem fieldset angezeigt, aber warum?

Ich habe auch schon probiert ne div box ins fieldset zu setzen und darin das hintergrundbild anzuzeigen, aber das funktioniert gar nicht .

mfg
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 05.11.2010, 15:44
Benutzerbild von nevermind
Trollflüsterer
XHTMLforum-Kenner
 
Registriert seit: 29.08.2005
Ort: Bietigheim-Bissingen
Beiträge: 2.221
nevermind ist ein Lichtblicknevermind ist ein Lichtblicknevermind ist ein Lichtblicknevermind ist ein Lichtblicknevermind ist ein Lichtblicknevermind ist ein Lichtblick
Standard

Code:
<form>
   <fieldset>
      <ol>
         <li>label, input</li>
         <li>input</li>
      </ol>
   </fieldset
</form>
...verwende ich - funktioniert ganz gut.
__________________
Gruß Roman // ngkreativ.de - Webdesign & Motorradumbau
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 05.11.2010, 20:18
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 10.12.2006
Beiträge: 888
threadi sorgt für eine eindrucksvolle Atmosphärethreadi sorgt für eine eindrucksvolle Atmosphäre
Standard

Das ist ein bekannter Bug, schau dir mal das an:
The IE Fieldset Background Color Bleed Bug
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Breite & Internet Explorer 6 Innocentus CSS 3 01.04.2009 21:45
position probleme mit dem internet explorer alejandro CSS 6 11.02.2008 14:54
layout zerschossen im internet explorer opentyper CSS 2 02.08.2007 12:57
Merkwürdiger Box-Abstand im Internet Explorer SPACEart CSS 20 05.09.2005 14:28
Internet Explorer am robustesten Anonymous Offtopic 2 20.10.2004 16:17


Alle Zeitangaben in WEZ +2. Es ist jetzt 02:35 Uhr.