zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > (X)HTML
Seite neu laden Hintergrundbilder, a:hover im firefox

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 21.10.2010, 12:03
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 21.10.2010
Beiträge: 2
joergl befindet sich auf einem aufstrebenden Ast
Standard Hintergrundbilder, a:hover im firefox

Hallo zusammen,

ich habe ein (größeres) Problem:

Ich habe einen Div-container mit Hintergrundbild angelegt (Größe 798x532 px) in dem sich der gesamte Inhalt befindet.
Auf der Startseite möchte ich 4 Links in Blockform (je 399x266 px, mit Hintergrundbildern und veränderten Hintergründen bei a:hover) angezeigt haben.

Hier der Code für den ersten Link in der CSS-Datei:

#all {
position:absolute;
top:50%;
left:50%;
width:798px;
height:532px;
margin-left:-399px;
margin-top:-266px;
background-image:url(../Bilder/HG.jpg);
}

.nav1 span {
display: none;
}
.nav1:link {
display: block;
width: 399px;
height: 266px;
position: absolute;
top: 0px;
left: 0px;
background: url(../Bilder/Bild 1.jpg);
}

.nav1:visited {
display: block;
width: 399px;
height: 266px;
position: absolute;
top: 0px;
left: 0px;
background: url(../Bilder/Bild 1.jpg);
}

.nav1:hover {
display: block;
width: 399px;
height: 266px;
position: absolute;
top: 0px;
left: 0px;
background: url(../Bilder/Bild 1 akt.jpg);
}

Der Code im HTML:

<div id="all">
<a href="seite.html" class="nav1"><span>seite</span></a>
</div>


Das funktioniert im IE ohne Probleme, der Firefox zeigt nur das HG-Bild des Containers, aber keinerlei weitere (Link)-Hintergründe.

Das gleiche Problem habe ich auch bei 2 ineinander gelegten Div-Containern. Beim 2. wird kein Hintergrundbild angezeigt.

Kann mir jemand helfen?

Vielen Dank im voraus.

joergl
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 21.10.2010, 12:06
$("#mettbröttchen");
XHTMLforum-Mitglied
 
Registriert seit: 28.09.2010
Ort: Bremen
Beiträge: 448
zeji wird schon bald berühmt werden
Standard

öhm bei den Bildern, sind das zwischen "Bild" und z.b "1" leerzeichen? wenn ja änder die mal in _
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 21.10.2010, 12:14
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 21.10.2010
Beiträge: 2
joergl befindet sich auf einem aufstrebenden Ast
Standard

Das wars... und ich such mich kaputt...

Vielen Dank...
Mit Zitat antworten
  #4 (permalink)  
Alt 21.10.2010, 12:19
$("#mettbröttchen");
XHTMLforum-Mitglied
 
Registriert seit: 28.09.2010
Ort: Bremen
Beiträge: 448
zeji wird schon bald berühmt werden
Standard

xD manchmal sind die trivialsten Sachen schuld^
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Seite links ausrichten like.no.other CSS 10 26.01.2011 01:10
z-index hoch, dennoch grafik nicht ganz oben bergg CSS 6 27.10.2010 16:02
Ungewöhnlicher abstand beim clearen von floats adrianno CSS 14 16.09.2009 14:20
Hilfe bei Positionierung eines Menüs opa-rudi CSS 0 18.11.2008 11:21
#boxes a:hover.info: 2.posting mit css !!! marioN CSS 5 25.01.2004 17:04


Alle Zeitangaben in WEZ +2. Es ist jetzt 05:53 Uhr.