zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Problem mit CSS in HTML einfügen

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 16.10.2010, 12:35
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 16.10.2010
Beiträge: 6
Chizzo befindet sich auf einem aufstrebenden Ast
Standard Problem mit CSS in HTML einfügen

Hallo,

habe folgende Codes:

Code:
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">



<head>

<link rel="stylesheet" type="text/css"
media="screen" href="design.css" />


<title>Beschreibung der Seite</title>

</head>

<body>


<div id="navi">
<ul>
<li>Startseite</li>
<li>Impressum</li>
</ul>
</div>


<div id="inhalte">
Hier HTML und CSS lernen und die 
eigene Website erstellen - selbst ist der Mensch
</div> 



</body>

</html>
Code:
<style type="text/css">
 <!--

 #navi {
   float:left;
   background-color:thistle;
   width:  150px;
 }
 
 #inhalte {
   background-color:lightblue;
   margin-left: 200px;
   width:  300px;
   height: 100px;
 }
 -->
 </style>

Das Problem: Den Inhalt zeigt mir mein Browser so an wie ich es haben möchte (Mit Rahmen, Farbe usw...). Die Navigation allerdings nicht... habs schon mit nem Validierungstool versucht das zeigt mir keine Fehler mehr an... Wo liegt mein Fehler? Muss ja einer da sein...

PS: Funktioniert weder im IE noch im Firefox.

Gruß
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 16.10.2010, 12:55
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 10.01.2010
Beiträge: 1.103
MrMurphy ist ein sehr geschätzer MenschMrMurphy ist ein sehr geschätzer MenschMrMurphy ist ein sehr geschätzer Mensch
Standard

Hallo,

der von dir gepostete Quelltext wird genau so angezeigt, wie du ihn eingegeben hast.

Ist das überhaupt der richtige? Einen Rahmen vermag ich darin nämlich nicht zu erkennen.

Außerdem solltest du etwas genauer beschreiben, was du mit

Zitat:
Die Navigation allerdings nicht..
meinst. Wir können kaum wissen, wie du die Navigation angezeigt haben möchtest, ohne das du das genauer beschreibst.

Gruss

MrMurphy
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 16.10.2010, 13:00
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 16.10.2010
Beiträge: 6
Chizzo befindet sich auf einem aufstrebenden Ast
Standard

Der Inhalt hat die Hintergrundfarbe lightblue, die Navigation soll in thistle erscheinen... tut sie aber nicht... Außerdem soll der Kasten 150px weit sein, ist er aber nicht... ist ja nicht mal einer da...
Mit Zitat antworten
  #4 (permalink)  
Alt 16.10.2010, 13:08
Benutzerbild von plastiko
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 26.12.2007
Ort: Hannover
Beiträge: 945
plastiko ist ein Lichtblickplastiko ist ein Lichtblickplastiko ist ein Lichtblickplastiko ist ein Lichtblickplastiko ist ein Lichtblick
Standard

design.css darf kein html enthalten.
__________________
MfG
Jens
Mit Zitat antworten
  #5 (permalink)  
Alt 16.10.2010, 13:10
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 16.10.2010
Beiträge: 6
Chizzo befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von plastiko Beitrag anzeigen
design.css darf kein html enthalten.
Aaaaaahhhhhhhhhh es geht manchmal sind die Fehler sooo einfach das man sie gar nicht sieht, lol... Vielen, vielen Dank!!!
Mit Zitat antworten
  #6 (permalink)  
Alt 18.10.2010, 16:52
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 16.10.2010
Beiträge: 6
Chizzo befindet sich auf einem aufstrebenden Ast
Standard

Also das hab ich jetzt hingekriegt... jetzt hab ich das nächste problem...


http://i51.tinypic.com/2emz978.jpg

Da sieht man, dass das Navi und die Inhalte auf versch. Höhen sind. Wie krieg ich das hin, dass sich die beiden auf gleicher Höhe befinden?

Hier der Quellcode:

Code:
* {margin:0; pardding:0;}

#navi {
float:left;
}


#navi ul {
list-style:none;
}


#navi li {
   background-color:silver;   
   border-top:1px black solid;    
   border-left:25px orange solid; 
   border-bottom:1px red solid;   
   border-right:2px blue solid;   
   margin-top:10px;            
   padding-top:5px;              
   padding-bottom:8px;       
   padding-left:8px;             
   padding-right:8px;          
 } 





#inhalte {

margin-left: 180px;
margin-top:35px;
width: 650px;
heigth: 400px;
background-color:orange;
color:blue;

}

a:visited {

font-family:arial;
font-size:14px;
color:blue;
}

a:link {

font-family:arial;
font-size:14px;
color:blue;
}

a:hover {

font-family:arial;
font-size:18px;
color:green;
}
Mit Zitat antworten
  #7 (permalink)  
Alt 18.10.2010, 20:07
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 10.12.2006
Beiträge: 887
threadi sorgt für eine eindrucksvolle Atmosphärethreadi sorgt für eine eindrucksvolle Atmosphäre
Standard

Schreibfehler "pardding" beseitigen.
Und das margin für #inhalte überdenken.
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit CSS relative, absolute & float FrageHabe CSS 3 13.08.2010 14:40
CSS Mouseover Bildwechsel Problem Kevin-Kai CSS 6 24.06.2010 19:29
einzelne Zeichen per CSS einfügen ? Geht das ? Saturnknight CSS 6 09.05.2010 11:48
Html & CSS problem mottzi CSS 1 25.03.2010 20:39
habe eine problem mit html + css madlarkin CSS 6 12.01.2006 13:24


Alle Zeitangaben in WEZ +2. Es ist jetzt 22:15 Uhr.