zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Background-Grafik neben navi-li Elementen - IE Probleme

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 14.09.2010, 10:01
ziemlich neu
neuer user
Thread-Ersteller
 
Registriert seit: 19.08.2010
Beiträge: 22
BobbyKreuzberg befindet sich auf einem aufstrebenden Ast
Frage Background-Grafik neben navi-li Elementen - IE Probleme

Ich habe eine vertikale Navi-Liste, bei der mit einem kleinen Pfeil als background-Grafik angezeigt werden soll, in welchem Menüpunkt man sich gerade befindet.

Code:
li#lino06 { 
		background-image: url(images/menuarrow.gif); 
		background-position: 0px 0px; 
		background-repeat: no-repeat; 
}
Dies alles wird korrekt dargestellt, auch im IE <8. Nur wenn ich die Unterstreichungen der li-Links mit

Code:
  a { background:transparent; text-decoration:none; color:#444;}
herausnehme, wird der Pfeil nicht mehr im IE7 dargestellt.

Das Ganze ist zu bewundern hier, einmal mit text-decoration:none
testcase

und einmal mit Unterstrichen, hier wird der Pfeil überall korrekt dargestellt
testcase

Als Framwork habe ich YAML verwendet. Ich würde mich freuen, wenn jemand einen Anhaltspunkt hätte.
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 14.09.2010, 10:14
Benutzerbild von Praktikant
Semantikbremse.
XHTMLforum-Kenner
 
Registriert seit: 22.04.2008
Beiträge: 4.992
Praktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz seinPraktikant kann auf vieles stolz sein
Standard

Die Anweisung background:transparent; würde ich rauslassen.

Im FF3.6.9 kann ich im übrigen auch nicht davon sprechen, dass alle Pfeile korrekt dargestellt werden, aber ich weiß auch nicht was korrekt ist und was nicht. Die Pfeile sind aber bei jedem Link wo anders.
__________________
Rettet die Erde.... sie ist der einzige Planet mit Schokolade!
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 14.09.2010, 11:15
ziemlich neu
neuer user
Thread-Ersteller
 
Registriert seit: 19.08.2010
Beiträge: 22
BobbyKreuzberg befindet sich auf einem aufstrebenden Ast
Standard

background:transparent; steht da, weil noch ein Logo im Hintergrund dazu kommt.

Zusätzlich zum einen statischen Pfeil gibt es noch ein li:hover, das auch noch einmal die Pfeile anzeigt.
Mit Zitat antworten
  #4 (permalink)  
Alt 14.09.2010, 11:22
ziemlich neu
neuer user
Thread-Ersteller
 
Registriert seit: 19.08.2010
Beiträge: 22
BobbyKreuzberg befindet sich auf einem aufstrebenden Ast
Standard

ich glaube, es hat sich schon erledigt. Statt
Code:
a { background:transparent; text-decoration:none; color:#444;}
a:link  {  text-decoration:none;  }
steht da jetzt
Code:
ul a {
		list-style-type:none;
		text-decoration:none; 
		color:#444; }
und das funktioniert auch im IE.

http://test67231.test-account.com/editingcss/index.htm
Mit Zitat antworten
Antwort

Stichwörter
background-image, ie7, yaml

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Headerbild einsetzten Demmin CSS 1 08.03.2011 03:58
Boxen von Navigation und Logo sind zu weit auseinander lila_3 CSS 2 03.09.2009 23:28
Problem mit CSS Style flo007 CSS 3 25.01.2009 17:08
Css Neuling Bräuchte Hilfe wc3_monster CSS 2 03.12.2008 22:23
Alles verschoben bei mir im Template!! Was nun? mar123 CSS 7 17.06.2005 15:58


Alle Zeitangaben in WEZ +2. Es ist jetzt 14:15 Uhr.