zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > (X)HTML
Seite neu laden CSS-Styles werden bei einem Linksprung von Webseite A auf Webseite B nicht geladen

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 10.09.2010, 22:54
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 14.08.2010
Beiträge: 15
Fools befindet sich auf einem aufstrebenden Ast
Standard CSS-Styles werden bei einem Linksprung von Webseite A auf Webseite B nicht geladen

Hallo!


Ich hab da mal ein Problem!


Beim Aufruf von einer Webseite 'A' auf eine andere Webseite 'B' tritt das Problem auf, dass Webseite 'B' meine für diese Seite definierten CSS-Styles aus meiner CSS-Datei nicht einliest und somit alles unformatiert erscheint.

Bei einem direkten Aufruf meiner Webseite 'B' (also ohne den expliziten Sprung von 'A' auf 'B'), wird die Seite jedoch sauber formatiert angezeigt.

Das Problem tritt übrigens sowohl mit dem Firefox als auch mit den Internet Explorer 8 auf.


Ich hab eine Vermutung woran es liegen könnte:

Webseite 'A' und Webseite 'B' liegen in unterschiedlichen Ordnern.

Meine Ordnerstruktur sieht wie folgt aus:

- WebContent
- - pages
- - - tmp
- - - - B.xhtml
- - - A.xhtml
- - resources
- - - css
- - - - default.css

"WebContent" als Root-Ordner, der zwei weitere Ordner beinhaltet ("pages" und "resources"). In "pages" befindet sich ein weiterer Ordner "tmp" und die Datei "A.xhtml". Im Ordner "tmp" befindet sich die Datei "B.xhtml". Der Ordner "resources" beinhaltet ein Ordner "css", der wiederum die Datei "default.css" beinhaltet.



Pack ich meine Webseite 'A' in den gleichen Ordner von Webseite 'B', dann gibt es keine Probleme.


Ich möchte aber ungern meine Ordner-/Dateihierarchie ändern.


Weiß jemand wie ich das Problem lösen kann?


HTML-Code der Webseite 'A':
HTML-Code:
<?xml version="1.0" encoding="UTF-8" ?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <link href="../resources/css/default.css" type="text/css" rel="stylesheet" />       
    </head>

    <body>
usw.

HTML-Code der Webseite 'B':
HTML-Code:
<?xml version="1.0" encoding="UTF-8" ?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <link href="../../resources/css/default.css" type="text/css" rel="stylesheet" />
    </head>

    <body>
usw.

Geändert von Fools (10.09.2010 um 22:59 Uhr)
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 11.09.2010, 01:26
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 14.08.2010
Beiträge: 15
Fools befindet sich auf einem aufstrebenden Ast
Standard

Kleiner Nachtrag:

Wenn ich mir über einen x-beliebigen Internet-Browser den Quellcode der Webseite 'B' anschaue, dann sehe ich ja meinen geschriebenen Code für diese Seite.

Unter anderem sehe ich natürlich auch die folgende Zeile:

HTML-Code:
<link href="../../../resources/css/default.css" type="text/css" rel="stylesheet" />
Wenn ich im Quellcode auf "../../../resources/css/default.css" klicke, dann springt ja man normalerweise direkt in den Quellcode der entsprechenden Datei (hier: default.css). Ich musste feststellen, wenn ich das tue, dann zeigt mir mein Browser eine leere Seite ohne Quellcode.


Wie gesagt, dass alles passiert nicht, wenn ich Webseite 'B' direkt aufrufe und nicht vorher von Webseite 'A' auf Webseite 'B' bin.
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 11.09.2010, 13:42
Benutzerbild von heiko_rs
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2005
Ort: Berlin
Beiträge: 9.858
heiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblick
Standard

Ich würde immer root-relative referenzieren:

Code:
<link href="/resources/css/default.css" type="text/css" rel="stylesheet" />
__________________
Wer keinen Link auf seine problembehaftete Seite posten kann, weil diese noch nicht online ist: Testcase bauen, online stellen, Link posten.
Internet-Grundregel: Unbekannte Begriffe googeln! (Erspart 99% aller Nachfragen.)
Mit Zitat antworten
  #4 (permalink)  
Alt 13.09.2010, 12:57
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 14.08.2010
Beiträge: 15
Fools befindet sich auf einem aufstrebenden Ast
Standard

Konnte leider nicht eher zurück schreiben:

Wollte mich noch mal bedanken.
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
CSS Styles eingebettet in html stabmixer CSS 5 22.06.2005 12:07
Mit CSS eingebundene Bilder werden immer neu geladen lomtas CSS 8 06.05.2005 18:56
CSS wird im FF nicht ganz geladen Philippp CSS 7 05.05.2005 10:51
CSS Styles werden nicht schnell genug geladen chrh CSS 5 14.04.2005 11:48
IE igoniert Styles aus externer CSS in <FORM> und utf- tbienk (X)HTML 3 22.10.2004 17:34


Alle Zeitangaben in WEZ +2. Es ist jetzt 15:37 Uhr.