XHTMLforum

XHTMLforum (http://xhtmlforum.de/index.php)
-   CSS (http://xhtmlforum.de/forumdisplay.php?f=73)
-   -   Rahmen oben (div) wird nicht angezeigt (http://xhtmlforum.de/showthread.php?t=58175)

yyyy 20.08.2009 14:43

Rahmen oben (div) wird nicht angezeigt
 
Hallo,

da ich das Problem einfach nicht gelöst bekomme versuche ich es hier.
Der div #rahmenoben wird einfach nicht angezeigt ...

Hier der Link zur Seite (hab das css in der index.html gelassen):
SEITE

Code:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Lebensimpulse</title>
<style type="text/css">
#body {
        background: #ffffff url(hintergrundgrafik.png) 0 0 repeat-x;
}
/*um die seite zu positionieren*/
#seitenposition {
        padding-left:170px;
        padding-top:30px;
        width:935px;
        }
#rahmenoben {
        margin-left:8px;
        padding-top:8px;
        background: url(rahmenoben.png)  repeat-x no-repeat y left top;
        width:936px;
}
#rahmenlinks {
        padding-left:8px;
        background: url(rahmenlinks.png) repeat-y left;
}

#seitenhintergrund {
        background-color:#FFF;
       
}
       
#rahmenrechts {
        width:944px;
        background: url(rahmenrechts.png) repeat-y right;
        }

#header {
        padding-left:15px;
        padding-top:15px;
        width:920px;
        height:82px;
        background-color:#FFF;
}

#submenu {
        width:935px;
        text-align:right;
        font-family: Verdana, Arial, Helvetica, sans-serif;
        font-size: 15px;
        line-height: 165%;
        background: #ffffff url() repeat-x 100% 100%;
       
}       

#navigation {
        float:left;
        width:150px;
        font-family: Verdana, Arial, Helvetica, sans-serif;
        font-size: 12px;
        line-height: 165%;
        color: #646464;
        clear:both;
}



#inhalt {
        margin-left:175px;
        width:725px;
        background: #fff;
        padding-right:35px;
       
}

[...]
.clear {
        clear:both;
        font-size:0px;
}
       
</style>
</head>

<body id="body">
   
    <div id="seitenposition">
    <div id="rahmenoben"></div>
    <div id="rahmenlinks">
    <div id="seitenhintergrund">
     
      <div id="rahmenrechts">
       
        <div id="header">
        <img src="logo.png" width="300" height="62" />
        </div>
     
              <div id="submenu"><strong>und Pyschotherapie</strong></div>
     
                <div id="navigation">
[...]
<div id="inhalt">
[...]
</div>
                  <div class="clear">&nbsp </div>
</div>
</div>
</div>
</div>
</body>
</html>

Gibt es vielleicht noch eine einfachere Methode einen ordentlichen Rahmen dran zu bekommen, der gut aussieht ?

DANKE und lg yyyy

heiko_rs 20.08.2009 14:58

Er wird angezeigt, aber seine fehlerhafte background-Deklaration wird ignoriert.

Aber leere Elemente sind eh tabu, gib die Grafik #seitenposition.

yyyy 20.08.2009 15:05

dann würde ja der ganze hintergrund den rahmen bekommen ...

heiko_rs 20.08.2009 15:12

Das kannst Du doch per repeat steuern.

yyyy 20.08.2009 15:37

jetzt tritt ein anderes Problem auf...

der rand rechts wird nach dem einfügen des randes unten nicht mehr angezeigt

(quelltext oben ist veraltet)

Praktikant 20.08.2009 15:42

Über #rahmenrechts ist eine "}" zuviel. Nehm die raus und er wird gezeigt.

yyyy 20.08.2009 15:45

ty hatte es gerade eben selbst bemerkt.

gibt es keine einfachere Möglichkeit en ordentlichen rahmen hin zu bekommen ?


Alle Zeitangaben in WEZ +2. Es ist jetzt 13:12 Uhr.

Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

© Dirk H. 2003 - 2020