zurück zur Startseite
  


Zurück XHTMLforum > Webentwicklung (außer XHTML und CSS) > Serveradministration und serverseitige Scripte
Seite neu laden SMTP Server einrichten [Mercury, Win03 Server]

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 18.08.2009, 18:23
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 07.04.2007
Beiträge: 311
ct2oo4 befindet sich auf einem aufstrebenden Ast
Frage SMTP Server einrichten [Mercury, Win03 Server]

Hallo Community,

ich habe seit Neustem einen Windows Server 2003 in unserem Rechenzentrum.
Darauf läuft eine Website.

Der eigentliche Admin hat bereits Xampp installiert (Ich weis, dass Xampp nicht für den produktiven Einsatz gedacht ist ).
Ich habe Remotedesktopzugang und Adminrechte.

Folgendes Problem: Ich möchte einen SMTP Server aufsetzen, damit ich mittels PHP Emails versenden kann. Und nun suche ich natürlich geeignete Links oder jmd, der mir erklären kann wie ich mit Hilfe von Mercury einen SMTP Server aufsetzen kann.
Ich habe mich bereits belesen und erfahren, dass man mit Mercury allein keinen SMTP Server erstellen kann, sondern nur externe Server angeben kann. Daher habe ich schon den Mailserver(POP3,SMTP)-dienst von Windows installiert. Die Konfiguration des Selbigen macht mir allerdings einige Probleme.

Wie kann ich testen ob der SMTP Server auch läuft? Wie spreche ich ihn an - smtp.RechnerIpAdresse?

Den POP3 Diernst benötige ich eigentlich nicht, da der andere Admin bereits bei der TopLevelDomain Einrichtung Weiterleitungen auf andere Emailadresse eingerichtet hat.

Im engeren Sinne möchte ich nur ein Kontaktformular auf der Seite anbieten und dazu halt keinen externen SMTP Server nutzen. Das einfach deswegen, da ich nun mal den Server zur Verfügung habe und darauf natürlich alles installieren und laufen lassen will.

Ich hoffe ihr könnte mir helfen

Danke schon im Voraus!


Mit freundlichen Grüßen

ct2oo4
__________________
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 18.08.2009, 19:54
Benutzerbild von laborix
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 11.12.2005
Beiträge: 1.494
laborix ist ein sehr geschätzer Menschlaborix ist ein sehr geschätzer Menschlaborix ist ein sehr geschätzer Mensch
Standard

Zitat:
Zitat von ct2oo4 Beitrag anzeigen
Der eigentliche Admin hat bereits Xampp installiert (Ich weis, dass Xampp nicht für den produktiven Einsatz gedacht ist ).
Ich habe Remotedesktopzugang und Adminrechte.
"Der eigentliche Admin?" Wer ist das?

Zitat:
Zitat von ct2oo4 Beitrag anzeigen
Ich hoffe ihr könnte mir helfen
Hier mal ein Ansatzpunkt, eventuell hilft es:
Mail Script versendet keine Mails nach Xampp installation - php.de

http://www.administrator.de/index.php?content=54034

http://www.apachefriends.org/f/viewtopic.php?p=34350
__________________
Personal stuff

Geändert von laborix (18.08.2009 um 20:02 Uhr)
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 18.08.2009, 20:22
Benutzerbild von Scheppertreiber
Chaot und Nonkonformist.
XHTMLforum-Kenner
 
Registriert seit: 13.03.2007
Ort: Steinmark im Spessart
Beiträge: 7.457
Scheppertreiber ist ein LichtblickScheppertreiber ist ein LichtblickScheppertreiber ist ein LichtblickScheppertreiber ist ein LichtblickScheppertreiber ist ein Lichtblick
Standard

Ist der Support/Entwicklung für Mercurs nicht eingestampft ?

Ich habe den auch. Ich kann auch Mails per Programm versenden. Halt C und kein PHP.
__________________
Grüße aus dem Spessart, Joe

{ table-layout: biertischistbesser; }
Der Mausinator
Mit Zitat antworten
  #4 (permalink)  
Alt 18.08.2009, 20:32
Benutzerbild von laborix
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 11.12.2005
Beiträge: 1.494
laborix ist ein sehr geschätzer Menschlaborix ist ein sehr geschätzer Menschlaborix ist ein sehr geschätzer Mensch
Standard

Zitat:
Zitat von Scheppertreiber Beitrag anzeigen
Ist der Support/Entwicklung für Mercurs nicht eingestampft ?
Möglich, vor vielen Jahren hatte ich den unter Novell Netware 4.11 am Laufen. Ist schon lange her

Warum man aber auf einem Windows 2003 Server mit XAMPP arbeiten muss, verstehe ich nicht. Für IIS 6 stehen zig-tausend Blogeinträge in allen möglichen Sprachen zur Verfügung, um fast jeden Fall zu lösen
__________________
Personal stuff
Mit Zitat antworten
  #5 (permalink)  
Alt 18.08.2009, 21:10
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 07.04.2007
Beiträge: 311
ct2oo4 befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von Scheppertreiber Beitrag anzeigen
Ist der Support/Entwicklung für Mercurs nicht eingestampft ?

Ich habe den auch. Ich kann auch Mails per Programm versenden. Halt C und kein PHP.
Hallo,

ob und in wie fern Mercury noch entwickelt wird, weis ich nicht. Ich weis nur, dass es bei Xampp gelich mit dabei ist
Wie hast du Mercury konfiguriert, damit du Mail versenden kannst? Hast du ein Tutorial o.ä. zur Hand?


Gruß

ct2oo4
__________________
Mit Zitat antworten
  #6 (permalink)  
Alt 22.08.2009, 13:51
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 07.04.2007
Beiträge: 311
ct2oo4 befindet sich auf einem aufstrebenden Ast
Standard

Hallo Leute,

Mercury habe ich zwar immer noch nicht zum Laufen gebracht, dafür aber habe ich ein neues Programm gefunden:
ArGo Software Design: Mail Freeware Server .NET Freeware

Da man in der Freeware nicht angeben kann, dass Zugriffe von 127.0.0.1 keine SMTP Authentifizierung benötigen sollen, habe ich mich dem Mailpackage von Pear bedient.

folgendes habe ich zum test in ein mail.php geschrieben:
Code:
require_once "pear_mail.php";

$from = "me";
$to = "ZIA";
$subject = "Hi!";
$body = "Hi,\n\nHow are you?";

$host = "localhost";
$username = "webuser";
$password = "ZIA";

$headers = array ('From' => $from,
  'To' => $to,
  'Subject' => $subject);
$smtp = Mail::factory('smtp',
  array ('host' => $host,
    'auth' => true,
    'username' => $username,
    'password' => $password));

$mail = $smtp->send($to, $headers, $body);

if (PEAR::isError($mail)) {
  echo("<p>" . $mail->getMessage() . "</p>");
 } else {
  echo("<p>Message successfully sent!</p>");
 }
?>
Den Code habe ich irgendwo mal kopiert.


Jedenfalls gibt es mir beim Aufruf ein schönes "Message successfully sent!" aus. Schau ich aber ins Programm steht da folgendes:
Authentifizierung erfolgreich etc...

[DLVR 000001 22-08-2009 13:44:19] ERROR: Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht ordnungsgemäß reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat
[DLVR 000001 22-08-2009 13:44:19] Will try next exchanger

Er versucht es meist mit 3 oder 4 verschiedene "exchanger'n"
Danach bricht er ab.

Was ist denn nun wieder falsch? Ich bekomm noch ne Kriese




Gruß

ct2oo4
__________________
Mit Zitat antworten
Antwort

Stichwörter
email, php, server, smtp server, windows, windows 2003 server

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Beim Seitenaufruf schon connect zu anderem Server herstellen Olel (X)HTML 8 01.02.2005 00:14


Alle Zeitangaben in WEZ +2. Es ist jetzt 13:37 Uhr.