zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > (X)HTML
Seite neu laden W3C Fehler und hilflos

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 16.08.2009, 23:30
Hans Wurst
neuer user
Thread-Ersteller
 
Registriert seit: 23.12.2007
Beiträge: 47
hallo2008 befindet sich auf einem aufstrebenden Ast
Standard W3C Fehler und hilflos

Dies ist mein Forum: 2-Wheel-Planet - Alles rund um das Tuning von Zweirädern
Derzeit bin ich auf Fehlerbeseitigung und habe auch schon einige selber korrigieren können.
Leider sind immer noch viele drinnen: [Invalid] Markup Validation of http://www.2-wheel-planet.de/ - W3C Markup Validator
Aber leider mit meinem Latein am Ende
Könnt ihr mir vlt. noch ein paar Tipps geben?

Gruß und Danke.
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 16.08.2009, 23:46
Benutzerbild von Gumbo
XHTMLforum-Kenner
 
Registriert seit: 22.08.2004
Ort: Trier
Beiträge: 2.735
Gumbo ist jedem bekanntGumbo ist jedem bekanntGumbo ist jedem bekanntGumbo ist jedem bekanntGumbo ist jedem bekanntGumbo ist jedem bekannt
Standard

Das &-Zeichen muss auch in Attributwerten durch eine Zeichenreferenz dargestellt werden. Die anderen Fehler hängen mit den SCRIPT-Tags zusammen. Entweder sollte der Code ausgelagert oder in einen CDATA-Block gepackt werden.
__________________
Markus Wulftange
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 16.08.2009, 23:50
Benutzerbild von heiko_rs
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2005
Ort: Berlin
Beiträge: 9.854
heiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblick
Standard

Als erstes: sämtliche & (auch die innerhalb von URLs im href-Attribut!) als & maskieren. Das sagt Dir aber auch der Validator:

Zitat:
An entity reference was found in the document, but there is no reference by that name defined. (...) The most common cause of this error is unencoded ampersands in URLs
und

Zitat:
If you want to use a literal ampersand in your document you must encode it as "&" (even inside URLs!)
Entities werden durch & eingeleitet, und wenn Du z.B. ?ref=485107&site=2234 schreibst, wird dies als Entity &site; verstanden, die aber aus zweierlei Gründen fehlerhaft ist: Erstens ist sie eh nicht existent, und zweitens fehlt ihr das abschließende Semikolon - schreibe es also als &site.

EDIT: Zu spät und außerdem hat Gumbo mehr als nur die erste Validator-Meldung gelesen
__________________
Wer keinen Link auf seine problembehaftete Seite posten kann, weil diese noch nicht online ist: Testcase bauen, online stellen, Link posten.
Internet-Grundregel: Unbekannte Begriffe googeln! (Erspart 99% aller Nachfragen.)
Mit Zitat antworten
  #4 (permalink)  
Alt 17.08.2009, 00:04
Hans Wurst
neuer user
Thread-Ersteller
 
Registriert seit: 23.12.2007
Beiträge: 47
hallo2008 befindet sich auf einem aufstrebenden Ast
Standard

Erstmal vielen Dank.

Ich werde mich dann mal dran machen

Haben Affiliate Seiten eigentlich keine IT-Profis? Weil deren ihre Codes sind eigentlich IMMER irgendwie fehlerhaft
Da in denen ihren AGB´s steht, man darf die Codes nicht verändern, darf man ja auch keine Validator Fehler korrigieren?
Mit Zitat antworten
  #5 (permalink)  
Alt 17.08.2009, 00:15
Hans Wurst
neuer user
Thread-Ersteller
 
Registriert seit: 23.12.2007
Beiträge: 47
hallo2008 befindet sich auf einem aufstrebenden Ast
Standard

So habe diese & Fehler bereinigt.

Es sind leider immer noch ein Haufen Fehler übrig, bei denen ich nicht weiter weiß

Zitat:
Die anderen Fehler hängen mit den SCRIPT-Tags zusammen. Entweder sollte der Code ausgelagert oder in einen CDATA-Block gepackt werden.
???
Mit Zitat antworten
  #6 (permalink)  
Alt 17.08.2009, 00:33
Benutzerbild von heiko_rs
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 18.09.2005
Ort: Berlin
Beiträge: 9.854
heiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblickheiko_rs ist ein wunderbarer Anblick
Standard

Dein JS-Code gehört nicht in HTML-Kommentare innerhalb eines script-Elementes, sondern entweder in eine externe Datei (beste Lösung für Code, der sich auf mehreren Seiten wiederholt, und Einbindungen externer JS-Dateien hast Du auch bereits in Deinem HTML-Code) oder einen CDATA-Block. Falls Du aus Gumbos Link nicht schlau wirst, hast Du weitere schnell ergoogelt, z.B. Javascript mit CDATA korrekt in XHTML einbinden | mediaVROG Blog
__________________
Wer keinen Link auf seine problembehaftete Seite posten kann, weil diese noch nicht online ist: Testcase bauen, online stellen, Link posten.
Internet-Grundregel: Unbekannte Begriffe googeln! (Erspart 99% aller Nachfragen.)
Mit Zitat antworten
  #7 (permalink)  
Alt 17.08.2009, 01:18
Benutzerbild von Gumbo
XHTMLforum-Kenner
 
Registriert seit: 22.08.2004
Ort: Trier
Beiträge: 2.735
Gumbo ist jedem bekanntGumbo ist jedem bekanntGumbo ist jedem bekanntGumbo ist jedem bekanntGumbo ist jedem bekanntGumbo ist jedem bekannt
Standard

Es gibt auch eine deutsche Übersetzung der XHTML-1.0-Spezifikation.
__________________
Markus Wulftange
Mit Zitat antworten
  #8 (permalink)  
Alt 17.08.2009, 01:19
Hans Wurst
neuer user
Thread-Ersteller
 
Registriert seit: 23.12.2007
Beiträge: 47
hallo2008 befindet sich auf einem aufstrebenden Ast
Standard

So war wohl nen vbseo Fehler.
Auf jeden Fall ist es nun durch diesen Tipp: How to validate with vBseo Virtual HTML? - vBulletin SEO Forums valide
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Redesign für Steiner Cycling Team pkipper Site- und Layoutcheck 11 09.02.2011 13:25
W3C Validator Fehler SpecialFighter (X)HTML 11 06.12.2010 12:52
7 Fehler vom W3C Markup Validation Service empfei (X)HTML 2 02.03.2009 09:53
W3C Validation Service Fehler reflo (X)HTML 14 05.08.2007 01:49
Neue Seite - Fehler laut W3C Pixel Design (X)HTML 25 14.12.2005 11:23


Alle Zeitangaben in WEZ +2. Es ist jetzt 18:19 Uhr.