zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Seltsam, seltsam...

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 12.08.2009, 12:04
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 12.08.2009
Beiträge: 4
McHubi befindet sich auf einem aufstrebenden Ast
Standard Seltsam, seltsam...

Hallo zusammen,

das der IE so manches anders "versteht" als der FF und umgekehrt ist ja normal. Aber das hier ist mir bislang noch nicht untergekommen:

HTML (Auszug) sieht so aus:

Code:
<div class="box_info_2">
  <div class="box_info_2_left">
    ...
  </div>
  <div class="box_info_2_right">
    <a href="http://www.meinedomain.de" title="zur Startseite">
      <img src="upload/bilder/schaltflaeche_startseite.jpg" alt="Bild" title="Bild" height="53px" width="116px">
    </a>
  </div>
</div>


Das passende CSS dazu so:

Code:
div.box_info_2 {
width: 596px;
height: 53px;
background-image: url('../upload/layout/background_div_box_info_2.jpg');
background-repeat: no-repeat;
}

div.box_info_2_left {
width: 470px;
float: left;
}

div.box_info_2_right {
width: 126px;
float: left;
}

Jetzt kommt's:

Im FF 3.5.2 wird die div.box_info_2_right korrekt rechts neben div.box_info_2_left angezeigt. Allerdings ist das Bild nicht als Link aktiviert.

Im IE6 und IE7 nimmt die div.box_info_2_left trotz der Breitenangabe die volle Breite von div.box_info_2 ein und dadurch rutscht div.box_info_2_right in "die nächste Zeile". Hier funktioniert allerdings der auf dem Bild liegende Link tadellos.



Nuja, dass der IE mal nicht so will wie man selbst ist man ja gewohnt, aber dass er nichtmal Breitenangaben respektiert ist schon irgendwie kurios. Einen Fehler kann ich im css nicht erkennen, ebensowenig im html. Und das der FF den ja tatsächlich vorhandenen Link nicht "aktiviert" hab ich auch noch nicht gesehen...

Auch ein Austausch des Bildes durch Text bringt nichts...

Ggf. ein Bug (diesmal im FF)? Oder überseh ich einfach nur eine Kleinigkeit?

Danke für einen Tipp!
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 12.08.2009, 12:16
Benutzerbild von protonenbeschleuniger
Verbesserer
XHTMLforum-Kenner
 
Registriert seit: 06.09.2007
Beiträge: 4.930
protonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblickprotonenbeschleuniger ist ein wunderbarer Anblick
Standard

Zitat:
Zitat von McHubi Beitrag anzeigen
Im FF 3.5.2 wird die div.box_info_2_right korrekt rechts neben div.box_info_2_left angezeigt. Allerdings ist das Bild nicht als Link aktiviert.
Kann ich nicht nachvollziehen, wenn ich deinen Code in ein HTML Dokument einbaue ist der Link aktiviert.

Zitat:
Zitat von McHubi Beitrag anzeigen
Im IE6 und IE7 nimmt die div.box_info_2_left trotz der Breitenangabe die volle Breite von div.box_info_2 ein und dadurch rutscht div.box_info_2_right in "die nächste Zeile". Hier funktioniert allerdings der auf dem Bild liegende Link tadellos.
auch das kann ich nicht nachvollziehen, bei mir sieht es im IE 7 absolut identisch aus
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 12.08.2009, 12:50
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 12.08.2009
Beiträge: 4
McHubi befindet sich auf einem aufstrebenden Ast
Standard

Hi,

tja, in einer separaten Test-html-Seite sieht's auch bei mir i.O. aus.

Großes Rätselraten. Ggf. liegt's an der Strukturierung/ dem Zusammenspiel von verschiedenen css-Dateien:

Code:
<link rel="stylesheet" href="css/standard.css" type="text/css" media="all" />
<link rel="stylesheet" href="css/content.css" type="text/css" media="all" />
<link href="css/module.css" rel="stylesheet" type="text/css" />
<!--[if lte IE 6]>
<link rel="stylesheet" media="all" type="text/css" href="css/ie6_hacks.css" />
<![endif]-->
standard.css: legt grundlegendes fest, zum Beispiel den Seitenaufbau durch DIVs
content.css: css-Eigenschaften für Inhalte, wie td, a, ...
module.css: die in php-Modulen genutzten Klassen
ie6_hacks.css: korrigiert ggf. Klassen aus den vorher geladenen css-Files

In der ie6_hacks.css wird aber gar nichts an den DIVs geändert.

Hier mal ein Link zum Anschauen: meine-region-meine-kasse.de - TEST

Wenn ich das floaten aus div.box_info_2_left rausnehme, rutscht mir das DIV im FF - genauso wie beim IE mit oder ohne float - in die nächste Zeile. Hier wird dann dollerweise der Link aktiviert...
Mit Zitat antworten
  #4 (permalink)  
Alt 12.08.2009, 12:52
Benutzerbild von inta
free as in freedom
XHTMLforum-Kenner
 
Registriert seit: 04.12.2006
Ort: Berlin
Beiträge: 5.026
inta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz sein
Standard

Zitat:
Zitat von McHubi Beitrag anzeigen
Großes Rätselraten.
Mit einem Link zu deinem Problemfall wäre das zu Ende.
Mit Zitat antworten
  #5 (permalink)  
Alt 12.08.2009, 13:01
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 12.08.2009
Beiträge: 4
McHubi befindet sich auf einem aufstrebenden Ast
Standard

Ähh....

Zitat:
Hier mal ein Link zum Anschauen: meine-region-meine-kasse.de - TEST
Wie im Post oben: meine-region-meine-kasse.de - TEST

Habe den beiden DIVs zur Veranschaulichung noch eine farbige Linie verpasst...
Mit Zitat antworten
  #6 (permalink)  
Alt 12.08.2009, 13:07
Benutzerbild von inta
free as in freedom
XHTMLforum-Kenner
 
Registriert seit: 04.12.2006
Ort: Berlin
Beiträge: 5.026
inta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz seininta kann auf vieles stolz sein
Standard

Oh, entschuldige, den Link oben habe ich übersehen.

Dein Div mit der Klasse „menu“ verdeckt den Link, darum ist dieser nicht klickbar.
Mit Zitat antworten
  #7 (permalink)  
Alt 12.08.2009, 13:14
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 12.08.2009
Beiträge: 4
McHubi befindet sich auf einem aufstrebenden Ast
Standard

AARRRGGHHH!!!! Jetzt haut's hin...

Dickes Danke!
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Tabelle in Firefox seltsam Darkness1 (X)HTML 2 20.10.2009 13:19
Float / Container Problem - Total seltsam. einfachder CSS 9 16.07.2008 13:05
Seltsam! "&" funktioniert - "&amp;" nicht! RollingStones Javascript & Ajax 4 22.01.2008 10:20
firefox - lesezeichen verhalten sich seltsam o_anonym Offtopic 0 22.05.2007 17:32
Listen für Navi im Firefox seltsam seelefant CSS 6 11.02.2007 13:48


Alle Zeitangaben in WEZ +2. Es ist jetzt 03:44 Uhr.