zurück zur Startseite
  


Zurück XHTMLforum > Webentwicklung (außer XHTML und CSS) > Javascript & Ajax
Seite neu laden ImageFlow: Bilder werden nicht angezeigt

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 17.06.2009, 14:27
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 13.06.2009
Beiträge: 30
crossgolfer85 befindet sich auf einem aufstrebenden Ast
Standard ImageFlow: Bilder werden nicht angezeigt

Moin,
kann mir jemand sagen woran es liegen könnt wenn Bilder in ImageFlow nicht angezeigt werden?

Ich habe mir ImageFlow runtergeladen und die enthaltene index.html UNVERÄNDERT geöffnet -> Bilder werden nicht angezeigt (Ordner lag auf dem Desktop).

Habe dann den ImageFlow-Ordner unter localhoost/imageflow abgelegt -> Bilder werden angezeigt (aber auch nur über Index of /!!)!

Binde ich die js-Datei dann in meinem Projekt im head ein und kopiere einfach nur das Beispiel aus der index.html -> Bilder werden nicht angezeigt!! Hä?

Habe dann auch den kompletten Pfad zum Bild angegeben, also mit Index of /, geht trotzdem nicht. Klicke ich aber auf das nichtangezeigte Bild erscheint die Grafik die bei longdesc hinterlegt ist. Beide Pfade, also longdesc und src sind aber absolut identisch.... stehe voll auf´m Schlauch
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 17.06.2009, 17:09
Benutzerbild von uspri
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 04.07.2005
Beiträge: 900
uspri sorgt für eine eindrucksvolle Atmosphäreuspri sorgt für eine eindrucksvolle Atmosphäre
Standard

Beim Imageflow werden die Bilder über ein PHP-Script ausgeliefert. Im Quellcode steht nur ein <img src ...> drinnen, dass dann per JS aber umgebaut wird. Imageflow läuft nur über einen PHPfähigen Webspace.
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 18.06.2009, 09:36
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 13.06.2009
Beiträge: 30
crossgolfer85 befindet sich auf einem aufstrebenden Ast
Standard

Vielen Dank!!
Ich habe einfach die reflect.php mit in den Ordner gepackt dann ging es!! Das muss man aber auch erstmal wissen. Ich habe zuletzt vor ca. 1,5 Jahren was mit Imageflow gemacht und soweit ich mich errinern kann musste ich damals die reflect.php direkt im img-Tag verweisen, wenn ich einen Schlagschatten haben möchte...

Weißt du wie ich die Bilder nicht über die den vertikalen Scroller sondern einfach nur über Buttons vor- und zurückschalten kann?

Maik
Mit Zitat antworten
  #4 (permalink)  
Alt 18.06.2009, 12:12
Benutzerbild von uspri
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 04.07.2005
Beiträge: 900
uspri sorgt für eine eindrucksvolle Atmosphäreuspri sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von crossgolfer85 Beitrag anzeigen
Vielen Dank!!
Ich habe einfach die reflect.php mit in den Ordner gepackt dann ging es!! Das muss man aber auch erstmal wissen. Ich habe zuletzt vor ca. 1,5 Jahren was mit Imageflow gemacht und soweit ich mich errinern kann musste ich damals die reflect.php direkt im img-Tag verweisen, wenn ich einen Schlagschatten haben möchte...
Das war die alte Version, es ist aber mittlerweile ne neuere draußen, die Objektorientiert geschrieben wurde und bei der Version ist vieles anders vom Aufbau her.

Zitat:
Zitat von crossgolfer85 Beitrag anzeigen
Weißt du wie ich die Bilder nicht über die den vertikalen Scroller sondern einfach nur über Buttons vor- und zurückschalten kann?
Das kann ich Dir leider nicht beantworten. Frag doch einfach mal beim Entwickler nach, der hat auf seiner Webseite ne Möglichkeit dazu.
Mit Zitat antworten
  #5 (permalink)  
Alt 08.10.2009, 17:44
Neuer Benutzer
neuer user
 
Registriert seit: 08.10.2009
Beiträge: 1
Dominique befindet sich auf einem aufstrebenden Ast
Standard Bilder werden nicht angezeigt

Hallo, ich habe das gleiche Problem wie du...nur verstehe ich leider nicht, wie du es gelöst hast. Ich habe den Ordner zuerst auf dem Desktop gespeichert und natürlich konnte ich die Bilder nicht sehen.
Mittlerweile habe ich ImageFlow hochgeladen und es funktioniert immernoch nich. Du hast geschrieben, dass du die reflect-dateien irgendwo abgelegt hast. Kannst du mir das bitte in "Anfängersprache" erklären...
Mit Zitat antworten
  #6 (permalink)  
Alt 08.10.2009, 18:01
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 13.06.2009
Beiträge: 30
crossgolfer85 befindet sich auf einem aufstrebenden Ast
Standard

Moin, die reflect.php muss in dem gleichen Verzeichnis liegen in der du auch die Datei liegen hast wo Imageflow eingebunden ist.

Da die reflect.php eine PHP-Datei ist kannst du sie nicht auf dem Desktop ausführen und solltest dir erstmal einen Webserver installieren wenn du den noch nicht hast (z.B. Xampp). Dann die entsprechende Seite über localhost aufrufen.

Wenn das ganze bei dir online nicht angezeigt wird hat das folgende Gründe:
- Dein Webspace unterstützt kein PHP
- Die reflect.php liegt im falschen Ordner.

Mfg
Mit Zitat antworten
  #7 (permalink)  
Alt 22.02.2011, 16:16
Benutzerbild von programm
#
neuer user
 
Registriert seit: 26.02.2008
Ort: Wuppertal
Beiträge: 44
programm befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von crossgolfer85 Beitrag anzeigen
Moin, die reflect.php muss in dem gleichen Verzeichnis liegen in der du auch die Datei liegen hast wo Imageflow eingebunden ist.
Jetzt muss ich diesen Uralt-Thread mal ausgraben.
Ich habe gerade entdeckt, dass genau das mein Problem ist. Also die reflect-Datei. Ich möchte das Script relativ dynamisch einsetzen und dazu würde ich gern in ein anderes Verzeichnis verlinken.

Kennt jemand eine Möglichkeit, anders auf die reflect-Datei zu linken?


//EDIT: Habe es geschafft.
__________________
mein name ist programm

Geändert von programm (23.02.2011 um 10:24 Uhr)
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Bilder werden in Netscape nicht angezeigt sqrack CSS 12 02.05.2010 22:53
Bilder werden unter Video angezeigt... BoFiaZ CSS 1 06.01.2010 11:01
Bilder werden nicht angezeigt ven (X)HTML 1 03.06.2007 19:38
bilder werden nicht angezeigt!? halbmond Serveradministration und serverseitige Scripte 6 02.01.2007 20:09
Bilder werden im IE nicht angezeigt nc2001 CSS 2 01.05.2005 22:15


Alle Zeitangaben in WEZ +2. Es ist jetzt 23:57 Uhr.