zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Navi geht nicht

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 18.05.2009, 21:19
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 09.11.2008
Beiträge: 8
$$freaky44$$ befindet sich auf einem aufstrebenden Ast
Standard Navi geht nicht

hi warum wird meine Navigationsleiste richtig angezeigt, in der browser ansicht mit scriptly richtig angezeigt und wenn ich sie normal öffne nicht richtig angezeigt?
ich benutze den IE8.
hir mein css
Code:
div#Rahmen {
  width: 100%;
  padding: 0.8em;
  border: 1px solid black;
  background-color: silver;
}
* html div#Rahmen {  /* Korrektur fuer IE 5.x */
  width: 48.7em;
  w\idth: 47.1em;
}
div#Rahmen div {
  clear: left;
}
ul#Navigation {
  margin: 0; padding: 0;
  text-align: center;
}

ul#Navigation li {
  list-style: none;
  float: left;  /* ohne width - nach CSS 2.1 erlaubt */
  position: relative;
  margin: 0.4em; padding: 0;
}
* html ul#Navigation li {  /* Korrektur fuer den IE 5 und 6 */
  margin-bottom: -0.4em;
}
*:first-child+html ul#Navigation li {  /* Korrektur fuer den IE 7 */
  margin-bottom: -0.1em;
}

ul#Navigation li ul {
  margin: 0; padding: 0;
  position: absolute;
  top: 1.6em; left: -0.4em;
  display: none;  /* Unternavigation ausblenden */
}
* html ul#Navigation li ul {  /* Korrektur fuer IE 5.x */
  left: -1.5em;
  lef\t: -0.4em;
}
*:first-child+html ul#Navigation ul {  /* Workaround fuer den IE 7 */
  background-color:silver; padding-bottom:0.4em;
}
ul#Navigation li:hover ul {
  display: block;  /* Unternavigation in modernen Browsern einblenden */
}
ul#Navigation li ul li {
  float: none;
  display: block;
  margin-bottom: 0.2em;
}

ul#Navigation a, ul#Navigation span {
  display: block;
  width: 6.4em;  /* Breite den in li enthaltenen Elementen zuweisen */
  padding: 0.2em 1em;
  text-decoration: none; font-weight: bold;
  border: 1px solid black;
  border-left-color: white; border-top-color: white;
  color: maroon; background-color: #ccc;
}
* html ul#Navigation a, * html ul#Navigation span {
  width: 8.6em;   /* Breite nach altem MS-Boxmodell für IE 5.x */
  w\idth: 6.4em;  /* korrekte Breite fuer den IE 6 im standardkonformen Modus */
}
ul#Navigation a:hover, ul#Navigation span, li a#aktuell {
  border-color: white;
  border-left-color: black; border-top-color: black;
  color: white; background-color: gray;
}
li a#aktuell {  /* aktuelle Rubrik kennzeichnen */
  color: maroon; background-color: silver;
}
ul#Navigation li ul span {  /* aktuelle Unterseite kennzeichnen */
  background-color: maroon;
}
danke jetzt schon mal für eure Hilfe
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 19.05.2009, 09:26
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 09.11.2008
Beiträge: 8
$$freaky44$$ befindet sich auf einem aufstrebenden Ast
Standard

Weiß das KEINER??????
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 19.05.2009, 09:46
Benutzerbild von hubspe
Eisen 7 ole....
XHTMLforum-Kenner
 
Registriert seit: 22.06.2007
Ort: Passau
Beiträge: 7.086
hubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblick
Standard

Moin,

Bitte einen Link zum Problem oder einen vollständigen, lauffähigen Testcase posten, der dein Problem zeigt.

Codeschnipsel sind meistens zuwenig.
__________________
Ein mehrfacher Gruß aus dem Südosten
Klaus
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
FAQ -- Häufig gestellte Fragen und häufig gegebene Antworten mazzo CSS 10 05.04.2012 18:32
grafische Navigation horizontal zentrieren, klappt nicht lila_3 CSS 4 30.11.2010 11:25
Boxen von Navigation und Logo sind zu weit auseinander lila_3 CSS 2 04.09.2009 00:28
IE verschiebt Navi Menü macmensa CSS 7 17.08.2009 17:45
Probleme mit horizontaler Navi rechts lila_3 CSS 2 14.07.2009 22:36


Alle Zeitangaben in WEZ +2. Es ist jetzt 05:47 Uhr.