zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Darstellungsprobleme im IE7 - FF, Google Chrome zeigen korrekt

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 05.09.2008, 00:35
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 05.09.2008
Beiträge: 8
webrise befindet sich auf einem aufstrebenden Ast
Frage Darstellungsprobleme im IE7 - FF, Google Chrome zeigen korrekt

Hallo an alle,

ich habe gerade ein Problem bei der Darstellung im IE entdeckt. Und das bei einer Vorführung unter Kumperls.

Und zwar die obere Navi unter atholiday.net wird im FF und seit neustem ja auch dem Google Chrome korrekt angezeigt. Nur im IE wird die headbar verschoben dargestellt. Und ich ich weiß jetzt wirklich nicht mehr, wie ich es beheben kann, das es auch im IE korrekt angezeigt wird ohne die Darstellung im FF zu zerstören.

Kann mir jemand weiterhelfen?
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 05.09.2008, 01:12
Benutzerbild von Crizzo
der mit dem Editor kämpft
XHTMLforum-Kenner
 
Registriert seit: 17.10.2006
Ort: Ost-Hessen
Beiträge: 4.837
Crizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer Mensch
Standard

Was macht das leere Textelement oben in der Navi? Schmeiß es mal raus.
__________________
Ohne Quelltext gibts selten Hilfe. Also: Onlinebeispiel hochladen und Link bereitstellen!
Foren-FAQ
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 05.09.2008, 01:19
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 05.09.2008
Beiträge: 8
webrise befindet sich auf einem aufstrebenden Ast
Standard

Welches Textelement meinst Du?

Meinst Du <p>&nbsp;</p>?

Geändert von webrise (05.09.2008 um 01:22 Uhr)
Mit Zitat antworten
  #4 (permalink)  
Alt 05.09.2008, 01:21
Benutzerbild von Crizzo
der mit dem Editor kämpft
XHTMLforum-Kenner
 
Registriert seit: 17.10.2006
Ort: Ost-Hessen
Beiträge: 4.837
Crizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer Mensch
Standard

Code:
<div id="navbar">
      <p></p>
<ul>
</ul>
</div>
Dann konzentrier dich mit dem Einbinden von Hintergrundgrafiken auf die vorhanden und sinnvollen Elemente in der Navigation. Falls noch mehr leere drin sind, können die auch raus.
__________________
Ohne Quelltext gibts selten Hilfe. Also: Onlinebeispiel hochladen und Link bereitstellen!
Foren-FAQ
Mit Zitat antworten
  #5 (permalink)  
Alt 05.09.2008, 01:25
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 05.09.2008
Beiträge: 8
webrise befindet sich auf einem aufstrebenden Ast
Standard

Aber genau das <p> Tag ist ja die Headbar also die Hintergrundgrafik

Mit Zitat antworten
  #6 (permalink)  
Alt 05.09.2008, 01:27
Benutzerbild von Crizzo
der mit dem Editor kämpft
XHTMLforum-Kenner
 
Registriert seit: 17.10.2006
Ort: Ost-Hessen
Beiträge: 4.837
Crizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer MenschCrizzo ist ein sehr geschätzer Mensch
Standard

Gib die Grafik #navi oder ul. Die Elemente haben wenigsten einen Sinn dort.

Dein Gebastel mit "pos:abs" scheint doch nur Probleme zu bringen.

Dazu sag ich mal lieber nichts: http://validator.w3.org/check?verbos...holiday.net%2F Sollte aber leicht zu bereinigen sein. Du musst nur ein paar "alt=" " " und "/" ergänzen, & umwandeln usw.

PS: http://xhtmlforum.de/40267-faq-h-ufi...tml#post296439
__________________
Ohne Quelltext gibts selten Hilfe. Also: Onlinebeispiel hochladen und Link bereitstellen!
Foren-FAQ

Geändert von Crizzo (05.09.2008 um 01:31 Uhr)
Mit Zitat antworten
  #7 (permalink)  
Alt 05.09.2008, 12:33
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 05.09.2008
Beiträge: 8
webrise befindet sich auf einem aufstrebenden Ast
Daumen hoch

Danke.

hab das p-Tag jetzt entfernt. dank byteandi hab ich jetzt funktionierenden code.

P.S. An den anderen Fehlern (alt-tags,...) arbeite ich noch
Mit Zitat antworten
Antwort

Stichwörter
css, explorer, firefox

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Fehlerhafte Menulink-Erkennung bei Google Chrome cychotic CSS 4 26.05.2011 08:20
Weite meines Divs zieht in Google Chrome nicht RaphaelWerz CSS 1 14.03.2011 14:39
Safar, Chrome und IE stellen <embed> nicht korrekt dar filmabend (X)HTML 2 04.11.2010 11:55
Darstellungsprobleme im IE7 netnite CSS 8 07.03.2009 00:14
Google Chrome: Final online! Crizzo Ressourcen 45 19.12.2008 08:47


Alle Zeitangaben in WEZ +2. Es ist jetzt 05:41 Uhr.