zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Navigation wird im IE 6 und 5.5 falsch dargestellt

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 13.08.2008, 18:21
Benutzerbild von Safran
Freak
neuer user
Thread-Ersteller
 
Registriert seit: 14.07.2005
Beiträge: 81
Safran befindet sich auf einem aufstrebenden Ast
Standard Navigation wird im IE 6 und 5.5 falsch dargestellt

Hallo Community,

mein Problem dreht sich um diese Seite.

Im Firefox sieht die Seite mittlerweile so aus wie sie es auch sollte. Allerdings machen mir zur zeit noch die IE's zu schaffen. Alle außer der IE 7 zerschießen mir meine obere Navigationsleiste und ich weiß leider nicht woran das liegt. Kann mir jemand einen Tipp geben?

Danke im Vorraus!

Edit: Wenn ich #navi li einen width-Wert zuweise stellt es der IE erstaunlicherweise auch da. Allerdings sind die Tabs unterschiedlich groß, so das der Browser selbst die Brete für die einzelnen Tabs bestimmen soll. Für den FF kann ich problemlos "width: auto !important;" schreiben. Aber was sage ich denn dem IE?

Geändert von Safran (13.08.2008 um 20:06 Uhr) Grund: Ergänzung
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 13.08.2008, 20:28
Benutzerbild von hubspe
Eisen 7 ole....
XHTMLforum-Kenner
 
Registriert seit: 22.06.2007
Ort: Passau
Beiträge: 7.086
hubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblick
Standard

Hi,

vielleicht sollte a auch floaten.
Schau doch mal in das Tut für Navis in die CSS-FAQ.

Warum steht die Navi im Quelltext eigentlich nach dem footer?

Gruß
Klaus
__________________
Ein mehrfacher Gruß aus dem Südosten
Klaus
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 14.08.2008, 11:54
Benutzerbild von Safran
Freak
neuer user
Thread-Ersteller
 
Registriert seit: 14.07.2005
Beiträge: 81
Safran befindet sich auf einem aufstrebenden Ast
Standard

Hey Klaus,

ich danke dir vielmals. Und für diese eine Zeile habe ich gestern meinen ganzen Nachmittag geopfert.
Du hast mir jedenfalls super geholfen!

Die FAQ's zu diesem Thema hatte ich selbstverständlich bereits gelesen. Allerdings hatten sie mich leider nicht sehr viel weiter gebracht, da mein Aufbau ja vom Prinzip her stimmte. Ich hatte fast alles schon ausprobiert gehabt. Naja, ich teste jetzt erst einmal noch eimal in Ruhe alle Browser durch.

Spielt es denn keine Rolle wo mein Header steht? Wie du ja siehst, habe ich ihn absolut positioniert. Daher ist es doch egal ob ich ihn vor dem Footer oder danach lade. Oder liege ich damit falsch?
Ich habe ihn einfach nur hinter meinem eigentlichen Contentbereich laden wollen, so dass Suchmaschienen erst meinen Inhalt durchsuchen und nicht in ihrem Beschreibungstext die Navigation wiedergeben. Das ist ein bisschen unzweckmäßig.

Gruß,
Safran

Ergänzung: Jetzt stimmt es mit dem IE 5.5 leider immernoch nicht. Dabei würde ich diesen schon gerne unterstützen, da immernoch ein nicht zu vernachlässingder Teil meiner Besucher diesen einsetzt (fragt mich bitte nicht warum ).
Mit Zitat antworten
  #4 (permalink)  
Alt 14.08.2008, 12:26
Benutzerbild von hubspe
Eisen 7 ole....
XHTMLforum-Kenner
 
Registriert seit: 22.06.2007
Ort: Passau
Beiträge: 7.086
hubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblickhubspe ist ein wunderbarer Anblick
Standard

Hi safran,

das mit dem floaten von a hab ich auch aus unserer FAQ, da hing ich nämlich mal genauso wie du fest.

Zitat:
Zitat von safran:
Spielt es denn keine Rolle wo mein Header steht? Wie du ja siehst, habe ich ihn absolut positioniert. Daher ist es doch egal ob ich ihn vor dem Footer oder danach lade. Oder liege ich damit falsch?
Ich habe ihn einfach nur hinter meinem eigentlichen Contentbereich laden wollen, so dass Suchmaschienen erst meinen Inhalt durchsuchen und nicht in ihrem Beschreibungstext die Navigation wiedergeben. Das ist ein bisschen unzweckmäßig.
Ich denke dem Sumabot ist es wurscht ob er zuerst auf die Links oder den Inhalt stößt. Du brauchst imho nicht befürchten das er deinen content links liegen läßt.

Absolute Positionierung versuche ich zu vermeiden, weil sie eine HP unflexibel macht.

Wie wärs denn in deinem Fall mit "skiplinks" und "skiplinktabs".
Dann könntest du gleich mehrere Fliegen mit einer Klappe schlagen!

Erstmal bietest du "screenreaderusern" und "Tastaturhanglern" die Möglichkeit
sich komfortabler durch die Seite zu hangeln.
Meistens reichen zwei, einer "zum Inhalt" und einer "zur Navi".

Wenn der erste zum Inhalt führt, hast du so den Sumabot direkt auf die richtige Spur gesetzt, die folgen ja so gerne Links.

Dann bräuchtest die auch die absolute Pos. nicht mehr und du könntest dein Markup bequem in der "normalen" Reihenfolge schreiben.

Gruß
Klaus
__________________
Ein mehrfacher Gruß aus dem Südosten
Klaus
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit Navigation safari CSS 12 20.04.2011 11:11
Navigation falsch dargestellt + Frage zu Hintergund Safran Q. CSS 8 23.09.2008 18:10
Javascript UL Navigation im IE6 ven CSS 7 29.04.2008 15:29
Navigation wird falsch dargestellt! st0ffy CSS 16 01.02.2008 11:30
Navigation wird im IE falsch, im FF richtig dargestellt... Stefanotis CSS 3 10.05.2007 16:33


Alle Zeitangaben in WEZ +2. Es ist jetzt 23:24 Uhr.