zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden max-width Problem Opera

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 29.02.2008, 22:51
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 04.11.2007
Beiträge: 8
Michael8576 befindet sich auf einem aufstrebenden Ast
Standard max-width Problem Opera

Hallo, ich gebe in meinem Script Bilder aus.
Den Bilder habe ich eine Klasse mit max-width Angabe gegeben.
Die Bilder sollen damit nicht größer als 800px angezeigt werden.
Funktioniert im FF und IE7 super, für den IE6 mußte ich tricksen.
Nun habe ich aber ein Problem mit dem Opera.
Und zwar verkleinert der Opera zwar das Bild, aber nicht die Tabelle drumherum.
Diese wird in Originalbreite gezeigt und zerstört so das Layout.
Gibt es da was um Opera in die Knie zu zwingen?
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 29.02.2008, 23:58
Benutzerbild von Geronimo
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 14.06.2004
Beiträge: 2.644
Geronimo sorgt für eine eindrucksvolle AtmosphäreGeronimo sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von Michael8576 Beitrag anzeigen
Und zwar verkleinert der Opera zwar das Bild, aber nicht die Tabelle drumherum.
Klingt nach einer ziemlich wirren Konstruktion. Kannst du uns den Quelltext und das zugehörige Stylesheet zeigen?
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 01.03.2008, 00:11
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 04.11.2007
Beiträge: 8
Michael8576 befindet sich auf einem aufstrebenden Ast
Standard

Testseite ist hier und CSS ist einmal hier und einmal hier.
Mit Zitat antworten
  #4 (permalink)  
Alt 01.03.2008, 00:52
EvT EvT ist offline
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 11.09.2006
Ort: Bad Wildungen
Beiträge: 2.222
EvT ist jedem bekanntEvT ist jedem bekanntEvT ist jedem bekanntEvT ist jedem bekanntEvT ist jedem bekanntEvT ist jedem bekannt
Standard

Erster Schritt ist immer das Validieren.
Mit Zitat antworten
  #5 (permalink)  
Alt 01.03.2008, 01:06
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 04.11.2007
Beiträge: 8
Michael8576 befindet sich auf einem aufstrebenden Ast
Standard

Die Seite ist Valid.
Baue nur gerade am Design rum beeinflußt aber nicht das Problem.
Mit Zitat antworten
  #6 (permalink)  
Alt 01.03.2008, 09:10
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 04.11.2007
Beiträge: 8
Michael8576 befindet sich auf einem aufstrebenden Ast
Standard

OK hat sich erledigt, habe es mittels PHP gelöst.
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit einem 3D-Effekt moep0710 CSS 12 12.06.2010 14:30
Problem mit Parent / Child Div lemmyk CSS 0 04.03.2010 16:44
rätselhafter Leerraum zwischen Content und Footer im IE jhonnybravo CSS 5 04.03.2010 11:47
Untermenü im IE nici CSS 10 22.06.2009 21:19
IE zeigt gewisse Texte nicht an zitronenbaum CSS 2 16.01.2008 15:25


Alle Zeitangaben in WEZ +2. Es ist jetzt 13:38 Uhr.