zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > Site- und Layoutcheck
Seite neu laden Unterschiedliche DArstellung bei unterschiedlichen Browsern

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 23.10.2007, 23:18
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.10.2007
Beiträge: 8
RogerG781 befindet sich auf einem aufstrebenden Ast
Frage Unterschiedliche DArstellung bei unterschiedlichen Browsern

Hi Leute,
ich lese schon seit einiger Zeit im Forum mit und hab mir auch schon ein paar Tips geholt.
Kann mich aber leider selbst nicht aktiv beteiligen, da mir in dem Bereich noch einiges an Erfahrung fehlt.
Da meine Freundin und ich einen längern Urlaub planen, bin ich dabei eine Webpage zu erstellen. NAchdem ich mich durch einige Tutorials und ein XHTML Buch gekämpft habe, sieht es eigentlich ganz passabel aus, so denke ich.
Allerdings habe ich leider Probleme.
Alle bisher erstellten Seiten, mit Ausnahme der Link- Seite, sind W3C Konform. Habe sie dort validiert und sie waren einwandfrei. DEnnoch gibt es unterschiedliche Darstellungsprobleme:
IE6 und IE7: Zeigt die obere Link- Leiste nur beim draufgehen an
Mozilla Firefox: Skaliert die Grösse des Inhaltsfenster nicht auf die Vorgabe
Vielleicht könnt ihr, wenn ihr einen Moment Lust und Zeit habt, mal drüber schauen und mir vielleicht einen Tip geben woran diese Abweichung bei der Darstellung liegt.
Link: AustraSeeland.de - Die Seite über unsere Tour durch Australien und Neuseeland

Vielen Dank schonmal im Voraus!
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 24.10.2007, 15:20
Benutzerbild von Dieter
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 12.09.2003
Beiträge: 3.640
Dieter sorgt für eine eindrucksvolle AtmosphäreDieter sorgt für eine eindrucksvolle Atmosphäre
Standard

Roger, validier bitte mal Dein CSS - evtl. sind einige Probleme dann weg!?
__________________
Informationen aus Koblenz-Metternich
-----------------------------------
"Wissen heißt, Fragen zu erwerben."
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 24.10.2007, 23:37
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.10.2007
Beiträge: 8
RogerG781 befindet sich auf einem aufstrebenden Ast
Standard

Hallo und erstmal danke für den Tip. Habe soeben die kompletten CSS Dateien durch den CSS Validator geschickt. Aufgefallen sind nur 6 kleine Fehler. Habe diese alle behoben.
Das eigentliche Problem der unterschiedlichen Darstellung hat es leider nicht gelöst. Am meisten stört mich, dass die erste Navigationsleiste im IE6 garnicht sichtbar ist, sondern einfach nur weiss bleibt.

Vielleicht noch ne Idee?

Danke.
Mit Zitat antworten
  #4 (permalink)  
Alt 24.10.2007, 23:45
Benutzerbild von Dieter
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 12.09.2003
Beiträge: 3.640
Dieter sorgt für eine eindrucksvolle AtmosphäreDieter sorgt für eine eindrucksvolle Atmosphäre
Standard

Habe Dein CSS soeben bei W3 validiert und erhalte folgende Fehlermeldungen:
Zitat:
Einlese-Fehler - ���@import url(style.css);
2 ��� Parse error - Unrecognized @import url(navigation.css);
3 ��� Parse error - Unrecognized @import url(basic.css);
Das solltest Du beheben!
__________________
Informationen aus Koblenz-Metternich
-----------------------------------
"Wissen heißt, Fragen zu erwerben."
Mit Zitat antworten
  #5 (permalink)  
Alt 24.10.2007, 23:47
Benutzerbild von Dieter
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 12.09.2003
Beiträge: 3.640
Dieter sorgt für eine eindrucksvolle AtmosphäreDieter sorgt für eine eindrucksvolle Atmosphäre
Standard

Hast Du die CSS auch mit UTF-8 abgespeichert?
__________________
Informationen aus Koblenz-Metternich
-----------------------------------
"Wissen heißt, Fragen zu erwerben."
Mit Zitat antworten
  #6 (permalink)  
Alt 25.10.2007, 00:02
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.10.2007
Beiträge: 8
RogerG781 befindet sich auf einem aufstrebenden Ast
Standard

Hallo, die Datein sind allesamt in UTF-8 abgespeichert. Dachte der Fehler bei dem main.css wäre normal, da er ja in dieser Umgebung die gemeinten Dateien nicht findet. Die anderen 3 Dateien werden ja beim aufruf der Seite gefunden und diese sind CSS validiert und ohne Fehler.
Bin gerade ein wenig ratlos, wie ich den Fehler behebn soll, werde mir dass aber gleich nochmal anschauen.
Habe die Datei nochmal erstellt und dabei darauf geachtet, dass es im Format UTF-8 gespeichert wird. Der Fehler ist nun auch behoben. Der Darstellungsfehler besteht leider immer noch
Trotzdem erstmal vielen Dank für die Hilfe.

Geändert von RogerG781 (25.10.2007 um 00:09 Uhr)
Mit Zitat antworten
  #7 (permalink)  
Alt 25.10.2007, 00:10
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.778
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Dein Editor speichert UTF mit BOM, das produziert den Fehler (im CSS-Validator). Sollte sich abstellen lassen.
Mit Zitat antworten
  #8 (permalink)  
Alt 25.10.2007, 00:19
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.10.2007
Beiträge: 8
RogerG781 befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von fricca Beitrag anzeigen
Dein Editor speichert UTF mit BOM, das produziert den Fehler (im CSS-Validator). Sollte sich abstellen lassen.
Hallo, danke. Fehler ist, wie gesagt, behoben und wird nun bei der CSS Validierung nicht mehr angezeigt.
Leider ist das Darstellungsproblem beim IE6 nicht verschwunden.
Mit Zitat antworten
  #9 (permalink)  
Alt 25.10.2007, 00:25
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.778
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Zitat:
Zitat von RogerG781 Beitrag anzeigen
Hallo, danke. Fehler ist, wie gesagt, behoben und wird nun bei der CSS Validierung nicht mehr angezeigt.
Kann ich nicht bestätigen. Der von Dieter zitierte Fehler besteht nach wie vor.

Zitat:
Leider ist das Darstellungsproblem beim IE6 nicht verschwunden.
Gib #topnav Layout.

Zitat:
Mozilla Firefox: Skaliert die Grösse des Inhaltsfenster nicht auf die Vorgabe
Ich weiß nicht, was du meinst.
Mit Zitat antworten
Sponsored Links
  #10 (permalink)  
Alt 25.10.2007, 00:40
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 23.10.2007
Beiträge: 8
RogerG781 befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von fricca Beitrag anzeigen
Kann ich nicht bestätigen. Der von Dieter zitierte Fehler besteht nach wie vor.
Habe nochmal geschaut, er sagt nur noch, dass er die Dateien nicht finden kann, aber das ist ja auch ok. Der Fehler mit den kryptischen Schriftzeichen ist nicht mehr vorhanden.

Zitat:
Gib #topnav Layout.
Muss ich mir nochmal anschauen.
Zitat:
Ich weiß nicht, was du meinst.
Wenn du die Seite mit dem IE6/IE7 öffnest und dann auf Reiseplanung gehst, verschwindet an der rechten Seite das Newsfenster und der Hauptinhalt wird auf die breite gestreckt.
Dies funktioniert im Firefox nicht, der Mitteteil (smallcontent) erkennt anscheinend nicht dass alle andere Seiten anders (content) definiert sind.
Mit Zitat antworten
Sponsored Links
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Justieren zur korrekten Darstellung in allen Browsern Jonas* (X)HTML 5 25.01.2010 21:21
Blocksatz in unterschiedlichen Browsern :-( MacDonky CSS 3 17.06.2009 21:40
Unterschiedliche Darstellung im IE joachimott CSS 6 28.06.2005 15:44
Problem mit unterschiedlichen Browsern Big_Player CSS 6 14.12.2004 11:59


Alle Zeitangaben in WEZ +2. Es ist jetzt 21:28 Uhr.