zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > Site- und Layoutcheck
Seite neu laden Design Problem, und keine Ahnung wieso

Antwort
 
LinkBack Themen-Optionen Ansicht
  #41 (permalink)  
Alt 18.01.2007, 17:24
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.784
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Zitat:
Zitat von nacho Beitrag anzeigen
Könnte man das mit einem Overflow im Menü selbst beheben, also mit einem overlfow: visible; ?
Nein. .
Mit Zitat antworten
Sponsored Links
  #42 (permalink)  
Alt 19.01.2007, 10:54
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 14.12.2006
Beiträge: 29
nacho befindet sich auf einem aufstrebenden Ast
Standard

So, die Seite habe ich nun hochgeladen, musste jedoch leider feststellen, das ich erneut ein Problem habe, auf das ich nicht komme.

Im FF wird nun alles gut angezeigt.

Allerdings im Internet Explorer nicht mehr so wie gewünscht.

Und zwar unter dem Punkt "Wehr -> Mannschaft" zerreisst es wieder das Design.
Aber wieso nur da, und nicht bei den anderen auch?

URL: Freiwillige Feuerwehr Bremen - Neustadt

Kann mir nochmal jemand helfen?

Danke.

P.S.: Mir ist noch aufgefallen, das es überall dort verzieht, wo ich die Menübuttons auch am linken Rand nutze.

Geändert von nacho (19.01.2007 um 11:00 Uhr)
Mit Zitat antworten
Sponsored Links
  #43 (permalink)  
Alt 19.01.2007, 11:02
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.784
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Du merkst jetzt, dass das Herumdoktern an Symptomen keinen Sinn hat.
Die einzige sinnvolle Lösung ist die Enfernung *aller* Layouttabellen und die Beseitigung der vielen Fehler. Validier deinen Code.
Der Code deiner linken Navigation ist --mit Verlaub-- Unsinn. Mach *eine* Liste draus, weg mit der Tabelle!!

Und dann überleg mal genau, welche Eigenschaften du der ID nav gegeben hast.
Eine ID darf nur genau *einmal* pro Dokument vorkommen. Was also hat diese ID x-mal in der linken Navigation zu suchen?

Geändert von fricca (19.01.2007 um 11:04 Uhr)
Mit Zitat antworten
  #44 (permalink)  
Alt 19.01.2007, 11:10
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 14.12.2006
Beiträge: 29
nacho befindet sich auf einem aufstrebenden Ast
Standard

Ja, ich sehe das Du vollkommen recht hast.

Werde mir ein Beispiel daran nehmen.
Auf jeden Fall klappt es, wenn ich es als Liste mache. Vielen Dank nochmals.
Mit Zitat antworten
  #45 (permalink)  
Alt 19.01.2007, 11:43
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.784
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Ich beantworte keine Fragen per PN. Stell sie im Forum.

Zitat:
Eine kleine Sache ist da noch:
Im Internet Explorer 6 wird der Contentbereich etwas größer angeziegt als in den anderen Browsern.
Enferne die br als Abstandhalter zwischen Navigation und Inhaltsbereich.
Gib dem Inhaltsbereich float:right und width.

edit: ich sehe gerade, dass es einen anderen Thread gibt, der die gleichen Inhalte und Empfehlungen hat wie dieser hier. Irgendwie ärgerlich sowas

Geändert von fricca (19.01.2007 um 11:48 Uhr)
Mit Zitat antworten
  #46 (permalink)  
Alt 19.01.2007, 12:00
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 14.12.2006
Beiträge: 29
nacho befindet sich auf einem aufstrebenden Ast
Standard

Der alte Thread bezog sich auf ein anderes Problem.

Damals waren dicke weisse Streifen zwischen den divs.

Wenn ich aber nun auf die Site gehe, dann wird es ja fast korrekt abgezeigt.

Problem ist eben nur, dass im IE6 der Content Bereich etwas weiter nach unten geht als in den anderen Browsern.

Das liess sich damit nicht beheben.
Mit Zitat antworten
  #47 (permalink)  
Alt 19.01.2007, 12:07
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.784
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Zitat:
Zitat von nacho Beitrag anzeigen
Der alte Thread bezog sich auf ein anderes Problem.
Mag sein.
Die allgemeingültige Lösung, die dir Heiko genannt hat, hast du hier aber bereits x-fach wieder gelesen.
Geändert hast du aber nichts. Das ist ärgerlich.
Heiko hat dir geschrieben, dass du Fragen nicht per PN stellen sollst. Du hast es bei mir wieder getan. Das ist ärgerlich.

Zitat:
Problem ist eben nur, dass im IE6 der Content Bereich etwas weiter nach unten geht als in den anderen Browsern.
Die Lösung habe ich dir genannt! Hier im Forum. Nicht per PN.

Ich beende hier dieses Gespräch. Bereinige deinen Code, dann kann man weiterreden.
Mit Zitat antworten
  #48 (permalink)  
Alt 19.01.2007, 12:15
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 14.12.2006
Beiträge: 29
nacho befindet sich auf einem aufstrebenden Ast
Standard

Ok, danke.

Seit alle wirklich sehr nett hier.

Ahso...heikos Lösung hat doch etwas gebracht. Also habe ich es doch umgesetzt. Vielleicht nicht komplett richtig, aber das liegt vielleicht auch daran, wie man einem Anfänger etwas erklärt.

Aber ich will mich hier nicht streiten.

Ihr habt recht. ich arbeite dran. Bis später.
Mit Zitat antworten
  #49 (permalink)  
Alt 19.01.2007, 12:20
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 28.01.2005
Beiträge: 11.784
fricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz seinfricca kann auf vieles stolz sein
Standard

Zitat:
Zitat von nacho Beitrag anzeigen
heikos Lösung hat doch etwas gebracht.
Die Lösung von der ich rede ist: weg mit den Layouttabellen. Weg mit den Syntaxfehlern.
Mit Zitat antworten
Sponsored Links
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Design problem Starksky (X)HTML 1 14.07.2011 18:53
Barriererarmes, skalierbares, 3Spaltiges Design (Designkontrolle) tliffcom Site- und Layoutcheck 4 01.03.2008 11:43
Design CCS Problem bei Joomla Template KITN Alomaman CSS 4 07.01.2008 15:43
Problem mit 3 Spaltigem Layout stipo CSS 0 27.05.2006 20:58
problem mit tableless design und breiter Tabelle im IE horizons CSS 14 06.04.2005 10:39


Alle Zeitangaben in WEZ +2. Es ist jetzt 00:50 Uhr.