Einzelnen Beitrag anzeigen
  #1 (permalink)  
Alt 27.04.2009, 11:59
Camelrider Camelrider ist offline
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.11.2007
Beiträge: 51
Camelrider befindet sich auf einem aufstrebenden Ast
Standard IE7 Render bzw. Editor Problem

Hi

Ich hab immer wieder ein reichlich stranges Phänomen dass ich mir nicht erklären kann - vielleicht habt ihr einen Tip für mich

folgende Ausgangslage:

HTML-Code:
<div class="print_icon">
	<a href=""><img src="http://xhtmlforum.de/images/icon_print.jpg"></a>
</div>
Im IE7 ist manchmal die Darstellung falsch ->
das div ist um 1px höher als bild das darin ist
wenn ich mir das ganze in der developer-toolbar ansehe zeigt er mir an
dass nach dem a-Tag angeblich noch "#text" ist

wenn ich den Code dann umbaue und in einer Wurscht schreibe ist das "#text" weg und die Darstellung richtig allerdings ist auch die Leserlichkeit
des Codes hinüber ...
HTML-Code:
<div class="print_icon"><a href=""><img src="http://xhtmlforum.de/images/icon_print.jpg"></a></div>
Das ganze ist unabhängig von etwaigen CSS-Styles ...

Als Editor verwende ich Notepad++ und es ist egal ob ich das File in utf-8 oder ansi oder was auch immer konvertiere/speichere

Das komisch ist dass das ganze nur manchmal auftritt

Ich bin ratlos - kann das ganze zwar umgehen mit dem "ineinerWurscht"-Ansatz aber optimal ist das nicht

Vielen Dank für etwaige Tips

lg Camelrider

Geändert von Camelrider (27.04.2009 um 12:03 Uhr)
Mit Zitat antworten
Sponsored Links