zurück zur Startseite
  


Zurück XHTMLforum > Webentwicklung (außer XHTML und CSS) > Serveradministration und serverseitige Scripte
Seite neu laden Cookie sendet nicht bei jedem User die Daten in jeden Bereich

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 09.08.2006, 13:49
Benutzerbild von nick
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 01.08.2006
Ort: Rheinland-Pfalz
Beiträge: 386
nick befindet sich auf einem aufstrebenden Ast
Idee Cookie sendet nicht bei jedem User die Daten in jeden Bereich

Hallo, kann mir jemand helfen?

Ich habe ein paar User, dessen Cookie-Daten können irgendwie nur von der
hauptseite entnommen werden!
Auf Unterseiten wie http://www.domain.de/Profil werden leider keine Daten
gesendet, obwohl ihre Einstellungen auf Cookie akzeptieren
sind und ich $_COOKIE['name'] verwende, um den Inhalt des Cookies rauszuholen!

Wie lasse ich da am besten die Cookies anlegen, auslesen?

Bis jetzt siehts bei mir so aus:

Code:
<?php
$var = setcookie ('pclanlog', $row->idnummer.'|'.$row->passwort.'|', time()+3600*24*10, '/');
          if ($var == FALSE) {echo 'Cookie setzen fehlgeschlagen!<p>';}
?>
schlug bei mir nochnie fehl.
rausgeholt werden sie folgendermassen...

Code:
<?php
if (isset($_COOKIE['pclanlog']) == TRUE) {
  $token = strtok($_COOKIE['pclanlog'], '|'); $name = $token;
  $token = strtok('|'); $passwort = $token;
}
?>
- Die Cookies weden bei allen Usern erfolgreich udn korrekt angelegt.
- Auf der Hauptseite (also im selben Skript-ServerVerzeichnis, indem das
Cookie angelegt worden ist) gillt JEDER User als eingeloggt!
- Ein paar User bekommen mit echo $name; auf Unterseiten nichts zu sehen, nur in Skripts des Server-Verzeichnisses, wo der Cookie angelegt
wurde.

Kann mir da jemand helfen?
Wie leg ich die Cookies am besten an, dass sie die Daten
innerhalb des kompletten Servers senden?
Ich bräuchte einen nützlichen Tipp...
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 09.08.2006, 17:28
Benutzerbild von netspy
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 13.08.2004
Ort: Leipzig
Beiträge: 1.956
netspy sorgt für eine eindrucksvolle Atmosphärenetspy sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von nick
...schlug bei mir nochnie fehl.
... was aber überhaupt nichts sagt:

http://de.php.net/setcookie
Zitat:
Wenn setcookie() erfolgreich durchgeführt wird, wird TRUE zurückgegeben. Dies sagt jedoch nichts darüber aus, ob der Benutzer das Cookie auch akzeptiert hat.
Zitat:
Zitat von nick
- Die Cookies weden bei allen Usern erfolgreich udn korrekt angelegt.
Woher willst du das wissen?

Zitat:
Zitat von nick
- Auf der Hauptseite (also im selben Skript-ServerVerzeichnis, indem das
Cookie angelegt worden ist) gillt JEDER User als eingeloggt!
- Ein paar User bekommen mit echo $name; auf Unterseiten nichts zu sehen, nur in Skripts des Server-Verzeichnisses, wo der Cookie angelegt
wurde.
Lass mal den Pfad weg.

Zitat:
Zitat von nick
Wie leg ich die Cookies am besten an, dass sie die Daten
innerhalb des kompletten Servers senden?
Ich bräuchte einen nützlichen Tipp...
Ein Blick in die Hilfe hönnte hier schon für viel Erhellung sorgen.

http://de.php.net/setcookie

Mario
__________________
AppDev Blog · AppDev Forum
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 09.08.2006, 18:50
Benutzerbild von nick
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 01.08.2006
Ort: Rheinland-Pfalz
Beiträge: 386
nick befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Woher willst du das wissen?
weil ich die werte erfolgreich abfragen kann.

Zitat:
Lass mal den Pfad weg.
Schon versucht

Ich weiss bis ins letzte, wie die Funktion geht.

Geändert von nick (09.08.2006 um 18:53 Uhr)
Mit Zitat antworten
  #4 (permalink)  
Alt 09.08.2006, 18:58
Benutzerbild von netspy
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 13.08.2004
Ort: Leipzig
Beiträge: 1.956
netspy sorgt für eine eindrucksvolle Atmosphärenetspy sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von nick
Ich weiss bis ins letzte, wie die Funktion geht.
Dann ist ja alles geklärt und es liegt wohl am Browser.

Mario

BTW: if (TRUE == TRUE) { ... } ist doppelt gemoppelt.
__________________
AppDev Blog · AppDev Forum
Mit Zitat antworten
  #5 (permalink)  
Alt 09.08.2006, 19:16
Benutzerbild von nick
Erfahrener Benutzer
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 01.08.2006
Ort: Rheinland-Pfalz
Beiträge: 386
nick befindet sich auf einem aufstrebenden Ast
Standard

Ok. Trotzdem danke für eure Antworten!
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Cookie lesen, zu kompliziert! cavebird Serveradministration und serverseitige Scripte 14 01.12.2009 12:25
FTP server in eine Seite integrieren? CL90 CSS 4 15.04.2009 13:59
Suche Idee für User Online Bereich tichy Serveradministration und serverseitige Scripte 3 28.08.2008 19:22
SESSION / COOKIE - Konflikte poppihasi Serveradministration und serverseitige Scripte 1 23.12.2007 13:29


Alle Zeitangaben in WEZ +2. Es ist jetzt 23:44 Uhr.