zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Problem mit dem Menü [erledigt]

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 15.01.2006, 21:38
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 15.01.2006
Beiträge: 84
Julian befindet sich auf einem aufstrebenden Ast
Standard Problem mit dem Menü [erledigt]

Hallo zusammen,

ich habe ein Problem, das ich zum verrecken nicht gelöst bekomme und hoffe, dass sich jemand hier findet der mir behilflich sein kann und möchte.

Ich habe mir ein Rollover-Menü gebastelt.
Code:
<ul id="buttons"> 
 <li id="but01">Firmenprofil 
 <li id="but02">Leistungen 
 <li id="but03">Design
 <li id="but04">Referenzen
 <li id="but05">Kontakt
 <li id="but06">Impressum[/list]
Hier das CSS dazu
Code:
 #buttons { width:585px; height:18px; margin:0 auto; padding:0; position:relative; list-style-type:none; background:url(../../img/de/standart/buttons.jpg);}
 #buttons li { display:block; height:18px; position:absolute; top:0; overflow:hidden; }
 #buttons li#but01 { left:0; width:122px; }
 #buttons li#but02 { left:122px; width:101px; }
 #buttons li#but03 { left:223px; width:68px; }
 #buttons li#but04 { left:291px; width:105px; }
 #buttons li#but05 { left:396px; width:80px; }
 #buttons li#but06 { left:476px; width:109px; }
 a:visited { color:#000; }
 #buttons li a, #buttons li a:visited { position:absolute; height:18px; background: url(../../img/de/standart/buttons.jpg); text-indent: -100em; overflow:hidden; }
 #buttons li#but01 a, #buttons li#but01 a:visited { background-position:0 0; width:122px; }
 #buttons li#but02 a, #buttons li#but02 a:visited { background-position:-122px 0; width:101px; }
 #buttons li#but03 a, #buttons li#but03 a:visited { background-position:-223px 0; width:68px; }
 #buttons li#but04 a, #buttons li#but04 a:visited { background-position:-291px 0; width:105px; }
 #buttons li#but05 a, #buttons li#but05 a:visited { background-position:-396px 0; width:80px;}
 #buttons li#but06 a, #buttons li#but06 a:visited { background-position:-476px 0; width:109px;}
 #buttons li a:hover, #buttons li a:focus { padding:0; top:0; height:18px; }
 #buttons li#but01 a:hover, #buttons li#but01 a:focus { background-position:0 -18px;}
 #buttons li#but02 a:hover, #buttons li#but02 a:focus { background-position:-122px -18px;}
 #buttons li#but03 a:hover, #buttons li#but03 a:focus { background-position:-223px -18px; }
 #buttons li#but04 a:hover, #buttons li#but04 a:focus { background-position:-291px -18px; }
 #buttons li#but05 a:hover, #buttons li#but05 a:focus { background-position:-396px -18px; }
 #buttons li#but06 a:hover, #buttons li#but06 a:focus { background-position:-476px -18px; }
Und dieses Menü funktioniert auch, solange ich es nicht im head-Bereich ablege sondern im content-Bereich (da soll es nur leider nicht hin).

Im Head funktioniert weder das Rollover, noch die Links.
Wenn jemand einen schlauen Gedanken hat, wo ich mir der Suche anfangen muss,

Bitte her damit
Danke

Julian

meine Seite
mein CSS
__________________
http://alles-ausser-banane.de/
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 15.01.2006, 23:24
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 28.11.2004
Beiträge: 547
lomtas befindet sich auf einem aufstrebenden Ast
Standard

Also ich würde mal behaupten, dass es am position: absolute liegt... ist aber nur ne vermutung
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 15.01.2006, 23:27
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 15.01.2006
Beiträge: 84
Julian befindet sich auf einem aufstrebenden Ast
Standard

an welchem?
dem im head oder im buttons?

edit: dem in den Buttons:
aber nun schauts auch grausam aus...
__________________
http://alles-ausser-banane.de/
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit CSS-Overflow in responsiven Menü GeorgBNM CSS 6 17.03.2013 13:58
Problem mit 2 Zeiligen Menü MrMartini83 CSS 0 09.06.2009 13:12
Norwegische Webmaster gegen veraltete Browser Schelm.isch Offtopic 255 23.04.2009 21:27
Session / Cookie Problem mit dem IE, sporadisch Boris Serveradministration und serverseitige Scripte 14 06.09.2007 12:54
Das Menü und mein Problem Sven CSS 1 13.03.2005 02:07


Alle Zeitangaben in WEZ +2. Es ist jetzt 10:18 Uhr.