zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > Knowledge Base
Seite neu laden Opera 8 BUG / Margin-Fehler bei Inline-Element

Antwort
 
LinkBack Themen-Optionen Ansicht
  #11 (permalink)  
Alt 18.08.2005, 00:27
Benutzerbild von Dieter
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 12.09.2003
Beiträge: 3.635
Dieter sorgt für eine eindrucksvolle AtmosphäreDieter sorgt für eine eindrucksvolle Atmosphäre
Standard

Fällt mir gerade auf:
Zitat:
Ohne dem Punkt vor dem Text...
Wieso vor dem Text? Der Punkt muss ans Ende des (Link)Textes!
__________________
Informationen aus Koblenz-Metternich
-----------------------------------
"Wissen heißt, Fragen zu erwerben."
Mit Zitat antworten
Sponsored Links
  #12 (permalink)  
Alt 18.08.2005, 00:59
Erfahrener Benutzer
XHTMLforum-Kenner
Thread-Ersteller
 
Registriert seit: 02.06.2003
Beiträge: 2.441
ulle befindet sich auf einem aufstrebenden Ast
Standard

Warum, es ist doch von der Lesefolge egal. Ein Punkt soll hinein damit eine Sprechpause initialisiert wird. Also haben die Listen bzw. Link-Elemente keinen Einfluss auf die Wortfolge oder Betonung. Demnach ist es auch egal wo der Punkt im Markup steht.

Abschliessender Punkt:
Text Punkt Text Punkt Text Punkt Text Punkt Text Punkt Text Punkt

Führender Punkt:
Punkt Text Punkt Text Punkt Text Punkt Text Punkt Text Punkt Text ... Punkt

Außer das beim 2. Beispiel mit einer Sprechpause begonnen wird und ich wohl nach der Navi noch einen Punkt ins Markup zaubern müßte, sehe (höre) ich nun keinen unterschied beim vorlesen.
__________________
</ulle>
Mit Zitat antworten
Sponsored Links
  #13 (permalink)  
Alt 18.08.2005, 01:06
Benutzerbild von Dieter
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 12.09.2003
Beiträge: 3.635
Dieter sorgt für eine eindrucksvolle AtmosphäreDieter sorgt für eine eindrucksvolle Atmosphäre
Standard

Ulle, das weiss ich jetzt nicht genau!

Klar klingt Deine Art des Punktesetzens erst mal logisch; aber rechne mal damit, dass es Reader gibt, die das Satzzeichen am Anfang des Satzes nicht oder falsch interpretieren!?

Denn das ist dann doch eine etwas unübliche Schreibweise!
__________________
Informationen aus Koblenz-Metternich
-----------------------------------
"Wissen heißt, Fragen zu erwerben."
Mit Zitat antworten
  #14 (permalink)  
Alt 18.08.2005, 01:19
Erfahrener Benutzer
XHTMLforum-Kenner
Thread-Ersteller
 
Registriert seit: 02.06.2003
Beiträge: 2.441
ulle befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von Dieter Krautkraemer
.......
Denn das ist dann doch eine etwas unübliche Schreibweise!
Wohl wahr, nur eine Wortfolge bzw. Wörter mit einem Punkt abzuschliessen genauso

Stichwort Satzzeichen; evtl. wäre ja für eine führende Pause ein Strich (|) besser geeignet. Ich meine aber mal gelesen zu haben das ein Strich generell die schlechtere Wahl ist, besser wäre immer Punkt und diesen mit CSS-Mitteln optisch zum Strich werden zu lassen, sofern dieser auch als Strich gesehen werden soll - wie oben in Deinem Beispiel.

Diese Diskussion (Barrierefrei) schweift nun aber total vom Inline-Element-Margin-BUG des Opera 8 ab und sollte besser im richtigen Forum weitergeführt werden.
__________________
</ulle>
Mit Zitat antworten
  #15 (permalink)  
Alt 20.09.2005, 22:46
Erfahrener Benutzer
XHTMLforum-Kenner
Thread-Ersteller
 
Registriert seit: 02.06.2003
Beiträge: 2.441
ulle befindet sich auf einem aufstrebenden Ast
Standard

Zur Info:

Der Eingangs behandelte Opera-Bug ist mit folgender Version nicht behoben!!

Zitat:
Version 8.5
Build 7700
Plattform Win32
Betriebssystem Windows XP
__________________
</ulle>
Mit Zitat antworten
  #16 (permalink)  
Alt 23.09.2005, 13:49
Neuer Benutzer
neuer user
 
Registriert seit: 23.09.2005
Beiträge: 2
alias befindet sich auf einem aufstrebenden Ast
Standard

Hi!

Ich denke ich habe das gleiche Problem, die Lösung scheint bei mir aber nicht zu funtionieren.

Folgender HTML-Code (Auszug):
Code:
<ul>[*]Magazines[*]Web[*]Dictionaries[*]Finland[/list]
Zugehöriger CSS-Code:
Code:
ul {
    list-style-type: circle;
    margin-top:      5px;
    margin-bottom:   5px;
}

li {
    margin-top:    0;
    margin-bottom: 0;
}
Opera (Version 8.5) scheint das margin des li komplett zu ignorieren. Ich habe den Punkt vor dem schliessenden </a> gesetzt (im Moment nicht), das hat aber leider keinen Effekt gehabt. Muss ich sonst noch irgendwas beachten? Die relevante Seite findet ihr unter: www.uni-koblenz.de/~twehner/ - mein Erstling btw., einige Sachen sind vielleicht noch nicht so optimal.

Vielen Dank schonmal und Grüße,

Thomas[/code]
__________________
\"Computer games don\'t affect kids; I mean if Pac-Man affected us as kids, we\'d all be running around in darkened rooms, munching magic pills and listening to repetitive electronic music.\" Kristian Wilson, Nintendo Inc., 1989.
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Anfänger: Positionierung. xam CSS 3 19.05.2012 15:18
joomla template wrock CSS 2 06.04.2012 20:24
ff ie8 negativer margin - HILFE!!!!!! nixchecker CSS 14 07.02.2012 17:20
Brauche Hilfe: Schwarzes Nichts Zwox CSS 10 19.11.2010 17:53
Float-Reihenfolge? wolf1985 CSS 0 21.08.2008 02:35


Alle Zeitangaben in WEZ +2. Es ist jetzt 19:40 Uhr.