zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > (X)HTML
Seite neu laden XHTML 1.0 transitional / Firefox CSS Probleme

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 21.01.2005, 14:23
Professional
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 25.06.2004
Ort: Wuppertal
Beiträge: 269
SimonWpt befindet sich auf einem aufstrebenden Ast
Standard XHTML 1.0 transitional / Firefox CSS Probleme

Hallo zusammen,

irgendwie fuchst es mich folgende Website:

http://www.bergischer-gruenderstammtisch.de

.htaccess
Code:
RewriteEngine on
RewriteBase /
RewriteCond %{HTTP_ACCEPT} application/xhtml\+xml
RewriteCond %{HTTP_ACCEPT} !application/xhtml\+xml\s*;\s*q=0
RewriteCond %{REQUEST_URI} \.html$
RewriteCond %{THE_REQUEST} HTTP/1\.1
RewriteRule .* - [T=application/xhtml+xml]
Bei Firefox treten Darstellungsfehler auf. Dort verschwinden das Hintergrundbild und es gibt einen Versatz am Kopf. In Opera gibt es nur den Versatz. IE stellt die Site dank dank content-type: application/html richtig dar.

Wieso?

Danke

Bertram
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 21.01.2005, 14:30
Benutzerbild von Tapsiturtle
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 22.07.2004
Beiträge: 196
Tapsiturtle befindet sich auf einem aufstrebenden Ast
Standard

Es wär von Vorteil wenn du den meta tag
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
rausnimmst.
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 21.01.2005, 14:43
Benutzerbild von Boris
Tanzender Webentwickler
XHTMLforum-Kenner
 
Registriert seit: 29.07.2004
Ort: Kornwestheim / Stuttgart
Beiträge: 4.930
Boris ist ein sehr geschätzer MenschBoris ist ein sehr geschätzer MenschBoris ist ein sehr geschätzer Mensch
Standard

Hm, bei mir funktioniert dieser xhtml/xml check über die .htaccess anscheinend nicht - gibt es mehr Informationen dazu?
__________________
My software never has bugs. It just develops random features ...

» DevShack - die Website des freien Webentwicklers Boris Bojic
Mit Zitat antworten
  #4 (permalink)  
Alt 21.01.2005, 14:55
Professional
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 25.06.2004
Ort: Wuppertal
Beiträge: 269
SimonWpt befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von Adagio
Hm, bei mir funktioniert dieser xhtml/xml check über die .htaccess anscheinend nicht - gibt es mehr Informationen dazu?
Was funktioniert genau nicht? Den Trackback zur htaccess gibt es hier:

http://meiert.com/de/releases/20041004/

Es scheint auf jeden Fall ein Float-Problem zu sein

Liebe Grüße


Bertram
Mit Zitat antworten
  #5 (permalink)  
Alt 21.01.2005, 14:56
Professional
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 25.06.2004
Ort: Wuppertal
Beiträge: 269
SimonWpt befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von Tapsiturtle
Es wär von Vorteil wenn du den meta tag
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
rausnimmst.
Kann ich wegen dem IE nicht. Das Meta-Tag produziert aber nicht den Fehler...

Liebe Grüße


Bertram
Mit Zitat antworten
  #6 (permalink)  
Alt 21.01.2005, 15:00
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 18.01.2005
Beiträge: 696
wahsaga befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von SimonWpt
Zitat:
Zitat von Tapsiturtle
Es wär von Vorteil wenn du den meta tag
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
rausnimmst. ;)
Kann ich wegen dem IE nicht.
wieso?

Zitat:
Das Meta-Tag produziert aber nicht den Fehler...
da wäre ich mir nicht so sicher - denn der steht ja im wiederspruch zur serverseitigen angabe von Content-type=application/xhtml+xml per response-header ...
Mit Zitat antworten
  #7 (permalink)  
Alt 21.01.2005, 15:10
Benutzerbild von Boris
Tanzender Webentwickler
XHTMLforum-Kenner
 
Registriert seit: 29.07.2004
Ort: Kornwestheim / Stuttgart
Beiträge: 4.930
Boris ist ein sehr geschätzer MenschBoris ist ein sehr geschätzer MenschBoris ist ein sehr geschätzer Mensch
Standard

Zitat:
Zitat von SimonWpt
Zitat:
Zitat von Adagio
Hm, bei mir funktioniert dieser xhtml/xml check über die .htaccess anscheinend nicht - gibt es mehr Informationen dazu?
Was funktioniert genau nicht? Den Trackback zur htaccess gibt es hier:
Hab den Fehler gefunden. Ich hatte in meinem PHP-Skript noch das drin stehen:

header("Content-type: text/html; charset=utf-8");

EDIT: Geht doch noch immer nicht - schau selbst:
http://ballettmodel-eva.de/

Und die Codierung wird auch nicht auf UTF-8 gestellt ... hmpf.
__________________
My software never has bugs. It just develops random features ...

» DevShack - die Website des freien Webentwicklers Boris Bojic
Mit Zitat antworten
  #8 (permalink)  
Alt 21.01.2005, 15:16
Benutzerbild von Boris
Tanzender Webentwickler
XHTMLforum-Kenner
 
Registriert seit: 29.07.2004
Ort: Kornwestheim / Stuttgart
Beiträge: 4.930
Boris ist ein sehr geschätzer MenschBoris ist ein sehr geschätzer MenschBoris ist ein sehr geschätzer Mensch
Standard

Noch schlimmer - der IE will es als Datei runterladen (?!?).
__________________
My software never has bugs. It just develops random features ...

» DevShack - die Website des freien Webentwicklers Boris Bojic
Mit Zitat antworten
  #9 (permalink)  
Alt 21.01.2005, 15:19
Professional
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 25.06.2004
Ort: Wuppertal
Beiträge: 269
SimonWpt befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von wahsaga
Zitat:
Kann ich wegen dem IE nicht.
wieso?
Weil der IE die Seite als html erhält und dann UTF8 nicht darstellen würde

Liebe Grüße


Bertram
Mit Zitat antworten
Sponsored Links
  #10 (permalink)  
Alt 21.01.2005, 15:22
Professional
XHTMLforum-Mitglied
Thread-Ersteller
 
Registriert seit: 25.06.2004
Ort: Wuppertal
Beiträge: 269
SimonWpt befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von Adagio
Noch schlimmer - der IE will es als Datei runterladen (?!?).
Das macht er bei content-typehtml, weil er xhtml nicht richtig kann. Siehe auch meinen Link auf dein Posting.

Liebe Grüße


Bertram
Mit Zitat antworten
Sponsored Links
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Sitecheck - Problem mit CSS und Darstellung mit Firefox muijschen Site- und Layoutcheck 2 27.07.2008 12:16
XHTML 1.0 strict: interpretation von alt und title (IMG) vom IE7, Opera und Firefox braindead (X)HTML 5 11.03.2007 16:57
XHTML 1.0 Transitional VS. Strict Despairing (X)HTML 24 07.06.2006 20:07
css, height: 100%, border, firefox und andere Probleme cynocephalus CSS 4 13.08.2005 17:25
Probleme mit XHTML und CSS Design un dem IE 5.0/5.5 plubird CSS 1 19.02.2004 21:01


Alle Zeitangaben in WEZ +2. Es ist jetzt 03:59 Uhr.