zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > (X)HTML
Seite neu laden IE igoniert Styles aus externer CSS in <FORM> und utf-

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 22.10.2004, 13:33
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.10.2004
Beiträge: 3
tbienk befindet sich auf einem aufstrebenden Ast
Standard IE igoniert Styles aus externer CSS in <FORM> und utf-

Hallo,

ein seltsames Phänomen raubt mir den Nerv:

Wenn ich utf-8 codiere werden Style-Angaben im IE aus externen Stylesheet im form ignoriert:

IE6, XPSP2 -> http://www.pharmaline.de/projekte/no...da/index1.html
Screenshot (4kb) unter http://www.pharmaline.de/projekte/no.../iemitutf8.gif
http://www.pharmaline.de/projekte/no...osollssein.gif

ich hab das nur beim IE nachvollziehen können. Wenn man manuell im IE auf eine andere Codierung umstellt (ISO/Windows), siehts auch aus wie bei allen anderen.

lustig sowas. Wenn ich übrigens direkt im html mit style="..." arbeite,
werden die formatierungen vom ie akzeptiert - frage mich woran das nun wieder liegen kann.
*grübel*

timo
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 22.10.2004, 14:29
Benutzerbild von toscho
Perplexifikator
XHTMLforum-Kenner
 
Registriert seit: 22.05.2004
Ort: Halle/Saale
Beiträge: 1.566
toscho sorgt für eine eindrucksvolle Atmosphäretoscho sorgt für eine eindrucksvolle Atmosphäre
Standard

Das kann unmöglich mit der Kodierung zusammenhängen.
Mach mal folgendes, um alle Fehlerquellen auszuschließen:
• Nimm alles aus dem HTML-Dokument und dem Stylesheet, was mit dem Problem nichts zu tun hat.
• Kodiere auch dein Stylesheet in UTF-8, gib diese Kodierung im HTTP-Header und per @charset-Regel an.
• Laß um die Kommentarenden immer einen Leerraum, also /* Kommentar */, nicht /*Kommentar*/.

Dann gib uns die URL des kurzen Testdokuments.

Code:
<meta http-equiv="Content-Type" content="application/xhtml+xml; charset=UTF-8" />
Lustig. Was soll das bewirken?

Gruß
Thomas
__________________
toscho.de
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 22.10.2004, 15:31
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.10.2004
Beiträge: 3
tbienk befindet sich auf einem aufstrebenden Ast
Standard

so, alles ausprobiert:
Problem ist gelöst. Styledatei in Notetab geöffnet und die Datei
als "DOS/ASCII" gespeichert - das wars. Wie das Problem zustandekam, keine Ahnung. Evtl. durch Copy&Paste in Topstyle...

Vielen Dank für deinen Tipp!

timo

Zitat:
Zitat von toscho
Lustig. Was soll das bewirken?
-> http://schneegans.de/tips/apache-xhtml/
Mit Zitat antworten
  #4 (permalink)  
Alt 22.10.2004, 16:34
Benutzerbild von magick
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 05.09.2004
Ort: Hamburg
Beiträge: 302
magick befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von tbienk
Du lieferst deine Seite trotzdem als text/html aus --> nochmal ganz durchlesen bitte
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Formularfelder CSS - Styles mit Firefox fuhrheiner CSS 7 21.03.2006 10:13
Styles mehrerer Seiten in einer css Datei? manuu CSS 5 07.02.2006 13:25
CSS Styles eingebettet in html stabmixer CSS 5 22.06.2005 11:07
CSS Styles werden nicht schnell genug geladen chrh CSS 5 14.04.2005 10:48
Externer Link bei CSS menü brenman (X)HTML 4 06.04.2005 18:26


Alle Zeitangaben in WEZ +2. Es ist jetzt 02:48 Uhr.