zurück zur Startseite
  


Zurück XHTMLforum > (X)HTML und CSS > CSS
Seite neu laden Unerwünschter Zeilenumbruch bei Links im IE

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 11.07.2004, 17:32
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.07.2004
Beiträge: 4
TomLe befindet sich auf einem aufstrebenden Ast
Standard Unerwünschter Zeilenumbruch bei Links im IE

Guten Tag, zusammen!

Ich bin als CSS-Neuling mit der Erstellung einer Kongress-website befasst und habe versucht, die Tabellenkonstruktion durch CSS zu ersetzen (arbeite mit Golive CS auf Macintosh). Ich war total begeistert, bis ich mir die Seite auf IE angesehen habe - klappt bei Mac und Windows nicht. Problem: Ein Hyperlink innerhalb des Textes führt zu einem unerwünschten Zeilenumbruch direkt nach dem Link (Beispielseite: http://www.efta2004.de/programm/sm01-13.html#sm01). Komisch: Lösche ich die Hintergrundfarbe, ist das Problem weg.

Für einen Tipp wäre ich dankbar

Tom
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 11.07.2004, 17:50
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 24.05.2004
Beiträge: 1.176
terrikay befindet sich auf einem aufstrebenden Ast
Standard

Ich hab zwar die Stelle mit den hüpfenden Links nicht gefunden, aber ich vermute, dass Du auf diesen Bug gestoßen bist: http://www.fabrice-pascal.de/bugbase/springendelinks/

Und nochwas: im IE Spreizen sich die Links beim Hovern so seltsam. Das liegt daran, dass der IE sehr empfindlich auf die richtige Reihenfolge der Links besteht:

a:hover
a:visited
a:hover
a:active

Und a:hover:visited gibt es meistens Wissens nach nicht.
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 11.07.2004, 18:13
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.07.2004
Beiträge: 4
TomLe befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von terrikay
Ich hab zwar die Stelle mit den hüpfenden Links nicht gefunden, aber ich vermute, dass Du auf diesen Bug gestoßen bist: http://www.fabrice-pascal.de/bugbase/springendelinks/

Und nochwas: im IE Spreizen sich die Links beim Hovern so seltsam. Das liegt daran, dass der IE sehr empfindlich auf die richtige Reihenfolge der Links besteht:

a:hover
a:visited
a:hover
a:active

Und a:hover:visited gibt es meistens Wissens nach nicht.


Hallo,

vielen Dank für die Antwort.

Meine Links springen aber nicht, sondern ich habe einen Zeilenumbruch statt fortlaufendem Text, sobald ich einen Namen verlinke.

:visited:hover habe ich irgendwo gelesen und eingefügt, weil der Link nur beim ersten hovern hervorgehoben wurde und nach dem Klicken eines Links nicht mehr. funktioniert jedenfalls.
Mit Zitat antworten
  #4 (permalink)  
Alt 11.07.2004, 18:57
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 11.07.2004
Beiträge: 106
come@death befindet sich auf einem aufstrebenden Ast
Standard

aber selbstverständlich gibt es a:hover:visited .. das tritt ein, wenn beide pseudo-klassen gleichzeitig auftreten - allerdings is dieser ********************* IE nicht fähig sowas darzustellen.
Mit Zitat antworten
  #5 (permalink)  
Alt 11.07.2004, 20:48
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.07.2004
Beiträge: 4
TomLe befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von come@death
aber selbstverständlich gibt es a:hover:visited .. das tritt ein, wenn beide pseudo-klassen gleichzeitig auftreten - allerdings is dieser ********************* IE nicht fähig sowas darzustellen.
Danke für den Hinweis. Allerdings bin ich nicht sicher, ob mein Problem etwas mit der Definition der Links zu tun hat oder mit dem CSS-Code. Wie gesagt, alle Browser funktionieren bestens, nur IE bringts nicht. What to do?
Mit Zitat antworten
  #6 (permalink)  
Alt 11.07.2004, 22:04
Erfahrener Benutzer
XHTMLforum-Kenner
 
Registriert seit: 24.05.2004
Beiträge: 1.176
terrikay befindet sich auf einem aufstrebenden Ast
Standard

Probier doch bitte erst einmal aus, sämtliche Links in diese Reihenfolge zu bringen:

a:link
a:visited
a:hover
a:active

Wenn es dann nicht geht, dann zerlege bitte Deinen Code, mach eine kurze Datei mit Problem und poste den Quellcode hier.
Mit Zitat antworten
  #7 (permalink)  
Alt 12.07.2004, 06:48
Neuer Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 11.07.2004
Beiträge: 4
TomLe befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von terrikay
Probier doch bitte erst einmal aus, sämtliche Links in diese Reihenfolge zu bringen:

a:link
a:visited
a:hover
a:active

Wenn es dann nicht geht, dann zerlege bitte Deinen Code, mach eine kurze Datei mit Problem und poste den Quellcode hier.
Vielen Dank für Deine Hilfe ! An der Reihenfolge der Links lag es übrigens nicht. Ich habe mit CSS-Edit ein ähnliches Stylesheet noch mal dupliziert und es dann mit der gewünschten Hintergrundfarbe belegt - siehe da, plötzlich funktioniert es unter IE. Scheint da noch irgendwelche versteckte Einstellungen zu geben, die im CSS-Editor nicht zu erkennen waren (weder in Golive noch in CSS-Edit).


Gruß
Tom
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
UL als Navigation (inline). Firefox zentriert die Links nicht meccs76 CSS 13 25.10.2008 23:14
DIV immer ganze Breite - normal?!?!? csski CSS 3 02.07.2008 12:20
IE 7 skaliert Links falsch? theonlyandy CSS 16 10.04.2008 10:44
links in externem fenster öffnen... HELP Plz!! NoPlanClan CSS 4 12.01.2004 18:54
Formularbuttons und Links mit CSS gleich gestalten Jürgen CSS 1 18.09.2003 18:33


Alle Zeitangaben in WEZ +2. Es ist jetzt 05:20 Uhr.