zurück zur Startseite
  


Zurück XHTMLforum > Sonstiges > Offtopic
Seite neu laden Was kann das wohl sein? Xhtml, Javascript oder ein Bug?

Antwort
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 01.07.2004, 11:32
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 21.10.2003
Beiträge: 98
PrinzEisenherz befindet sich auf einem aufstrebenden Ast
Standard Was kann das wohl sein? Xhtml, Javascript oder ein Bug?

Mir ist aufgefallen, das der NN7.1 und der Firefox0.9.1 nicht auf <map> bzw. <area> reagieren.

Ich habe folgenden Code auf diesen Seiten
http://www.daddlers-paradise.de/inde...cht&auswahl=20
http://www.daddlers-paradise.de/inde...lan&auswahl=20

Code:
<div style="position:relative; width:560px; margin:auto;">[img]http://www.daddlers-paradise.de/grafik/deutschland6.gif[/img]
<map id="Dellien">
<area shape="circle" coords="8,8,8" href="http://www.daddlers-paradise.de/index.php?ziel=News&amp;auswahl=20" alt="" onmouseover="Partyinfo('03.09.2004', '05.09.2004', 'Dellien','48','32','13',1);" onmouseout="Partyinfo('','','','','','',0);" />
</map>
[img]http://www.daddlers-paradise.de/grafik/iconparty3.gif[/img]
</div>
Der IE6 und der Opera 7.23 zeigen den onmouseover-Effekt an und lassen sich auch auf den Link weiterleiten.
Der NN7.1 und der Firefox0.9.1 ignorieren so ziehmlich alles, was es da nur gibt.
Das der onmouseover-Effekt nicht geht, damit habe ich ja gerechnet, aber das nicht mal der Link funktioniert schockt mich schon etwas.

Ich habe dann den Link durch

Code:
onclick="location.href='http://www.daddlers-paradise.de/index.php?ziel=News&amp;auswahl=20';"
ersetzt und im href ein # angegeben. Das hat dann bei allen nicht funktioniert. Wenn ich das href="#" weg nehme gehts wieder im IE und im Opera, aber wieder nicht im NN und Firefox.

Was ist denn das jetzt für ein Prob?
Liegt das an meinem Doctype?

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
Oder hat das eine ganz andere Begründung?
__________________
PrinzEisenherz

www.daddlers-paradise.de
Lan-Partys
Mit Zitat antworten
Sponsored Links
  #2 (permalink)  
Alt 01.07.2004, 11:42
raf raf ist offline
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 03.03.2004
Beiträge: 260
raf befindet sich auf einem aufstrebenden Ast
Standard

Hi,

frag doch mal hier nach:

http://firefox.stw.uni-duisburg.de/forum/
__________________
Ein Gedanke... unendliche Verbindungen
Mit Zitat antworten
Sponsored Links
  #3 (permalink)  
Alt 01.07.2004, 11:48
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 21.10.2003
Beiträge: 98
PrinzEisenherz befindet sich auf einem aufstrebenden Ast
Standard

Hey, danke. Das werde ich gleich mal da posten.

Hat hier eigendlich jeder das gleiche Forum
__________________
PrinzEisenherz

www.daddlers-paradise.de
Lan-Partys
Mit Zitat antworten
  #4 (permalink)  
Alt 01.07.2004, 11:49
raf raf ist offline
Erfahrener Benutzer
XHTMLforum-Mitglied
 
Registriert seit: 03.03.2004
Beiträge: 260
raf befindet sich auf einem aufstrebenden Ast
Standard

ggg das Gleiche?

Keine Ahnung ich habe verschiedene ggg
__________________
Ein Gedanke... unendliche Verbindungen
Mit Zitat antworten
  #5 (permalink)  
Alt 01.07.2004, 19:08
Benutzer
neuer user
Thread-Ersteller
 
Registriert seit: 21.10.2003
Beiträge: 98
PrinzEisenherz befindet sich auf einem aufstrebenden Ast
Standard

Ich habe den Fehler gefunden.

Leider...leider ist der Firefox daran schuld.

Laut xhtml gehört ja in den Tag <map> nicht mehr das Attribut "name" sondern das "id".

Das versteht der Firefox an dieser Stelle nicht. Der NN7.1 übrigens auch nicht. Auch wenn ich dann keinen validen Code habe, habe ich dort erstmal das Attribut "name" stehen gelassen.

Ich hab aber glaube ich irgendwo gelesen, das man in solchen Fällen beiden eintragen kann.

Ist das richtig?
__________________
PrinzEisenherz

www.daddlers-paradise.de
Lan-Partys
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
XHTML Table Border Bug?!?! homy (X)HTML 6 30.10.2012 17:02
Javascript will nicht unter XHTML Wyqer Javascript & Ajax 15 14.03.2009 01:19
XHTML + iframes +javascript flying sheep Javascript & Ajax 7 22.11.2007 20:47
XHTML und javascript (document.submit();) daemonrob (X)HTML 12 25.06.2007 16:46
XHTML und JavaScript funktionieren nicht zusammen?! hyperterminal (X)HTML 2 22.08.2005 20:16


Alle Zeitangaben in WEZ +2. Es ist jetzt 14:05 Uhr.