zurück zur Startseite
  


Zurück XHTMLforum > Sonstiges > Fragen, Konstruktive Kritik, Lob / Bekanntmachungen > http://csskueche.xhtmlforum.de/
Seite neu laden http://csskueche.xhtmlforum.de/index.php?css=1 -Steffen-

 
 
LinkBack Themen-Optionen Ansicht
  #1 (permalink)  
Alt 17.05.2005, 20:35
Philippp
Gast
Thread-Ersteller
 
Beiträge: n/a
Standard http://csskueche.xhtmlforum.de/index.php?css=1 -Steffen-

http://csskueche.xhtmlforum.de/index.php?css=1

- Die halbtransparentz gefällt mir. Nur hätte ich sie mit png realisiert. Der IE ist eh draußen .
- CSS Code gefällt mir. Alles schön klein gehalten. Shortcuts benutzt etc. .
- @charset "utf-8"; laut Terry guter Stil. Von daher gut .
- Lauter Angaben die ich noch nie verwendet habe (direction: rtl;, content : "Koch: "; etc.)

Alles in allem eine Interesannte CSS.
Gruß, Philippp
Sponsored Links
  #2 (permalink)  
Alt 17.05.2005, 21:13
Neuer Benutzer
neuer user
 
Registriert seit: 11.05.2005
Beiträge: 23
steffen befindet sich auf einem aufstrebenden Ast
Standard

huch, philippp hat schon mit meinem angefangen

Aufgrund von Zeitmangel habe ich gar keine Rücksicht auf die unterschiedlichen Absätze genommen.

Ausgangspunkt war die Assoziation von Küche mit Gemütlichkeit, und da habe ich sofort an Kamin gedacht.
Glücklicherweise habe ich ein sehr schönes Foto mit Kamin gefunden.
Damit war die Farbgebung da. Als Hintergrund habe ich die typischen Kacheln ebenfalls in Braun/Rottönen genommen.
Die Transparenz habe ich gewählt, um die Kacheln besser zu integrieren. Ich hätte auch lieber mit transparenten Bildern gearbeitet, aber durch den Verlaufshintergrund und dem Zeitmangel hab ich mich da schwer getan.
__________________
*** bloody greenhorn ***
Hommingberger Gepardenforelle
Sponsored Links
  #3 (permalink)  
Alt 17.05.2005, 23:25
Anonymous
Gast
 
Beiträge: n/a
Standard

mir gefällt das layout nicht so gut.

die grafiken zwischen den absätzen finde ich kitschig.
auch die anderen grafiken gefallen mir nicht sonderlich.
die hintergrundgrafik.

von der opacity habe ich als oper-user ooch nischt.

@charset "utf-8"; warum ist das gut?

dein style ist gut verständlich.
  #4 (permalink)  
Alt 18.05.2005, 07:21
Benutzerbild von derHund
durstiges Tier
XHTMLforum-Mitglied
 
Registriert seit: 16.09.2004
Beiträge: 870
derHund befindet sich auf einem aufstrebenden Ast
Standard

Zitat:
Zitat von legman
@charset "utf-8"; warum ist das gut?
das braucht man, um ... ich habe es verwendet, weil ... habs vergessen es war aber definitiv notwenig, um ... tja.

laut toscho ists doch vorallem für offline-versionen interessant?
__________________
Die Zeit hat ihre Kinder längst gefressen: hund (back in black) | ??? | ??? | ...
  #5 (permalink)  
Alt 18.05.2005, 08:58
Benutzerbild von toscho
Perplexifikator
XHTMLforum-Kenner
 
Registriert seit: 22.05.2004
Ort: Halle/Saale
Beiträge: 1.566
toscho sorgt für eine eindrucksvolle Atmosphäretoscho sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von legman
@charset "utf-8"; warum ist das gut?
Damit Browser und potentielle Betrachter unabhängig vom Transportprotokoll wissen, wie das Stylesheet kodiert wurde.
In diesem Fall ist es sogar angebracht, denn der Server verrät die Kodierung leider nicht (wer muß sich jetzt schämen?).
__________________
toscho.de
  #6 (permalink)  
Alt 18.05.2005, 12:08
Neuer Benutzer
neuer user
 
Registriert seit: 11.05.2005
Beiträge: 23
steffen befindet sich auf einem aufstrebenden Ast
Standard

genau aus dem von Toscho genannten Grund habe ich diese Anweisung aufgenommen.
Da die Quelldatei auch utf-8 kodiert war, habe ich es als konsequent angesehen, das auch mit der zugehörigen CSS zu machen.
Daher ist die Angabe zwingend, damit die CSS auch richtig interpretiert wird.

Ein Bug habe ich im Menü festgestellt und der ist mir nicht ganz erklärlich.
Ich habe im hover ein :before und :after eingesetzt. before ist ein gelbes Sternchen und after ein weisses (die Farbunterschiede gehören eher in die kategorie "überflüssige Spielerei").
Nun erscheint dieser Content nur sporadisch. Bei meiner auf meinem Server getesteten Version (incl. php-Script für die Header) funktionierte das einwandfrei, auf diesem Server nicht. Vielleicht kann mir ja jemand auf die Sprünge helfen.
__________________
*** bloody greenhorn ***
Hommingberger Gepardenforelle
  #7 (permalink)  
Alt 18.05.2005, 22:40
Anonymous
Gast
 
Beiträge: n/a
Standard

Zitat:
Zitat von toscho
Zitat:
Zitat von legman
@charset "utf-8"; warum ist das gut?
Damit Browser und potentielle Betrachter unabhängig vom Transportprotokoll wissen, wie das Stylesheet kodiert wurde.
In diesem Fall ist es sogar angebracht, denn der Server verrät die Kodierung leider nicht (wer muß sich jetzt schämen?).
demnach dürfte es ja zu problemen mit den styles geben, die keine utf-8 codierung haben?
niemand muß sich schämen!

wieso hast du eigentlich nicht mitgemacht?
  #8 (permalink)  
Alt 18.05.2005, 22:56
Benutzerbild von toscho
Perplexifikator
XHTMLforum-Kenner
 
Registriert seit: 22.05.2004
Ort: Halle/Saale
Beiträge: 1.566
toscho sorgt für eine eindrucksvolle Atmosphäretoscho sorgt für eine eindrucksvolle Atmosphäre
Standard

Zitat:
Zitat von legman
demnach dürfte es ja zu problemen mit den styles geben, die keine utf-8 codierung haben?
Zumindest mit solchen, bei denen die Kodierung geheim bleibt. Und das tut es ja auch: Sieh dir Terrys Stylesheet mal im Browser an, oder den Generated Content des Hundes (am Seitenende bei :hover): Da zeigt ein richtiger Browser nur das Ersatzzeichen für invalide Zeichen, aber nicht das, was sich die Autoren vorgestellt haben.
Solange das Stylesheet vollständig ACSII-kompatibel bleibt, wie bei Steffen, spielt es keine Rolle, aber wenn später mal jemand etwas bearbeitet, kann – und wird es vermutlich – schief gehen. Deshalb beginnt man ein Stylesheet am besten immer mit der @charset-Regel.
Zitat:
wieso hast du eigentlich nicht mitgemacht?
Weil ich a) keine Zeit habe und mir b) der Quellcode und c) der Text nicht zusagen.
__________________
toscho.de
  #9 (permalink)  
Alt 19.05.2005, 00:07
Anonymous
Gast
 
Beiträge: n/a
Standard

ich sehe nur das das ü nicht dargestellt wird. dies liegt am fehlenden utf-8? ich habe mein zeichnekodierung im browser (opera) auf automatisch gestellt.

was soll mir an terrys css auffallen? ich sehe das sie kein utf-8 verwendet?
Sponsored Links
  #10 (permalink)  
Alt 19.05.2005, 01:48
Neuer Benutzer
neuer user
 
Registriert seit: 11.05.2005
Beiträge: 23
steffen befindet sich auf einem aufstrebenden Ast
Standard

das das ü nicht richtig dargestellt wird, liegt aber daran, das die Datei nicht utf-8 gespeichert wurde, sonst wäre das korrekt. Das ist auch etwas, wo man immer drauf achten muss, wenn man utf-8 schreibt.
__________________
*** bloody greenhorn ***
Hommingberger Gepardenforelle
Sponsored Links
 

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus



Alle Zeitangaben in WEZ +2. Es ist jetzt 18:17 Uhr.